aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2011-07-27 15:19:16 +0800
committerkuriyama <kuriyama@FreeBSD.org>2011-07-27 15:19:16 +0800
commit1b5a2e1c1da9c1fc83db2d276953f52c6b130ef3 (patch)
treeab6dd58ee085503005fcacda93dc969e485841d0 /devel
parent7942ce9872295aeffbcbc5fe117d5b19a8316be2 (diff)
downloadfreebsd-ports-gnome-1b5a2e1c1da9c1fc83db2d276953f52c6b130ef3.tar.gz
freebsd-ports-gnome-1b5a2e1c1da9c1fc83db2d276953f52c6b130ef3.tar.zst
freebsd-ports-gnome-1b5a2e1c1da9c1fc83db2d276953f52c6b130ef3.zip
Validation::Class is a different approach to data validation, it
attempts to simplify and centralize data validation rules to ensure DRY (don't repeat yourself) code. The primary intent of this module is to provide a simplistic validation work-flow and promote code (validation) reuse. WWW: http://search.cpan.org/dist/Validation-Class/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Validation-Class/Makefile27
-rw-r--r--devel/p5-Validation-Class/distinfo2
-rw-r--r--devel/p5-Validation-Class/pkg-descr7
-rw-r--r--devel/p5-Validation-Class/pkg-plist5
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 95f0b672415a..5216db446565 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2500,6 +2500,7 @@
SUBDIR += p5-VCS
SUBDIR += p5-VCS-CVS
SUBDIR += p5-VCS-Lite
+ SUBDIR += p5-Validation-Class
SUBDIR += p5-Variable-Magic
SUBDIR += p5-Version-Requirements
SUBDIR += p5-Want
diff --git a/devel/p5-Validation-Class/Makefile b/devel/p5-Validation-Class/Makefile
new file mode 100644
index 000000000000..fde5a09143d4
--- /dev/null
+++ b/devel/p5-Validation-Class/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: Validation::Class
+# Date created: 27 Jul 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Validation-Class
+PORTVERSION= 0.111912
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:AWNCORP
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for centralized input validation for any application
+
+RUN_DEPENDS= \
+ p5-Array-Unique>0:${PORTSDIR}/devel/p5-Array-Unique \
+ p5-Moose>0:${PORTSDIR}/devel/p5-Moose
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Validation::Class.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Validation-Class/distinfo b/devel/p5-Validation-Class/distinfo
new file mode 100644
index 000000000000..a0c938f3fef2
--- /dev/null
+++ b/devel/p5-Validation-Class/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Validation-Class-0.111912.tar.gz) = 50c7adc78efbadbe2029b2a2e5adf071b34f9d2f55c34fbd5bccc2215517b577
+SIZE (Validation-Class-0.111912.tar.gz) = 26008
diff --git a/devel/p5-Validation-Class/pkg-descr b/devel/p5-Validation-Class/pkg-descr
new file mode 100644
index 000000000000..2153284cd269
--- /dev/null
+++ b/devel/p5-Validation-Class/pkg-descr
@@ -0,0 +1,7 @@
+Validation::Class is a different approach to data validation, it
+attempts to simplify and centralize data validation rules to ensure
+DRY (don't repeat yourself) code. The primary intent of this module is
+to provide a simplistic validation work-flow and promote code
+(validation) reuse.
+
+WWW: http://search.cpan.org/dist/Validation-Class/
diff --git a/devel/p5-Validation-Class/pkg-plist b/devel/p5-Validation-Class/pkg-plist
new file mode 100644
index 000000000000..c974ecec653a
--- /dev/null
+++ b/devel/p5-Validation-Class/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Validation/Class/.packlist
+%%SITE_PERL%%/Validation/Class.pm
+@dirrmtry %%SITE_PERL%%/Validation
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Validation/Class
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Validation