aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-10-29 14:32:40 +0800
committerwen <wen@FreeBSD.org>2010-10-29 14:32:40 +0800
commit1eb0d06f604e00a0b837a4debc1888175d33c1cf (patch)
tree1ac59d563d7ec5473e71d261410f3bc08d5a82fe /devel
parenta53841f4836cd295ae9c6007b66daa98cf3f9d26 (diff)
downloadfreebsd-ports-gnome-1eb0d06f604e00a0b837a4debc1888175d33c1cf.tar.gz
freebsd-ports-gnome-1eb0d06f604e00a0b837a4debc1888175d33c1cf.tar.zst
freebsd-ports-gnome-1eb0d06f604e00a0b837a4debc1888175d33c1cf.zip
perlbrew is a program to automate the building and
installation of perl in the users HOME. At the moment, it installs everything to ~/perl5/perlbrew, and requires you to tweak your PATH by including a bashrc/cshrc file it provides. You then can benefit from not having to run 'sudo' commands to install cpan modules because those are installed inside your HOME too. It's a completely separate perl environment. WWW: http://search.cpan.org/dist/App-perlbrew/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-perlbrew/Makefile28
-rw-r--r--devel/p5-perlbrew/distinfo3
-rw-r--r--devel/p5-perlbrew/pkg-descr14
-rw-r--r--devel/p5-perlbrew/pkg-plist7
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d0f4ee79b36d..692e97b0ce3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2401,6 +2401,7 @@
SUBDIR += p5-namespace-clean
SUBDIR += p5-orz
SUBDIR += p5-parent
+ SUBDIR += p5-perlbrew
SUBDIR += p5-pip
SUBDIR += p5-prefork
SUBDIR += p5-reaper
diff --git a/devel/p5-perlbrew/Makefile b/devel/p5-perlbrew/Makefile
new file mode 100644
index 000000000000..bd05c37b5f81
--- /dev/null
+++ b/devel/p5-perlbrew/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-perlbrew
+# Date created: 2010-10-20
+# Whom: ports@c0decafe.net <ports@c0decafe.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= perlbrew
+PORTVERSION= 0.10
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/G/GU/GUGOD
+PKGNAMEPREFIX= p5-
+DISTNAME= App-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= ports@c0decafe.net
+COMMENT= Perl Environment manager
+
+BUILD_DEPENDS= p5-File-Path-Tiny>=0.1:${PORTSDIR}/devel/p5-File-Path-Tiny\
+ p5-HTTP-Lite>=2.2:${PORTSDIR}/www/p5-HTTP-Lite
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE=yes
+
+MAN1= perlbrew.1
+MAN3= App::perlbrew.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-perlbrew/distinfo b/devel/p5-perlbrew/distinfo
new file mode 100644
index 000000000000..31cc25262652
--- /dev/null
+++ b/devel/p5-perlbrew/distinfo
@@ -0,0 +1,3 @@
+MD5 (App-perlbrew-0.10.tar.gz) = 0255735028dd865f4e490629d6925ff7
+SHA256 (App-perlbrew-0.10.tar.gz) = 07a85f42f2f1fe97c14e33654a1f383c720519149e96fb21ac40c01c9e27ffbc
+SIZE (App-perlbrew-0.10.tar.gz) = 35885
diff --git a/devel/p5-perlbrew/pkg-descr b/devel/p5-perlbrew/pkg-descr
new file mode 100644
index 000000000000..d94e6831a88d
--- /dev/null
+++ b/devel/p5-perlbrew/pkg-descr
@@ -0,0 +1,14 @@
+perlbrew is a program to automate the building and
+installation of perl in the users HOME.
+
+At the moment, it installs everything to ~/perl5/perlbrew,
+and requires you to tweak your PATH by including
+a bashrc/cshrc file it provides.
+
+You then can benefit from not having to run 'sudo' commands
+to install cpan modules because those are installed inside
+your HOME too.
+
+It's a completely separate perl environment.
+
+WWW: http://search.cpan.org/dist/App-perlbrew/
diff --git a/devel/p5-perlbrew/pkg-plist b/devel/p5-perlbrew/pkg-plist
new file mode 100644
index 000000000000..117a5784c7d2
--- /dev/null
+++ b/devel/p5-perlbrew/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+bin/perlbrew
+%%SITE_PERL%%/App/perlbrew.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/perlbrew/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/perlbrew
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App
+@dirrmtry %%SITE_PERL%%/App