aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2013-02-05 20:07:28 +0800
committermakc <makc@FreeBSD.org>2013-02-05 20:07:28 +0800
commit21b783c8d088a7345bda426c5ad3f69fcca8aae1 (patch)
treea7a5e14e77d35cedddfcab172260a21ee81d6560 /devel
parentac3df3185be70b0c7e1d2142cbac10183b074c0a (diff)
downloadfreebsd-ports-gnome-21b783c8d088a7345bda426c5ad3f69fcca8aae1.tar.gz
freebsd-ports-gnome-21b783c8d088a7345bda426c5ad3f69fcca8aae1.tar.zst
freebsd-ports-gnome-21b783c8d088a7345bda426c5ad3f69fcca8aae1.zip
- Convert last kde@ port to new options framework \o/
Diffstat (limited to 'devel')
-rw-r--r--devel/libdbusmenu-qt/Makefile20
1 files changed, 7 insertions, 13 deletions
diff --git a/devel/libdbusmenu-qt/Makefile b/devel/libdbusmenu-qt/Makefile
index d8e8e1e0b0ee..1c2824a7e5b9 100644
--- a/devel/libdbusmenu-qt/Makefile
+++ b/devel/libdbusmenu-qt/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libdbusmenu-qt
-# Date created: 2010-05-10
-# Whom: Dima Panov <fluffy@FreeBSD.org>
-#
+# Created by: Dima Panov <fluffy@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libdbusmenu-qt
PORTVERSION= 0.9.2
@@ -15,23 +11,21 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt4 implementation of the DBusMenu protocol
LICENSE= LGPL20
-LICENSE_FILE= ${WRKSRC}/COPYING
+USE_QT4= dbus gui xml \
+ moc_build qmake_build rcc_build uic_build
FETCH_ARGS= -Fpr
USE_BZIP2= yes
USE_CMAKE= yes
-USE_QT4= dbus gui xml \
- moc_build qmake_build rcc_build uic_build
-USE_LDCONFIG= yes
-
-CMAKE_OUTSOURCE= yes
+CMAKE_OUTSOURCE=yes
MAKE_JOBS_SAFE= yes
+USE_LDCONFIG= yes
-OPTIONS= DOCS "Install API documentation (requires Doxygen)" off
+OPTIONS_DEFINE= DOXYGEN
.include <bsd.port.options.mk>
-.if defined(WITH_DOCS)
+.if ${PORT_OPTIONS:MDOXYGEN}
BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
PORTDOCS= *
CMAKE_ARGS+= -DDOC_INSTALL_DIR:PATH="${DOCSDIR_REL}"