aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-15 05:23:23 +0800
committererwin <erwin@FreeBSD.org>2006-07-15 05:23:23 +0800
commit21fa290ff162d8633b8137f7b73a05d6a3bb6b75 (patch)
tree2bdb1ce890e0757b23861f7ed06a22299a36f212 /devel
parentc6c9e0eb5c8339e6c2a5d54fd73848608a2077d2 (diff)
downloadfreebsd-ports-gnome-21fa290ff162d8633b8137f7b73a05d6a3bb6b75.tar.gz
freebsd-ports-gnome-21fa290ff162d8633b8137f7b73a05d6a3bb6b75.tar.zst
freebsd-ports-gnome-21fa290ff162d8633b8137f7b73a05d6a3bb6b75.zip
Add p5-Clone-Fast 0.90.1, natively copying Perl data structures.
PR: ports/100308 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Clone-Fast/Makefile30
-rw-r--r--devel/p5-Clone-Fast/distinfo3
-rw-r--r--devel/p5-Clone-Fast/pkg-descr21
-rw-r--r--devel/p5-Clone-Fast/pkg-plist8
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b71b0b401c17..3ed5817a065b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -840,6 +840,7 @@
SUBDIR += p5-Class-WhiteHole
SUBDIR += p5-Class-XPath
SUBDIR += p5-Clone
+ SUBDIR += p5-Clone-Fast
SUBDIR += p5-Code-Perl
SUBDIR += p5-Commands-Guarded
SUBDIR += p5-Config-Auto
diff --git a/devel/p5-Clone-Fast/Makefile b/devel/p5-Clone-Fast/Makefile
new file mode 100644
index 000000000000..ff6d8ded0fbc
--- /dev/null
+++ b/devel/p5-Clone-Fast/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: p5-Clone-Fast
+# Date created: 2006-07-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Clone-Fast
+PORTVERSION= 0.90.1
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Clone
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Natively copying Perl data structures
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+PERL_CONFIGURE= yes
+
+MAN3= Clone::Fast.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Clone-Fast/distinfo b/devel/p5-Clone-Fast/distinfo
new file mode 100644
index 000000000000..6caf1f8c552b
--- /dev/null
+++ b/devel/p5-Clone-Fast/distinfo
@@ -0,0 +1,3 @@
+MD5 (Clone-Fast-0.90.1.tar.gz) = 43b3607b71d28c8ab9c96415ae6dcba0
+SHA256 (Clone-Fast-0.90.1.tar.gz) = 2d91d511ee0fe53fb40b02c254fe423a87c665aeede1909241b79f05a5fc9b58
+SIZE (Clone-Fast-0.90.1.tar.gz) = 24582
diff --git a/devel/p5-Clone-Fast/pkg-descr b/devel/p5-Clone-Fast/pkg-descr
new file mode 100644
index 000000000000..17661dee1982
--- /dev/null
+++ b/devel/p5-Clone-Fast/pkg-descr
@@ -0,0 +1,21 @@
+Essentially, this module is a very optimized version of Clone::More.
+By taking advantage of one of Clone::More's 'OPTIMIZATION_HACKS' as
+well as removing all the Pure Perl from the More.pm, I was able to
+gain a lot of speed out of the module. Essentially, though, the core
+of the module is exactly as that of Clone::More.
+
+You will see that by useing Benchmark::cmpthese, I ran a simple
+comparison between Storable::dclone, Clone::More::clone, and
+Clone::Fast::clone. You will (should) begin to see the reason why I
+loaded this module along side of Clone::More.
+
+ Rate Storable Clone::More Clone::Fast
+ Storable 7552/s -- -39% -59%
+ Clone::More 12400/s 64% -- -33%
+ Clone::Fast 18442/s 144% 49% --
+
+For more information relative to the DESCRIPTION of this module, I
+recommend peeking into the POD written for Clone::More (I took more
+time with it ;) )
+
+WWW: http://search.cpan.org/dist/Clone-Fast/
diff --git a/devel/p5-Clone-Fast/pkg-plist b/devel/p5-Clone-Fast/pkg-plist
new file mode 100644
index 000000000000..3486b7f21757
--- /dev/null
+++ b/devel/p5-Clone-Fast/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clone/Fast/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clone/Fast/Fast.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Clone/Fast/Fast.so
+%%SITE_PERL%%/%%PERL_ARCH%%/Clone/Fast.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Clone/Fast
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Clone
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Clone