aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-03-21 01:03:00 +0800
committerbapt <bapt@FreeBSD.org>2013-03-21 01:03:00 +0800
commit24763ad730d8f1d8204c1a9f4f0b32e7fabe05c0 (patch)
treee7e7f2c69d052694a4b45fcef26f27cf2b15b0ee /devel
parenta7c842506c3b02f611688816132c7f0567aaec0e (diff)
downloadfreebsd-ports-gnome-24763ad730d8f1d8204c1a9f4f0b32e7fabe05c0.tar.gz
freebsd-ports-gnome-24763ad730d8f1d8204c1a9f4f0b32e7fabe05c0.tar.zst
freebsd-ports-gnome-24763ad730d8f1d8204c1a9f4f0b32e7fabe05c0.zip
Fix a corner case usage of pkgconf spotted in webkit-gtk3
Reported by: Gustau Pérez i Querol, kwm (both via irc) Tested by: Gustau Pérez i Querol, kwm Obtained from: pkgconf git
Diffstat (limited to 'devel')
-rw-r--r--devel/pkgconf/Makefile2
-rw-r--r--devel/pkgconf/files/patch-pkg.c-222
2 files changed, 23 insertions, 1 deletions
diff --git a/devel/pkgconf/Makefile b/devel/pkgconf/Makefile
index fa1d16249411..222a2a13618e 100644
--- a/devel/pkgconf/Makefile
+++ b/devel/pkgconf/Makefile
@@ -2,7 +2,7 @@
PORTNAME= pkgconf
PORTVERSION= 0.9.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://rabbit.dereferenced.org/~nenolod/distfiles/ \
http://files.etoilebsd.net/pkgconf/
diff --git a/devel/pkgconf/files/patch-pkg.c-2 b/devel/pkgconf/files/patch-pkg.c-2
new file mode 100644
index 000000000000..f376468716da
--- /dev/null
+++ b/devel/pkgconf/files/patch-pkg.c-2
@@ -0,0 +1,22 @@
+diff --git pkg.c pkg.c
+index ed23b47..58eed08 100644
+--- pkg.c
++++ pkg.c
+@@ -461,6 +461,8 @@ pkg_find(const char *name, unsigned int flags)
+ pkg_node_t *n;
+ FILE *f;
+
++ pkg_dir_list_build(flags);
++
+ /* name might actually be a filename. */
+ if (str_has_suffix(name, PKG_CONFIG_EXT))
+ {
+@@ -485,8 +487,6 @@ pkg_find(const char *name, unsigned int flags)
+ }
+ }
+
+- pkg_dir_list_build(flags);
+-
+ PKG_FOREACH_LIST_ENTRY(pkg_dir_list.head, n)
+ {
+ pkg_path_t *pkg_path = n->data;