aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-11-03 06:36:10 +0800
committerpav <pav@FreeBSD.org>2004-11-03 06:36:10 +0800
commit249ab0598c43733516d615d31266d0c7a395363d (patch)
tree9f3b7a313d9479474fb74f7c28ebab581e7ffff5 /devel
parent116287eaf545b6fb72e1f360da6b83efb3eb1c46 (diff)
downloadfreebsd-ports-gnome-249ab0598c43733516d615d31266d0c7a395363d.tar.gz
freebsd-ports-gnome-249ab0598c43733516d615d31266d0c7a395363d.tar.zst
freebsd-ports-gnome-249ab0598c43733516d615d31266d0c7a395363d.zip
Add ocaml-extlib, a complete - yet small - standard library for the OCaml programming langage
PR: ports/73385 Submitted by: Jun Mukai <mukai@jmuk.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ocaml-extlib/Makefile32
-rw-r--r--devel/ocaml-extlib/distinfo2
-rw-r--r--devel/ocaml-extlib/pkg-descr12
-rw-r--r--devel/ocaml-extlib/pkg-plist109
5 files changed, 156 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2bf115336e13..6f5e57bfb8b4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -555,6 +555,7 @@
SUBDIR += oaf
SUBDIR += ocaml-camomile
SUBDIR += ocaml-classes
+ SUBDIR += ocaml-extlib
SUBDIR += ocaml-findlib
SUBDIR += ocaml-pcre
SUBDIR += ocaml-sdl
diff --git a/devel/ocaml-extlib/Makefile b/devel/ocaml-extlib/Makefile
new file mode 100644
index 000000000000..3805fff28a8b
--- /dev/null
+++ b/devel/ocaml-extlib/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: extlib
+# Date created: Nov 2, 2004
+# Whom: mukai
+#
+# $FreeBSD$
+#
+
+PORTNAME= extlib
+PORTVERSION= 1.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ocaml-lib
+PKGNAMEPREFIX= ocaml-
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= mukai@jmuk.org
+COMMENT= A complete - yet small - standard library for OCaml
+
+BUILD_DEPENDS= ocamlc:${PORTSDIR}/lang/ocaml \
+ ocamlfind:${PORTSDIR}/devel/ocaml-findlib
+
+USE_GMAKE= yes
+ALL_TARGET= all opt doc
+DOCSDIR= ${PREFIX}/share/doc/ocaml/${PORTNAME}
+
+post-install:
+.if !defined(NO_PORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ocaml-extlib/distinfo b/devel/ocaml-extlib/distinfo
new file mode 100644
index 000000000000..1b4b88fb6360
--- /dev/null
+++ b/devel/ocaml-extlib/distinfo
@@ -0,0 +1,2 @@
+MD5 (extlib-1.3.tgz) = b98fc222fee229ac6e77439624c0f794
+SIZE (extlib-1.3.tgz) = 71546
diff --git a/devel/ocaml-extlib/pkg-descr b/devel/ocaml-extlib/pkg-descr
new file mode 100644
index 000000000000..c04b2c5382a2
--- /dev/null
+++ b/devel/ocaml-extlib/pkg-descr
@@ -0,0 +1,12 @@
+ExtLib is a project aiming at providing a complete - yet small -
+standard library for the OCaml programming langage. The purpose of
+this library is to add new functions to OCaml Standard Library
+modules, to modify some functions in order to get better performances
+or more safety (tail-recursive) but also to provide new modules which
+should be useful for the average OCaml programmer.
+
+ExtLib is not directly related to OCaml authors (INRIA) although this
+library can be seen as a proposal for inclusion in the official
+distribution.
+
+WWW: http://ocaml-lib.sourceforge.net/
diff --git a/devel/ocaml-extlib/pkg-plist b/devel/ocaml-extlib/pkg-plist
new file mode 100644
index 000000000000..1369f0beac9e
--- /dev/null
+++ b/devel/ocaml-extlib/pkg-plist
@@ -0,0 +1,109 @@
+lib/ocaml/site-lib/extlib/IO.cmi
+lib/ocaml/site-lib/extlib/base64.cmi
+lib/ocaml/site-lib/extlib/bitSet.cmi
+lib/ocaml/site-lib/extlib/dbi.cmi
+lib/ocaml/site-lib/extlib/dllist.cmi
+lib/ocaml/site-lib/extlib/dynArray.cmi
+lib/ocaml/site-lib/extlib/enum.cmi
+lib/ocaml/site-lib/extlib/extHashtbl.cmi
+lib/ocaml/site-lib/extlib/extLib.cmi
+lib/ocaml/site-lib/extlib/extList.cmi
+lib/ocaml/site-lib/extlib/extString.cmi
+lib/ocaml/site-lib/extlib/global.cmi
+lib/ocaml/site-lib/extlib/optParse.cmi
+lib/ocaml/site-lib/extlib/option.cmi
+lib/ocaml/site-lib/extlib/pMap.cmi
+lib/ocaml/site-lib/extlib/refList.cmi
+lib/ocaml/site-lib/extlib/std.cmi
+lib/ocaml/site-lib/extlib/uChar.cmi
+lib/ocaml/site-lib/extlib/uTF8.cmi
+lib/ocaml/site-lib/extlib/unzip.cmi
+lib/ocaml/site-lib/extlib/extLib.cma
+lib/ocaml/site-lib/extlib/extLib.cmxa
+lib/ocaml/site-lib/extlib/extLib.a
+lib/ocaml/site-lib/extlib/META
+%%PORTDOCS%%%%DOCSDIR%%/Base64.html
+%%PORTDOCS%%%%DOCSDIR%%/BitSet.html
+%%PORTDOCS%%%%DOCSDIR%%/Dbi.Decimal.html
+%%PORTDOCS%%%%DOCSDIR%%/Dbi.connection.html
+%%PORTDOCS%%%%DOCSDIR%%/Dbi.html
+%%PORTDOCS%%%%DOCSDIR%%/Dbi.statement.html
+%%PORTDOCS%%%%DOCSDIR%%/Dllist.html
+%%PORTDOCS%%%%DOCSDIR%%/DynArray.html
+%%PORTDOCS%%%%DOCSDIR%%/Enum.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtHashtbl.Hashtbl.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtHashtbl.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtList.List.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtList.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtString.String.html
+%%PORTDOCS%%%%DOCSDIR%%/ExtString.html
+%%PORTDOCS%%%%DOCSDIR%%/Global.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.BigEndian.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.in_channel.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.in_chars.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.out_channel.html
+%%PORTDOCS%%%%DOCSDIR%%/IO.out_chars.html
+%%PORTDOCS%%%%DOCSDIR%%/OptParse.Formatter.html
+%%PORTDOCS%%%%DOCSDIR%%/OptParse.Opt.html
+%%PORTDOCS%%%%DOCSDIR%%/OptParse.OptParser.html
+%%PORTDOCS%%%%DOCSDIR%%/OptParse.StdOpt.html
+%%PORTDOCS%%%%DOCSDIR%%/OptParse.html
+%%PORTDOCS%%%%DOCSDIR%%/Option.html
+%%PORTDOCS%%%%DOCSDIR%%/PMap.html
+%%PORTDOCS%%%%DOCSDIR%%/RefList.Index.html
+%%PORTDOCS%%%%DOCSDIR%%/RefList.html
+%%PORTDOCS%%%%DOCSDIR%%/Std.html
+%%PORTDOCS%%%%DOCSDIR%%/UChar.html
+%%PORTDOCS%%%%DOCSDIR%%/UTF8.Buf.html
+%%PORTDOCS%%%%DOCSDIR%%/UTF8.html
+%%PORTDOCS%%%%DOCSDIR%%/Unzip.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/index_attributes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_class_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_classes.html
+%%PORTDOCS%%%%DOCSDIR%%/index_exceptions.html
+%%PORTDOCS%%%%DOCSDIR%%/index_methods.html
+%%PORTDOCS%%%%DOCSDIR%%/index_module_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_modules.html
+%%PORTDOCS%%%%DOCSDIR%%/index_types.html
+%%PORTDOCS%%%%DOCSDIR%%/index_values.html
+%%PORTDOCS%%%%DOCSDIR%%/style.css
+%%PORTDOCS%%%%DOCSDIR%%/type_Base64.html
+%%PORTDOCS%%%%DOCSDIR%%/type_BitSet.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Dbi.Decimal.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Dbi.connection.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Dbi.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Dbi.statement.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Dllist.html
+%%PORTDOCS%%%%DOCSDIR%%/type_DynArray.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Enum.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtHashtbl.Hashtbl.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtHashtbl.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtList.List.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtList.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtString.String.html
+%%PORTDOCS%%%%DOCSDIR%%/type_ExtString.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Global.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.BigEndian.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.in_channel.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.in_chars.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.out_channel.html
+%%PORTDOCS%%%%DOCSDIR%%/type_IO.out_chars.html
+%%PORTDOCS%%%%DOCSDIR%%/type_OptParse.Formatter.html
+%%PORTDOCS%%%%DOCSDIR%%/type_OptParse.Opt.html
+%%PORTDOCS%%%%DOCSDIR%%/type_OptParse.OptParser.html
+%%PORTDOCS%%%%DOCSDIR%%/type_OptParse.StdOpt.html
+%%PORTDOCS%%%%DOCSDIR%%/type_OptParse.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Option.html
+%%PORTDOCS%%%%DOCSDIR%%/type_PMap.html
+%%PORTDOCS%%%%DOCSDIR%%/type_RefList.Index.html
+%%PORTDOCS%%%%DOCSDIR%%/type_RefList.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Std.html
+%%PORTDOCS%%%%DOCSDIR%%/type_UChar.html
+%%PORTDOCS%%%%DOCSDIR%%/type_UTF8.Buf.html
+%%PORTDOCS%%%%DOCSDIR%%/type_UTF8.html
+%%PORTDOCS%%%%DOCSDIR%%/type_Unzip.html
+@dirrm lib/ocaml/site-lib/extlib
+@dirrm %%DOCSDIR%%