aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-10-07 04:21:18 +0800
committerswills <swills@FreeBSD.org>2011-10-07 04:21:18 +0800
commit25cb2fb552d09ec6e50078669901cab447fc8d73 (patch)
treec6174cfb22cafcece7324e30446378887ae2b738 /devel
parentd57a22fe285cc254cb63b9003fbcded7f16f587d (diff)
downloadfreebsd-ports-gnome-25cb2fb552d09ec6e50078669901cab447fc8d73.tar.gz
freebsd-ports-gnome-25cb2fb552d09ec6e50078669901cab447fc8d73.tar.zst
freebsd-ports-gnome-25cb2fb552d09ec6e50078669901cab447fc8d73.zip
Test::Timer implements a set of test primitives to test and assert test times
from bodies of code. WWW: http://search.cpan.org/dist/Test-Timer/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Timer/Makefile26
-rw-r--r--devel/p5-Test-Timer/distinfo2
-rw-r--r--devel/p5-Test-Timer/pkg-descr4
-rw-r--r--devel/p5-Test-Timer/pkg-plist7
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 127cdb042d87..c8d89cfa70e2 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2452,6 +2452,7 @@
SUBDIR += p5-Test-Taint
SUBDIR += p5-Test-TempDir
SUBDIR += p5-Test-Tester
+ SUBDIR += p5-Test-Timer
SUBDIR += p5-Test-Trap
SUBDIR += p5-Test-Unit
SUBDIR += p5-Test-UseAllModules
diff --git a/devel/p5-Test-Timer/Makefile b/devel/p5-Test-Timer/Makefile
new file mode 100644
index 000000000000..26ac595a6616
--- /dev/null
+++ b/devel/p5-Test-Timer/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-Timer
+# Date created: 2011-10-06
+# Whom: Steve Wills <swills@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Timer
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+
+MAINTAINER= swills@FreeBSD.org
+COMMENT= A test module to test/assert response times
+
+BUILD_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
+RUN_DEPENDS= p5-Error>=0:${PORTSDIR}/lang/p5-Error
+
+TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::Timer.3 Test::Timer::TimeoutException.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Timer/distinfo b/devel/p5-Test-Timer/distinfo
new file mode 100644
index 000000000000..499ba14aee7d
--- /dev/null
+++ b/devel/p5-Test-Timer/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Test-Timer-0.05.tar.gz) = b5f833797d858951ef2392e2052c4c96c327ceac3407d238c6b16b511443ed9e
+SIZE (Test-Timer-0.05.tar.gz) = 9003
diff --git a/devel/p5-Test-Timer/pkg-descr b/devel/p5-Test-Timer/pkg-descr
new file mode 100644
index 000000000000..1ab00f2e6420
--- /dev/null
+++ b/devel/p5-Test-Timer/pkg-descr
@@ -0,0 +1,4 @@
+Test::Timer implements a set of test primitives to test and assert test times
+from bodies of code.
+
+WWW: http://search.cpan.org/dist/Test-Timer/
diff --git a/devel/p5-Test-Timer/pkg-plist b/devel/p5-Test-Timer/pkg-plist
new file mode 100644
index 000000000000..19bc313e10f4
--- /dev/null
+++ b/devel/p5-Test-Timer/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Test/Timer/TimeoutException.pm
+%%SITE_PERL%%/Test/Timer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Timer/.packlist
+@dirrmtry %%SITE_PERL%%/Test/Timer
+@dirrmtry %%SITE_PERL%%/Test
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Timer
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test