aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-02-14 09:43:15 +0800
committersobomax <sobomax@FreeBSD.org>2002-02-14 09:43:15 +0800
commit26779de402b15f1bb7f7f4e057945a8100cc7004 (patch)
tree1c00d9fae9f1e4149b282f3cf8f2746e957522a5 /devel
parent743ab1ca721712c8fbda7066a332b29de8b7a987 (diff)
downloadfreebsd-ports-gnome-26779de402b15f1bb7f7f4e057945a8100cc7004.tar.gz
freebsd-ports-gnome-26779de402b15f1bb7f7f4e057945a8100cc7004.tar.zst
freebsd-ports-gnome-26779de402b15f1bb7f7f4e057945a8100cc7004.zip
Fix an incompatibility with FreeBSD, which caused bonobo-activation-server
hang-up randomly. After this update the package passes all self-tests buindled with it. Also forcefully supply -pthread cc(1) option to guard from libc/libc_r ordering issues I see on my -current box. Bump PORTREVISION.
Diffstat (limited to 'devel')
-rw-r--r--devel/bonobo-activation/Makefile3
-rw-r--r--devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c14
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/bonobo-activation/Makefile b/devel/bonobo-activation/Makefile
index b9286f2a5ed4..ef9959d09e53 100644
--- a/devel/bonobo-activation/Makefile
+++ b/devel/bonobo-activation/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bonobo-activation
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= pre-gnome2/releases/gnome-2.0-desktop-alpha2
@@ -25,7 +26,7 @@ USE_BISON= yes
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib -pthread"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
pre-patch:
diff --git a/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
new file mode 100644
index 000000000000..ac381550b930
--- /dev/null
+++ b/devel/bonobo-activation/files/patch-bonobo-activation::bonobo-activation-fork-server.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- bonobo-activation/bonobo-activation-fork-server.c 2002/02/14 01:06:52 1.1
++++ bonobo-activation/bonobo-activation-fork-server.c 2002/02/14 01:07:07
+@@ -270,6 +270,8 @@
+ } else if ((childpid = fork ())) {
+ _exit (0); /* de-zombifier process, just exit */
+ } else {
++ sigprocmask (SIG_SETMASK, &omask, NULL);
++
+ if (display)
+ bonobo_activation_setenv ("DISPLAY", display);
+ if (od_iorstr)