aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbeech <beech@FreeBSD.org>2008-05-05 22:59:21 +0800
committerbeech <beech@FreeBSD.org>2008-05-05 22:59:21 +0800
commit29edd10e450ab11a8287e29a83e5813c5b4ad48c (patch)
treeb5f5166f3b50d272c1869f8f00d3ea5fd6be1a86 /devel
parenta1e75903249e69c06ce9250894ebdbb160ee4428 (diff)
downloadfreebsd-ports-gnome-29edd10e450ab11a8287e29a83e5813c5b4ad48c.tar.gz
freebsd-ports-gnome-29edd10e450ab11a8287e29a83e5813c5b4ad48c.tar.zst
freebsd-ports-gnome-29edd10e450ab11a8287e29a83e5813c5b4ad48c.zip
Add tclxml-expat , API for parsing XML documents using Tcl.
TclXML is an API for parsing XML documents using the Tcl scripting language. It is also a package with several parser implementations. The goal of the TclXML package is to provide an API for Tcl scripts that allows "Plug-and-Play" parser implementations; ie. an application will be able to use different parser implementations without change to the application code.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tclxml-expat/Makefile23
-rw-r--r--devel/tclxml-expat/pkg-descr9
-rw-r--r--devel/tclxml-expat/pkg-plist6
4 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1405c5a69dc4..1bd22ca905c3 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2377,6 +2377,7 @@
SUBDIR += tclthread
SUBDIR += tcltls
SUBDIR += tclxml
+ SUBDIR += tclxml-expat
SUBDIR += tdl
SUBDIR += templ
SUBDIR += terminality
diff --git a/devel/tclxml-expat/Makefile b/devel/tclxml-expat/Makefile
new file mode 100644
index 000000000000..1439bc6956cf
--- /dev/null
+++ b/devel/tclxml-expat/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: tclxml-expat
+# Date created: 28 April 2008
+# Whom: Frank Fenor
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -expat
+
+MAINTAINER= frank@fenor.de
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/TclxmlConfig.sh:${PORTSDIR}/devel/tclxml
+
+USE_LDCONFIG= ${LOCALBASE}/lib/Tclexpat${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/expat
+LATEST_LINK= ${PORTNAME}${PKGNAMESUFFIX}
+CONFIGURE_ENV+= CFLAGS="${CFLAGS} -I${LOCALBASE}/include"
+
+MASTERDIR= ${.CURDIR}/../tclxml
+
+BUILDING_EXPAT= yes
+
+.include "${MASTERDIR}/Makefile"
diff --git a/devel/tclxml-expat/pkg-descr b/devel/tclxml-expat/pkg-descr
new file mode 100644
index 000000000000..d87e45fbabfc
--- /dev/null
+++ b/devel/tclxml-expat/pkg-descr
@@ -0,0 +1,9 @@
+tclxml-expat
+TclXML is an API for parsing XML documents using the Tcl scripting
+language. It is also a package with several parser implementations.
+The goal of the TclXML package is to provide an API for Tcl scripts
+that allows "Plug-and-Play" parser implementations; ie. an application
+will be able to use different parser implementations without change
+to the application code.
+
+WWW: http://tclxml.sourceforge.net/
diff --git a/devel/tclxml-expat/pkg-plist b/devel/tclxml-expat/pkg-plist
new file mode 100644
index 000000000000..28147b65b358
--- /dev/null
+++ b/devel/tclxml-expat/pkg-plist
@@ -0,0 +1,6 @@
+include/xmlparse.h
+include/xmlrole.h
+include/xmltok.h
+lib/Tclexpat%%VER%%/libTclexpat%%VER%%.so
+lib/Tclexpat%%VER%%/pkgIndex.tcl
+@dirrm lib/Tclexpat3.1