aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2014-03-29 22:46:08 +0800
committerswills <swills@FreeBSD.org>2014-03-29 22:46:08 +0800
commit2a96064b342d98bc9044c1b7b9f120fcc3ba411e (patch)
treed9ef3b3e268fc4fd9f59a5276bc34e29d0311570 /devel
parent597998aef2f42436cffadd25fa36070ca77c40a2 (diff)
downloadfreebsd-ports-gnome-2a96064b342d98bc9044c1b7b9f120fcc3ba411e.tar.gz
freebsd-ports-gnome-2a96064b342d98bc9044c1b7b9f120fcc3ba411e.tar.zst
freebsd-ports-gnome-2a96064b342d98bc9044c1b7b9f120fcc3ba411e.zip
BinData is a declarative way to read and write binary file formats.
This means the programmer specifies *what* the format of the binary data is, and BinData works out *how* to read and write data in this format. It is an easier (and more readable) alternative to Ruby's #pack and #unpack methods. WWW: https://github.com/dmendel/bindata PR: ports/187950 Submitted by: Michael Moll <kvedulv at kvedulv.de>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-bindata/Makefile20
-rw-r--r--devel/rubygem-bindata/distinfo2
-rw-r--r--devel/rubygem-bindata/pkg-descr8
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1dab267b033c..46e85e676c92 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4139,6 +4139,7 @@
SUBDIR += rubygem-bacon
SUBDIR += rubygem-benelux
SUBDIR += rubygem-bin_utils
+ SUBDIR += rubygem-bindata
SUBDIR += rubygem-bioruby
SUBDIR += rubygem-blockenspiel
SUBDIR += rubygem-bson
diff --git a/devel/rubygem-bindata/Makefile b/devel/rubygem-bindata/Makefile
new file mode 100644
index 000000000000..ce2d0e40568c
--- /dev/null
+++ b/devel/rubygem-bindata/Makefile
@@ -0,0 +1,20 @@
+# Created by: Michael Moll <kvedulv at kvedulv.de>
+# $FreeBSD$
+
+PORTNAME= bindata
+PORTVERSION= 2.0.0
+CATEGORIES= devel ruby
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby library to read and write binary file formats
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= rubygem-minitest>=5.0.6:${PORTSDIR}/devel/rubygem-minitest
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-bindata/distinfo b/devel/rubygem-bindata/distinfo
new file mode 100644
index 000000000000..b27f1b296fc9
--- /dev/null
+++ b/devel/rubygem-bindata/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bindata-2.0.0.gem) = 414e7fc359c5b5d1453d8ff2ffe58915e7ea46ae95d1e36ece6f28b2287bc609
+SIZE (rubygem/bindata-2.0.0.gem) = 68608
diff --git a/devel/rubygem-bindata/pkg-descr b/devel/rubygem-bindata/pkg-descr
new file mode 100644
index 000000000000..7af9baa8c731
--- /dev/null
+++ b/devel/rubygem-bindata/pkg-descr
@@ -0,0 +1,8 @@
+BinData is a declarative way to read and write binary file formats.
+
+This means the programmer specifies *what* the format of the binary
+data is, and BinData works out *how* to read and write data in this
+format. It is an easier (and more readable) alternative to Ruby's
+#pack and #unpack methods.
+
+WWW: https://github.com/dmendel/bindata