aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-25 00:07:05 +0800
committerbapt <bapt@FreeBSD.org>2014-06-25 00:07:05 +0800
commit2c273d39f363e150b3fb9acf6e5bd22564061424 (patch)
tree27ab026a511913b02956a4ff54d4c2899e139b54 /devel
parent2e62a492bb4872ab85d417cff04f8799bc17f336 (diff)
downloadfreebsd-ports-gnome-2c273d39f363e150b3fb9acf6e5bd22564061424.tar.gz
freebsd-ports-gnome-2c273d39f363e150b3fb9acf6e5bd22564061424.tar.zst
freebsd-ports-gnome-2c273d39f363e150b3fb9acf6e5bd22564061424.zip
Add a minimal version of gmake to reduce the risk of circular dependencies on
the building cluster and allow to simplify the process on removing texinfo and groff from base
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gmake-minimal/Makefile32
-rw-r--r--devel/gmake-minimal/distinfo2
-rw-r--r--devel/gmake-minimal/pkg-descr3
-rw-r--r--devel/gmake/Makefile2
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 38511af3a057..2611c7aab4a1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -578,6 +578,7 @@
SUBDIR += glrparser
SUBDIR += glui
SUBDIR += gmake
+ SUBDIR += gmake-minimal
SUBDIR += gnatcoll
SUBDIR += gnatpython
SUBDIR += gnome-common
diff --git a/devel/gmake-minimal/Makefile b/devel/gmake-minimal/Makefile
new file mode 100644
index 000000000000..1c0f1cba0dd5
--- /dev/null
+++ b/devel/gmake-minimal/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= make
+PORTVERSION= 3.82
+CATEGORIES= devel ports-mgmt
+MASTER_SITES= GNU
+PKGNAMEPREFIX= g
+PKGNAMESUFFIX= -minimal
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Minimalist version of gnu make
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS= gmake-[0-9]*
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --program-prefix=g \
+ --disable-nls
+
+USES= tar:bzip2
+
+PLIST_FILES= bin/gmake \
+ man/man1/gmake.1.gz
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/make ${STAGEDIR}${PREFIX}/bin/gmake
+ ${INSTALL_MAN} ${WRKSRC}/make.1 ${STAGEDIR}${PREFIX}/man/man1/gmake.1
+
+.include <bsd.port.mk>
+
diff --git a/devel/gmake-minimal/distinfo b/devel/gmake-minimal/distinfo
new file mode 100644
index 000000000000..6f75d6baced1
--- /dev/null
+++ b/devel/gmake-minimal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (make-3.82.tar.bz2) = e2c1a73f179c40c71e2fe8abf8a8a0688b8499538512984da4a76958d0402966
+SIZE (make-3.82.tar.bz2) = 1242186
diff --git a/devel/gmake-minimal/pkg-descr b/devel/gmake-minimal/pkg-descr
new file mode 100644
index 000000000000..215a7928dc49
--- /dev/null
+++ b/devel/gmake-minimal/pkg-descr
@@ -0,0 +1,3 @@
+Minimalistic version of GNU make
+
+WWW: http://www.gnu.org/software/make/make.html
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index d9632756bd24..3b5c87e8e12b 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -15,6 +15,8 @@ DISTNAME= make-${PORTVERSION}
MAINTAINER= autotools@FreeBSD.org
COMMENT= GNU version of 'make' utility
+CONFLICTS= gmake-minimal-*
+
LICENSE= GPLv3
GNU_CONFIGURE= yes