aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-12-29 00:29:03 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-12-29 00:29:03 +0800
commit2c46a94665e3d5574ce0fa81e5698dc6b9a97af0 (patch)
tree62ac44f85eb3b96db4044ab1e1b13459aa9aef8a /devel
parent515ceeeca506ff05ae1dfd13579bd153cf186023 (diff)
downloadfreebsd-ports-gnome-2c46a94665e3d5574ce0fa81e5698dc6b9a97af0.tar.gz
freebsd-ports-gnome-2c46a94665e3d5574ce0fa81e5698dc6b9a97af0.tar.zst
freebsd-ports-gnome-2c46a94665e3d5574ce0fa81e5698dc6b9a97af0.zip
- Add rubygem-ransack 1.7.0
Ransack is a rewrite of MetaSearch created by Ernie Miller and maintained by Ryan Bigg, Jon Atack and a great group of contributors. While it supports many of the same features as MetaSearch, its underlying implementation differs greatly from MetaSearch, and backwards compatibility is not a design goal. Ransack enables the creation of both simple and advanced search forms for your Ruby on Rails application (demo source code here). If you're looking for something that simplifies query generation at the model or controller layer, you're probably not looking for Ransack (or MetaSearch, for that matter). Try Squeel instead. WWW: https://github.com/activerecord-hackery/ransack
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-ransack/Makefile26
-rw-r--r--devel/rubygem-ransack/distinfo2
-rw-r--r--devel/rubygem-ransack/pkg-descr12
4 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c69e0da8977..b4203ee907a4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4961,6 +4961,7 @@
SUBDIR += rubygem-rainbow
SUBDIR += rubygem-rake
SUBDIR += rubygem-rake-compiler
+ SUBDIR += rubygem-ransack
SUBDIR += rubygem-rapt
SUBDIR += rubygem-rash
SUBDIR += rubygem-rb-fsevent
diff --git a/devel/rubygem-ransack/Makefile b/devel/rubygem-ransack/Makefile
new file mode 100644
index 000000000000..3102f87828ab
--- /dev/null
+++ b/devel/rubygem-ransack/Makefile
@@ -0,0 +1,26 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ransack
+PORTVERSION= 1.7.0
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Successor to the MetaSearch gem
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-actionpack4>=3.0:${PORTSDIR}/www/rubygem-actionpack4 \
+ rubygem-activerecord4>=3.0:${PORTSDIR}/databases/rubygem-activerecord4 \
+ rubygem-activesupport4>=3.0:${PORTSDIR}/devel/rubygem-activesupport4 \
+ rubygem-i18n>=0:${PORTSDIR}/devel/rubygem-i18n \
+ rubygem-polyamorous>=1.2:${PORTSDIR}/devel/rubygem-polyamorous
+
+NO_ARCH= yes
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ransack/distinfo b/devel/rubygem-ransack/distinfo
new file mode 100644
index 000000000000..64662bc1f9af
--- /dev/null
+++ b/devel/rubygem-ransack/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ransack-1.7.0.gem) = adac76c9598da297403bb6fef4e00c5eec199bae7d6fc486f207a1d1ed74a34d
+SIZE (rubygem/ransack-1.7.0.gem) = 73216
diff --git a/devel/rubygem-ransack/pkg-descr b/devel/rubygem-ransack/pkg-descr
new file mode 100644
index 000000000000..f59099426bd7
--- /dev/null
+++ b/devel/rubygem-ransack/pkg-descr
@@ -0,0 +1,12 @@
+Ransack is a rewrite of MetaSearch created by Ernie Miller and maintained by
+Ryan Bigg, Jon Atack and a great group of contributors. While it supports many
+of the same features as MetaSearch, its underlying implementation differs
+greatly from MetaSearch, and backwards compatibility is not a design goal.
+
+Ransack enables the creation of both simple and advanced search forms for your
+Ruby on Rails application (demo source code here). If you're looking for
+something that simplifies query generation at the model or controller layer,
+you're probably not looking for Ransack (or MetaSearch, for that matter). Try
+Squeel instead.
+
+WWW: https://github.com/activerecord-hackery/ransack