aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-08 11:34:31 +0800
committerclsung <clsung@FreeBSD.org>2006-08-08 11:34:31 +0800
commit2dfa8f32daefbbc560033c923d275fc36e0c9763 (patch)
tree85bcb6c2ef8df27148a5dfdd0552041de9a4a803 /devel
parent2d96fdc60f95f62551214a4bcf8987209b76c5cf (diff)
downloadfreebsd-ports-gnome-2dfa8f32daefbbc560033c923d275fc36e0c9763.tar.gz
freebsd-ports-gnome-2dfa8f32daefbbc560033c923d275fc36e0c9763.tar.zst
freebsd-ports-gnome-2dfa8f32daefbbc560033c923d275fc36e0c9763.zip
- mark IGNORE for perl < 5.6
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index ee83e7713e89..57046796ddf8 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -17,7 +17,10 @@ MAINTAINER= clsung@FreeBSD.org
COMMENT= Build and install Perl modules
RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools \
- ${SITE_PERL}/ExtUtils/CBuilder.pm:${PORTSDIR}/devel/p5-ExtUtils-CBuilder
+ ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
+ ${SITE_PERL}/ExtUtils/CBuilder.pm:${PORTSDIR}/devel/p5-ExtUtils-CBuilder \
+ ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-ParseXS \
+ ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
BUILD_DEPENDS= ${RUN_DEPENDS}
PERL_MODBUILD= yes
@@ -33,10 +36,8 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} > 500600
-RUN_DEPENDS+= ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
-RUN_DEPENDS+= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar
-RUN_DEPENDS+= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
.endif
MAN3= Module::Build.3 \