aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorfoxfair <foxfair@FreeBSD.org>2003-10-28 23:30:46 +0800
committerfoxfair <foxfair@FreeBSD.org>2003-10-28 23:30:46 +0800
commit2e84e5106669b9e4560b134eb3e592ee54f3d8a0 (patch)
tree217545740e09f09a6edb4722c76619c9e373be2c /devel
parentc60419dde814016479eb26960ce05d42795d8042 (diff)
downloadfreebsd-ports-gnome-2e84e5106669b9e4560b134eb3e592ee54f3d8a0.tar.gz
freebsd-ports-gnome-2e84e5106669b9e4560b134eb3e592ee54f3d8a0.tar.zst
freebsd-ports-gnome-2e84e5106669b9e4560b134eb3e592ee54f3d8a0.zip
Add p5-Algorithm-Networksort 1.01,
a perl module that will create inline comparisons for sorting. PR: 58551 Submitted by: clsung@dragon2.net
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Algorithm-Networksort/Makefile29
-rw-r--r--devel/p5-Algorithm-Networksort/distinfo1
-rw-r--r--devel/p5-Algorithm-Networksort/pkg-descr17
-rw-r--r--devel/p5-Algorithm-Networksort/pkg-plist5
5 files changed, 53 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7a3de5591251..c5a71f337741 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -497,6 +497,7 @@
SUBDIR += p5-Algorithm-MDiff
SUBDIR += p5-Algorithm-MarkovChain
SUBDIR += p5-Algorithm-NaiveBayes
+ SUBDIR += p5-Algorithm-Networksort
SUBDIR += p5-Algorithm-Numerical-Shuffle
SUBDIR += p5-Algorithm-Permute
SUBDIR += p5-Alias
diff --git a/devel/p5-Algorithm-Networksort/Makefile b/devel/p5-Algorithm-Networksort/Makefile
new file mode 100644
index 000000000000..414137318e60
--- /dev/null
+++ b/devel/p5-Algorithm-Networksort/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: Algorithm::Networksort
+# Date created: Oct 26 2003
+# Whom: clsung@dragon2.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= Algorithm-Networksort
+PORTVERSION= 1.01
+PORTREVISION= 0
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Algorithm
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= clsung@dragon2.net
+COMMENT= A perl module that will create sorting networks
+
+PERL_CONFIGURE= yes
+
+MAN3= Algorithm::Networksort.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= This port requires perl 5.6.x or later. Install lang/perl5 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Algorithm-Networksort/distinfo b/devel/p5-Algorithm-Networksort/distinfo
new file mode 100644
index 000000000000..f1f5c6211977
--- /dev/null
+++ b/devel/p5-Algorithm-Networksort/distinfo
@@ -0,0 +1 @@
+MD5 (Algorithm-Networksort-1.01.tar.gz) = 64a983aee3568d7d2cba73b1b62c2227
diff --git a/devel/p5-Algorithm-Networksort/pkg-descr b/devel/p5-Algorithm-Networksort/pkg-descr
new file mode 100644
index 000000000000..def541ae4dc3
--- /dev/null
+++ b/devel/p5-Algorithm-Networksort/pkg-descr
@@ -0,0 +1,17 @@
+This module will create sorting networks, a sequence of comparisons
+that do not depend upon the results of prior comparisons.
+
+There are several algorithms to generate sorting networks. This
+module has three of them: Bose and Nelson's, Hibbard's, and
+Batcher's Merge Exchange. It also has networks that were found
+to be superior in comparison count to those generated automatically
+by these algorithms.
+
+There is a flexible formatting function that will allow you to
+print out your network in many ways (see documentation). There
+is also a graphical output function that will return the network
+in an encapsulated postscript, SVG, or text form.
+
+WWW: http://search.cpan.org/dist/Algorithm-Networksort/
+
+Author: John M. Gamble <jgamble@ripco.com>
diff --git a/devel/p5-Algorithm-Networksort/pkg-plist b/devel/p5-Algorithm-Networksort/pkg-plist
new file mode 100644
index 000000000000..73c7c9d98fb0
--- /dev/null
+++ b/devel/p5-Algorithm-Networksort/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Algorithm/Networksort.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Networksort/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm/Networksort
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Algorithm 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Algorithm 2>/dev/null || true