aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2007-02-27 03:31:55 +0800
committertobez <tobez@FreeBSD.org>2007-02-27 03:31:55 +0800
commit2f99ab893506e3761d9a5142d2da5198010f1594 (patch)
tree570882e4b38857c497d76049ac35099dc9ca02a0 /devel
parent7332300f7e53a5321134d62a1b5f5b7ff2ff5e4b (diff)
downloadfreebsd-ports-gnome-2f99ab893506e3761d9a5142d2da5198010f1594.tar.gz
freebsd-ports-gnome-2f99ab893506e3761d9a5142d2da5198010f1594.tar.zst
freebsd-ports-gnome-2f99ab893506e3761d9a5142d2da5198010f1594.zip
Add devel/p5-B-Generate 1.06, a Perl module that facilitates
Perl optree manipulation from Perl.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-B-Generate/Makefile28
-rw-r--r--devel/p5-B-Generate/distinfo3
-rw-r--r--devel/p5-B-Generate/pkg-descr8
-rw-r--r--devel/p5-B-Generate/pkg-plist6
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 297d50e0492d..dfae447e778d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -835,6 +835,7 @@
SUBDIR += p5-Attribute-Persistent
SUBDIR += p5-AutoLoader
SUBDIR += p5-B-Deobfuscate
+ SUBDIR += p5-B-Generate
SUBDIR += p5-B-Graph
SUBDIR += p5-B-Keywords
SUBDIR += p5-B-Size
diff --git a/devel/p5-B-Generate/Makefile b/devel/p5-B-Generate/Makefile
new file mode 100644
index 000000000000..707f930e3cda
--- /dev/null
+++ b/devel/p5-B-Generate/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-B-Generate
+# Date created: 26 February 2007
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= B-Generate
+PORTVERSION= 1.06
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= B
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Create your own Perl op trees
+
+PERL_MODBUILD= yes
+
+MAN3= B::Generate.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-B-Generate/distinfo b/devel/p5-B-Generate/distinfo
new file mode 100644
index 000000000000..ebaff392360f
--- /dev/null
+++ b/devel/p5-B-Generate/distinfo
@@ -0,0 +1,3 @@
+MD5 (B-Generate-1.06.tar.gz) = e1a52ef58619accf0c9a0a55a71dd897
+SHA256 (B-Generate-1.06.tar.gz) = 073b3f01438297b65a356e594e90dc8dbf05cc04bf98ffd3bd979d330624b81d
+SIZE (B-Generate-1.06.tar.gz) = 12379
diff --git a/devel/p5-B-Generate/pkg-descr b/devel/p5-B-Generate/pkg-descr
new file mode 100644
index 000000000000..4203acc0c479
--- /dev/null
+++ b/devel/p5-B-Generate/pkg-descr
@@ -0,0 +1,8 @@
+Malcolm Beattie's B module allows you to examine the Perl op tree at
+runtime, in Perl space; it's the basis of the Perl compiler. But what it
+doesn't let you do is manipulate that op tree: it won't let you create
+new ops, or modify old ones. Now you can.
+
+Well, if you're intimately familiar with Perl's internals, you can.
+
+WWW: http://search.cpan.org/dist/B-Generate/
diff --git a/devel/p5-B-Generate/pkg-plist b/devel/p5-B-Generate/pkg-plist
new file mode 100644
index 000000000000..76a1a4ecae5a
--- /dev/null
+++ b/devel/p5-B-Generate/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Generate/Generate.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Generate/Generate.so
+%%SITE_PERL%%/%%PERL_ARCH%%/B/Generate.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B/Generate
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/B
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/B