aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2004-08-12 02:03:54 +0800
committerskv <skv@FreeBSD.org>2004-08-12 02:03:54 +0800
commit2fdad4a5ec7deed16950a0cd8dbb0eb6a6d8e225 (patch)
tree8e7797c083c692c65226874469ced27098dd11d4 /devel
parent45635ff006b5864a93ca609aacca3645d8b25431 (diff)
downloadfreebsd-ports-gnome-2fdad4a5ec7deed16950a0cd8dbb0eb6a6d8e225.tar.gz
freebsd-ports-gnome-2fdad4a5ec7deed16950a0cd8dbb0eb6a6d8e225.tar.zst
freebsd-ports-gnome-2fdad4a5ec7deed16950a0cd8dbb0eb6a6d8e225.zip
Add p5-Devel-SmallProf 2.00, per-line Perl profiler.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Devel-SmallProf/Makefile32
-rw-r--r--devel/p5-Devel-SmallProf/distinfo2
-rw-r--r--devel/p5-Devel-SmallProf/pkg-descr6
-rw-r--r--devel/p5-Devel-SmallProf/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 094f2c245c1a..5f7c07bde818 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -753,6 +753,7 @@
SUBDIR += p5-Devel-Profile
SUBDIR += p5-Devel-Profiler
SUBDIR += p5-Devel-Size
+ SUBDIR += p5-Devel-SmallProf
SUBDIR += p5-Devel-StackTrace
SUBDIR += p5-Devel-Symdump
SUBDIR += p5-Devel-Trace
diff --git a/devel/p5-Devel-SmallProf/Makefile b/devel/p5-Devel-SmallProf/Makefile
new file mode 100644
index 000000000000..5a1a24c6233a
--- /dev/null
+++ b/devel/p5-Devel-SmallProf/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: Devel-SmallProf
+# Date created: 11 August 2004
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Devel-SmallProf
+PORTVERSION= 2.00
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/S/SA/SALVA
+PKGNAMEPREFIX= p5-
+DISTNAME= ${PORTNAME}-${PORTVERSION}_02
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Per-line Perl profiler
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Time/HiRes.pm:${PORTSDIR}/devel/p5-Time-HiRes
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Devel::SmallProf.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= "Perl 5.8 or newer required. Install lang/perl5.8 and try again."
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Devel-SmallProf/distinfo b/devel/p5-Devel-SmallProf/distinfo
new file mode 100644
index 000000000000..52526453fde5
--- /dev/null
+++ b/devel/p5-Devel-SmallProf/distinfo
@@ -0,0 +1,2 @@
+MD5 (Devel-SmallProf-2.00_02.tar.gz) = 6f1a134ee48d0c28d905cb48464c9ac8
+SIZE (Devel-SmallProf-2.00_02.tar.gz) = 9032
diff --git a/devel/p5-Devel-SmallProf/pkg-descr b/devel/p5-Devel-SmallProf/pkg-descr
new file mode 100644
index 000000000000..d9b358534073
--- /dev/null
+++ b/devel/p5-Devel-SmallProf/pkg-descr
@@ -0,0 +1,6 @@
+The Devel::SmallProf profiler is focused on the time taken for a program
+run on a line-by-line basis. It is intended to be as "small" in terms
+of impact on the speed and memory usage of the profiled program as
+possible and also in terms of being simple to use.
+
+WWW: http://search.cpan.org/dist/Devel-SmallProf/
diff --git a/devel/p5-Devel-SmallProf/pkg-plist b/devel/p5-Devel-SmallProf/pkg-plist
new file mode 100644
index 000000000000..0f0d851837ae
--- /dev/null
+++ b/devel/p5-Devel-SmallProf/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Devel/SmallProf.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/SmallProf/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/Devel 2>/dev/null || true
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel/SmallProf
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Devel 2>/dev/null || true