aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2013-01-28 21:44:00 +0800
committervanilla <vanilla@FreeBSD.org>2013-01-28 21:44:00 +0800
commit33db7db4c874b780ecbfe65a1ca4e2fb8748d261 (patch)
tree35a1d614e0a2d46819dec34a44dc3c5dc3721db9 /devel
parent42b7f45a5ce500d92b83402b3760728ce97da689 (diff)
downloadfreebsd-ports-gnome-33db7db4c874b780ecbfe65a1ca4e2fb8748d261.tar.gz
freebsd-ports-gnome-33db7db4c874b780ecbfe65a1ca4e2fb8748d261.tar.zst
freebsd-ports-gnome-33db7db4c874b780ecbfe65a1ca4e2fb8748d261.zip
1: Upgrade to 0.2.3
2: add 2 patches for clang. PR: ports/175646 Submitted by: maintainer
Diffstat (limited to 'devel')
-rw-r--r--devel/pecl-ev/Makefile15
-rw-r--r--devel/pecl-ev/distinfo4
-rw-r--r--devel/pecl-ev/files/patch-watcher.c11
-rw-r--r--devel/pecl-ev/files/patch-watcher.h11
4 files changed, 27 insertions, 14 deletions
diff --git a/devel/pecl-ev/Makefile b/devel/pecl-ev/Makefile
index 6fb3e682c62a..f3413c376a21 100644
--- a/devel/pecl-ev/Makefile
+++ b/devel/pecl-ev/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ev
-PORTVERSION= 0.2.2
+PORTVERSION= 0.2.3
CATEGORIES= devel
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -14,20 +14,11 @@ COMMENT= Libev extension for PHP
LICENSE= PHP301
+USE_PHP= yes
USE_PHP_BUILD= yes
USE_PHPIZE= yes
USE_PHPEXT= yes
PHP_MODNAME= ev
IGNORE_WITH_PHP=4 52 53
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/include/php/ext/sockets/php_sockets.h)
-USE_PHP= sockets
-CONFIGURE_ARGS+= --enable-ev-sockets
-.else
-USE_PHP= yes
-CONFIGURE_ARGS+= --disable-ev-sockets
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/pecl-ev/distinfo b/devel/pecl-ev/distinfo
index c9d6be7e5be8..cce013cd494d 100644
--- a/devel/pecl-ev/distinfo
+++ b/devel/pecl-ev/distinfo
@@ -1,2 +1,2 @@
-SHA256 (PECL/ev-0.2.2.tgz) = 059b17ec9a1c8f77bdc5531433b565392b7e53860e5208fa50e83443c5ea580b
-SIZE (PECL/ev-0.2.2.tgz) = 93696
+SHA256 (PECL/ev-0.2.3.tgz) = 80ca5927f19d55977677681a1ad8d498cef28a9d237456fe9c20925f4b19389f
+SIZE (PECL/ev-0.2.3.tgz) = 92926
diff --git a/devel/pecl-ev/files/patch-watcher.c b/devel/pecl-ev/files/patch-watcher.c
new file mode 100644
index 000000000000..594ff8bc06c7
--- /dev/null
+++ b/devel/pecl-ev/files/patch-watcher.c
@@ -0,0 +1,11 @@
+--- watcher.c.orig 2013-01-28 21:38:15.000000000 +0800
++++ watcher.c 2013-01-28 21:38:24.000000000 +0800
+@@ -27,7 +27,7 @@
+ extern zend_class_entry *ev_loop_class_entry_ptr;
+
+ /* {{{ php_ev_set_watcher_priority() */
+-inline void php_ev_set_watcher_priority(ev_watcher *watcher, long priority TSRMLS_DC)
++void php_ev_set_watcher_priority(ev_watcher *watcher, long priority TSRMLS_DC)
+ {
+ PHP_EV_CHECK_PENDING_WATCHER(watcher);
+ ev_set_priority(watcher, priority);
diff --git a/devel/pecl-ev/files/patch-watcher.h b/devel/pecl-ev/files/patch-watcher.h
new file mode 100644
index 000000000000..952942b71271
--- /dev/null
+++ b/devel/pecl-ev/files/patch-watcher.h
@@ -0,0 +1,11 @@
+--- watcher.h.orig 2013-01-28 21:38:20.000000000 +0800
++++ watcher.h 2013-01-28 21:38:27.000000000 +0800
+@@ -131,7 +131,7 @@ void php_ev_set_watcher(ev_watcher *w, s
+ void *php_ev_new_watcher(size_t size, zval *self, php_ev_loop *loop,
+ const zend_fcall_info *pfci, const zend_fcall_info_cache *pfcc, zval *data, int priority TSRMLS_DC);
+ void php_ev_stop_watcher(ev_watcher *watcher TSRMLS_DC);
+-inline void php_ev_set_watcher_priority(ev_watcher *watcher, long priority TSRMLS_DC);
++void php_ev_set_watcher_priority(ev_watcher *watcher, long priority TSRMLS_DC);
+ void php_ev_start_watcher(ev_watcher *watcher TSRMLS_DC);
+
+ #endif /* PHP_EV_WATCHER_H */