aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2005-06-13 03:18:10 +0800
committerthierry <thierry@FreeBSD.org>2005-06-13 03:18:10 +0800
commit362e44bf584e87e1259abe631f162ffacbb8b806 (patch)
tree8c2af75cc929be4a0007b555ad22687d1ba8b5b8 /devel
parent2e87f6c6badc1e83b77380f1bb8f5d868a85a55b (diff)
downloadfreebsd-ports-gnome-362e44bf584e87e1259abe631f162ffacbb8b806.tar.gz
freebsd-ports-gnome-362e44bf584e87e1259abe631f162ffacbb8b806.tar.zst
freebsd-ports-gnome-362e44bf584e87e1259abe631f162ffacbb8b806.zip
Add looks 1.3.1: the JGoodies Looks improve the appearance of your
Java applications.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/looks/Makefile59
-rw-r--r--devel/looks/distinfo2
-rw-r--r--devel/looks/pkg-descr4
4 files changed, 66 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7cdbb9f53415..0da6fa5e04bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -534,6 +534,7 @@
SUBDIR += log4cxx
SUBDIR += log4j
SUBDIR += log4sh
+ SUBDIR += looks
SUBDIR += lwp
SUBDIR += m17n-db
SUBDIR += m17n-docs
diff --git a/devel/looks/Makefile b/devel/looks/Makefile
new file mode 100644
index 000000000000..562a8d3e50b4
--- /dev/null
+++ b/devel/looks/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: looks
+# Date created: 22 May 2005
+# Whom: Thierry Thomas <thierry@pompo.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= looks
+PORTVERSION= 1.3.1
+CATEGORIES= devel java
+MASTER_SITES= https://looks.dev.java.net/files/documents/31/10378/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S|.|_|g}-${DISTDATE}
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= The JGoodies Looks improve the appearance of your Java applications
+
+FETCH_DEPENDS= ${LOCALBASE}/bin/wget:${PORTSDIR}/ftp/wget
+
+DISTDATE= 20050325
+
+FETCH_CMD= ${LOCALBASE}/bin/wget
+DISABLE_SIZE= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+JARFILE= ${PORTNAME}.jar
+
+PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+DOCFILES= README.html RELEASE-NOTES.txt
+EXAMPLES= demo.jar lib/forms-1.0.5.jar tiny.jar
+PORTDOCS= *
+
+.if !defined(NOPORTDOCS)
+PLIST_FILES+= ${EXAMPLES:S|^|%%EXAMPLESDIR%%/|}
+PLIST_DIRS+= %%EXAMPLESDIR%%/lib %%EXAMPLESDIR%%
+.endif
+
+post-extract:
+ @${MV} ${WRKSRC}/LICENSE.txt ${WRKSRC}/LICENSE.${PORTNAME}.txt
+
+do-install:
+ ${INSTALL_DATA} ${JARFILE:S|.jar|-${PORTVERSION}.jar|:S|^|${WRKSRC}/|} \
+ ${JAVAJARDIR}/${JARFILE}
+ @${INSTALL_DATA} ${WRKSRC}/LICENSE.${PORTNAME}.txt ${JAVAJARDIR}
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR} ${EXAMPLESDIR}/lib
+ @${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/|} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/docs/* ${DOCSDIR}
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${INSTALL_DATA} ${EXAMPLES:S|^|${WRKSRC}/examples/|} ${EXAMPLESDIR}
+ @${MV} ${EXAMPLESDIR}/forms-1.0.5.jar ${EXAMPLESDIR}/lib
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/looks/distinfo b/devel/looks/distinfo
new file mode 100644
index 000000000000..39d99d9dd731
--- /dev/null
+++ b/devel/looks/distinfo
@@ -0,0 +1,2 @@
+MD5 (looks-1_3_1-20050325.zip) = f8b28647b2d1801ef1877748e39737ef
+SIZE (looks-1_3_1-20050325.zip) = 1794865
diff --git a/devel/looks/pkg-descr b/devel/looks/pkg-descr
new file mode 100644
index 000000000000..dd503f660a1d
--- /dev/null
+++ b/devel/looks/pkg-descr
@@ -0,0 +1,4 @@
+The JGoodies look&feels make your Swing applications and applets look better.
+They have been optimized for readability, precise micro-design and usability.
+
+WWW: https://looks.dev.java.net/