aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsperber <sperber@FreeBSD.org>2013-05-01 01:46:48 +0800
committersperber <sperber@FreeBSD.org>2013-05-01 01:46:48 +0800
commit38a6e456e5f04fc2cd1b5320a3411df223658097 (patch)
treef703d6677618680959db3d2e4f649382c359ba24 /devel
parent15a6faaf31b658b01269078f5821d63e59b9238d (diff)
downloadfreebsd-ports-gnome-38a6e456e5f04fc2cd1b5320a3411df223658097.tar.gz
freebsd-ports-gnome-38a6e456e5f04fc2cd1b5320a3411df223658097.tar.zst
freebsd-ports-gnome-38a6e456e5f04fc2cd1b5320a3411df223658097.zip
- Update to 1.21.0
- Switch to OptionsNG - Update pkg-descr and WWW: - Trim Makefile headers - Add USES= pkgconfig - Update MAINTAINER to my FreeBSD address PR: ports/175919 Submitted by: Po-Chien Lin <linpc _AT_ cs.nctu.edu.tw> Approved by: beat (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/libfirm/Makefile21
-rw-r--r--devel/libfirm/distinfo4
-rw-r--r--devel/libfirm/files/patch-configure.ac2
-rw-r--r--devel/libfirm/pkg-descr32
-rw-r--r--devel/libfirm/pkg-plist8
5 files changed, 30 insertions, 37 deletions
diff --git a/devel/libfirm/Makefile b/devel/libfirm/Makefile
index 7bc075d048c5..10b19d68ba3b 100644
--- a/devel/libfirm/Makefile
+++ b/devel/libfirm/Makefile
@@ -1,16 +1,12 @@
-# New ports collection makefile for: libFIRM
-# Date created: 22 Nov 2008
-# Whom: Christoph Mallon <christoph.mallon@gmx.de>
-#
+# Created by: Christoph Mallon <christoph.mallon@gmx.de>
# $FreeBSD$
-#
PORTNAME= libfirm
-PORTVERSION= 1.20.0
+PORTVERSION= 1.21.0
CATEGORIES= devel lang
MASTER_SITES= SF
-MAINTAINER= armin@frozen-zone.org
+MAINTAINER= sperber@FreeBSD.org
COMMENT= A graph-based SSA intermediate representation library for compilers
LICENSE= GPLv2 LGPL21
@@ -19,17 +15,18 @@ LICENSE_COMB= multi
USE_AUTOTOOLS= autoconf
USE_BZIP2= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack pkgconfig
+USE_GNOME= gnomehack
USE_LDCONFIG= yes
+USES= pkgconfig
-OPTIONS= DEBUG "Build a debug version of libFIRM" OFF
+OPTIONS_DEFINE= DEBUG
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.ifdef WITH_DEBUG
+.if ${PORT_OPTIONS:MDEBUG}
CONFIGURE_ARGS+= --enable-debug
.else
CONFIGURE_ARGS+= --disable-debug
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/libfirm/distinfo b/devel/libfirm/distinfo
index 193390b56833..0e4dfaf3682c 100644
--- a/devel/libfirm/distinfo
+++ b/devel/libfirm/distinfo
@@ -1,2 +1,2 @@
-SHA256 (libfirm-1.20.0.tar.bz2) = 2c3e7841dc447c654b76578f3b58379887bebe0d1011dd94c16e0d1b5f0ea7e9
-SIZE (libfirm-1.20.0.tar.bz2) = 1471229
+SHA256 (libfirm-1.21.0.tar.bz2) = 5c126f69e6a985b54aa9f0a919ab68575f18fc3d851c2d5ff71ffbf414e29812
+SIZE (libfirm-1.21.0.tar.bz2) = 1457097
diff --git a/devel/libfirm/files/patch-configure.ac b/devel/libfirm/files/patch-configure.ac
index be65b8ed9e35..33ef65877ebf 100644
--- a/devel/libfirm/files/patch-configure.ac
+++ b/devel/libfirm/files/patch-configure.ac
@@ -1,6 +1,6 @@
--- configure.ac.orig 2011-08-12 11:46:34.000000000 +0100
+++ configure.ac 2011-08-12 11:46:48.000000000 +0100
-@@ -90,9 +90,6 @@
+@@ -89,9 +89,6 @@
dnl ----------------------
AC_PROG_CC
diff --git a/devel/libfirm/pkg-descr b/devel/libfirm/pkg-descr
index 87fddfd1d124..db943db14cbd 100644
--- a/devel/libfirm/pkg-descr
+++ b/devel/libfirm/pkg-descr
@@ -1,24 +1,24 @@
-libFIRM provides a graph-based intermediate representation (IR), which operates
-exclusively in SSA-form, starting at IR construction until assembler code
-emission. It offers many analyses and optimizations, provides extensive
-debugging support and includes a backend framework.
+The Firm library implements the Firm intermediate representation (IR). libFirm
+contains algorithms for construction of the SSA form directly from the
+attributed syntax tree. A set of analyses and optimisation phases is provided.
+This version includes a complete backend for the IA32 architecture, as well as
+some unfinished backends for SPARC, ARM
+* support for object oriented type hierarchies
* analyses: dominance, loop tree, execution frequency, control dependencies,
call graph, rapid type, def-use, alias analysis, class hierarchy analysis
-* optimizations: dead code elimination (happens implicitly), constant folding,
- local common subexpression elimination, arithmetic identities (happens on the
- fly), unreachable code elimination, global common subexpression elimination,
- code placement, strength reduction, scalar replacement, if-conversion,
- load/store optimization, control flow optimizations, reassociation, partial
- condition evaluation, tail recursion elimination, inlining, procedure cloning
+* Optimisations: constant folding, local common subexpression elimination,
+ global common subexpression elimination, code placement, operator strength
+ reduction, scalar replacement, load/store, control flow optimisations,
+ if-conversion, partial condition evaluation, reassociation, tail recursion
+ elimination, inlining, procedure cloning, dead code elimination, ...
* enhanced debugging support: extensive checkers, breakpoints on node creation,
entity creation, graph dumping
* lowering of intrinsics, double word arithmetics, bitfields
-* generic backend features:
- * novel SSA based register allocator
- * several SSA copy coalescing and spilling algorithms
- * algorithms for instruction and basic block scheduling
-* working ia32 backend, unfinished backends for ARM, MIPS, PPC32
+* backend with SSA based register allocation including several algorithms for
+ spilling and copy coalescing. Instruction and block scheduling, support for
+ ABI handling.
+* working ia32 backend with support for x87 and SSE2 floating point
* handwritten recursive descent C90/C99 frontend available (lang/cparser)
-WWW: http://libfirm.org/
+WWW: http://sourceforge.net/projects/libfirm/
diff --git a/devel/libfirm/pkg-plist b/devel/libfirm/pkg-plist
index dfb41b1d01a5..cc0aba68ba49 100644
--- a/devel/libfirm/pkg-plist
+++ b/devel/libfirm/pkg-plist
@@ -1,10 +1,8 @@
include/libfirm/adt/array.h
include/libfirm/adt/bipartite.h
-include/libfirm/adt/cpset.h
include/libfirm/adt/gaussjordan.h
include/libfirm/adt/gaussseidel.h
include/libfirm/adt/hashptr.h
-include/libfirm/adt/hashset.h
include/libfirm/adt/hungarian.h
include/libfirm/adt/list.h
include/libfirm/adt/obst.h
@@ -14,7 +12,6 @@ include/libfirm/adt/plist.h
include/libfirm/adt/pmap.h
include/libfirm/adt/pqueue.h
include/libfirm/adt/pset.h
-include/libfirm/adt/pset_new.h
include/libfirm/adt/set.h
include/libfirm/adt/unionfind.h
include/libfirm/adt/xmalloc.h
@@ -24,7 +21,6 @@ include/libfirm/begin.h
include/libfirm/callgraph.h
include/libfirm/cdep.h
include/libfirm/cgana.h
-include/libfirm/compound_path.h
include/libfirm/dbginfo.h
include/libfirm/end.h
include/libfirm/execfreq.h
@@ -42,7 +38,6 @@ include/libfirm/irdom.h
include/libfirm/irdump.h
include/libfirm/iredgekinds.h
include/libfirm/iredges.h
-include/libfirm/irextbb.h
include/libfirm/irflag.h
include/libfirm/irgmod.h
include/libfirm/irgopt.h
@@ -50,7 +45,6 @@ include/libfirm/irgraph.h
include/libfirm/irgwalk.h
include/libfirm/irhooks.h
include/libfirm/irio.h
-include/libfirm/irpass.h
include/libfirm/irloop.h
include/libfirm/irmemory.h
include/libfirm/irmode.h
@@ -59,6 +53,7 @@ include/libfirm/irop.h
include/libfirm/iropt.h
include/libfirm/iroptimize.h
include/libfirm/irouts.h
+include/libfirm/irpass.h
include/libfirm/irprintf.h
include/libfirm/irprog.h
include/libfirm/irtypeinfo.h
@@ -66,6 +61,7 @@ include/libfirm/irverify.h
include/libfirm/lowering.h
include/libfirm/nodeops.h
include/libfirm/opcodes.h
+include/libfirm/statev.h
include/libfirm/timing.h
include/libfirm/trouts.h
include/libfirm/tv.h