aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2009-08-03 05:29:04 +0800
committermarcus <marcus@FreeBSD.org>2009-08-03 05:29:04 +0800
commit38ca82ef265e7340fc808556029f2a62be7b3fc7 (patch)
tree8344944871c3f69d0ccb1785d6c0a55891ad6953 /devel
parentb28832d6e0bddc25116ad7fd24de9e39fba38cc8 (diff)
downloadfreebsd-ports-gnome-38ca82ef265e7340fc808556029f2a62be7b3fc7.tar.gz
freebsd-ports-gnome-38ca82ef265e7340fc808556029f2a62be7b3fc7.tar.zst
freebsd-ports-gnome-38ca82ef265e7340fc808556029f2a62be7b3fc7.zip
Make hal support optional (default on).
PR: 137364 Submitted by: "Carlos A. M. dos Santos" <unixmania@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/gnome-vfs/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index d40d6deef01b..71376861d658 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -20,7 +20,6 @@ USE_BZIP2= yes
.if !defined(REFERENCE_PORT)
-LIB_DEPENDS= hal.1:${PORTSDIR}/sysutils/hal
RUN_DEPENDS= ${LOCALBASE}/share/mime/magic:${PORTSDIR}/misc/shared-mime-info
USE_GMAKE= yes
@@ -33,7 +32,6 @@ USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-openssl \
--disable-gnutls \
--disable-howl \
- --enable-hal \
--with-hal-mount=/sbin/mount \
--with-hal-umount=/sbin/umount
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include -DPTHREAD_LIB=\"${PTHREAD_LIBS}\""
@@ -47,7 +45,8 @@ GCONF_SCHEMAS= desktop_default_applications.schemas \
system_http_proxy.schemas system_smb.schemas
OPTIONS= SAMBA "Enable SMB volume support" on \
- MDNS "Enable Bonjour/Rendezvous support" on
+ MDNS "Enable Bonjour/Rendezvous support" on \
+ HAL "Enable HAL support" on
.include <bsd.port.pre.mk>
@@ -59,6 +58,13 @@ USE_FAM= yes
LIB_DEPENDS+= krb5:${PORTSDIR}/security/heimdal
.endif
+.if !defined(WITHOUT_HAL)
+CONFIGURE_ARGS+=--enable-hal
+LIB_DEPENDS+= hal.1:${PORTSDIR}/sysutils/hal
+.else
+CONFIGURE_ARGS+=--disable-hal
+.endif
+
.if !defined(WITHOUT_SAMBA)
LIB_DEPENDS+= smbclient.0:${PORTSDIR}/net/samba-libsmbclient
PLIST_SUB+= SAMBA=""