aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjkim <jkim@FreeBSD.org>2015-10-15 08:15:24 +0800
committerjkim <jkim@FreeBSD.org>2015-10-15 08:15:24 +0800
commit3c355ae8220fd07d6bc903c421078e99cc0920e1 (patch)
tree9e3a81ed7668ee8e1fc67838a1bede940e8069e5 /devel
parentd31207a2043315c2457ff3fdd5295ce7775ba9c1 (diff)
downloadfreebsd-ports-gnome-3c355ae8220fd07d6bc903c421078e99cc0920e1.tar.gz
freebsd-ports-gnome-3c355ae8220fd07d6bc903c421078e99cc0920e1.tar.zst
freebsd-ports-gnome-3c355ae8220fd07d6bc903c421078e99cc0920e1.zip
PyOpenCL gives you easy, Pythonic access to the OpenCL parallel computation
API. What makes PyOpenCL special? - Object cleanup tied to lifetime of objects. This idiom, often called RAII in C++, makes it much easier to write correct, leak- and crash-free code. - Completeness. PyOpenCL puts the full power of OpenCL's API at your disposal, if you wish. Every obscure get_info() query and all CL calls are accessible. - Automatic Error Checking. All errors are automatically translated into Python exceptions. - Speed. PyOpenCL's base layer is written in C++, so all the niceties above are virtually free. - Helpful Documentation. - Liberal license. PyOpenCL is open-source under the MIT license and free for commercial, academic, and private use. WWW: http://mathema.tician.de/software/pyopencl
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-pyopencl/Makefile30
-rw-r--r--devel/py-pyopencl/distinfo2
-rw-r--r--devel/py-pyopencl/pkg-descr17
4 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 52ea37ce0c41..ec7419f223ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4179,6 +4179,7 @@
SUBDIR += py-pymarc
SUBDIR += py-pympler
SUBDIR += py-pymtbl
+ SUBDIR += py-pyopencl
SUBDIR += py-pyrfc3339
SUBDIR += py-pyro
SUBDIR += py-pyshapelib
diff --git a/devel/py-pyopencl/Makefile b/devel/py-pyopencl/Makefile
new file mode 100644
index 000000000000..3ed25a0fe3f8
--- /dev/null
+++ b/devel/py-pyopencl/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= pyopencl
+PORTVERSION= 2015.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Python wrapper for OpenCL
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${LOCALBASE}/include/CL/cl.h:${PORTSDIR}/devel/opencl \
+ ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy
+LIB_DEPENDS= libOpenCL.so:${PORTSDIR}/devel/ocl-icd
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pytools/__init__.py:${PORTSDIR}/devel/py-pytools \
+ ${PYTHON_SITELIBDIR}/numpy/__init__.py:${PORTSDIR}/math/py-numpy \
+ ${PYTHON_SITELIBDIR}/mako/__init__.py:${PORTSDIR}/textproc/py-mako
+
+USE_PYTHON= autoplist distutils
+USES= python
+
+CPPFLAGS+= -isystem ${LOCALBASE}/include
+
+post-install:
+ ${FIND} ${STAGEDIR}${PYTHON_SITELIBDIR}/${PORTNAME} -name '*.so' \
+ -exec ${STRIP_CMD} {} \;
+
+.include <bsd.port.mk>
diff --git a/devel/py-pyopencl/distinfo b/devel/py-pyopencl/distinfo
new file mode 100644
index 000000000000..f2eab237301b
--- /dev/null
+++ b/devel/py-pyopencl/distinfo
@@ -0,0 +1,2 @@
+SHA256 (pyopencl-2015.1.tar.gz) = 823b8c5ae438a70de87b3675c3896d04d785261cb0cbd45c01c7dd0fe9d9f6ff
+SIZE (pyopencl-2015.1.tar.gz) = 1652046
diff --git a/devel/py-pyopencl/pkg-descr b/devel/py-pyopencl/pkg-descr
new file mode 100644
index 000000000000..086d4b7a5795
--- /dev/null
+++ b/devel/py-pyopencl/pkg-descr
@@ -0,0 +1,17 @@
+PyOpenCL gives you easy, Pythonic access to the OpenCL parallel computation
+API. What makes PyOpenCL special?
+
+- Object cleanup tied to lifetime of objects. This idiom, often called RAII
+ in C++, makes it much easier to write correct, leak- and crash-free code.
+- Completeness. PyOpenCL puts the full power of OpenCL's API at your
+ disposal, if you wish. Every obscure get_info() query and all CL calls
+ are accessible.
+- Automatic Error Checking. All errors are automatically translated into
+ Python exceptions.
+- Speed. PyOpenCL's base layer is written in C++, so all the niceties above
+ are virtually free.
+- Helpful Documentation.
+- Liberal license. PyOpenCL is open-source under the MIT license and free
+ for commercial, academic, and private use.
+
+WWW: http://mathema.tician.de/software/pyopencl