aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-08-08 12:24:10 +0800
committermarino <marino@FreeBSD.org>2016-08-08 12:24:10 +0800
commit3f885892495d9a60ce73afdd4a6821f2c3bdc69f (patch)
tree6c0b241149f495a57f217edb6ac5383c63dc4f62 /devel
parent697d2caa418b6d9fbec0d0f68f7c9a5cf5bd8df7 (diff)
downloadfreebsd-ports-gnome-3f885892495d9a60ce73afdd4a6821f2c3bdc69f.tar.gz
freebsd-ports-gnome-3f885892495d9a60ce73afdd4a6821f2c3bdc69f.tar.zst
freebsd-ports-gnome-3f885892495d9a60ce73afdd4a6821f2c3bdc69f.zip
devel/pcsc-ada: Fix build on DragonFly
The Linker_Options pragma was removed upstream and the linker options moved to the common GPR file. Extend the sed command to add the -L/usr/local/lib LDFLAG for examples rather than have to patch several individual files. Needed by DF where /usr/local/lib is not a default library path for the base compiler.
Diffstat (limited to 'devel')
-rw-r--r--devel/pcsc-ada/Makefile9
1 files changed, 1 insertions, 8 deletions
diff --git a/devel/pcsc-ada/Makefile b/devel/pcsc-ada/Makefile
index b4f84f099fd0..4de0108a0e34 100644
--- a/devel/pcsc-ada/Makefile
+++ b/devel/pcsc-ada/Makefile
@@ -41,15 +41,8 @@ INTF_TEST_ALL_TARGET= itests
post-patch:
${REINPLACE_CMD} -e 's|"-lpcsclite"|${GPRLINK}|' \
+ ${WRKSRC}/pcscada_common.gpr \
${WRKSRC}/pcscada_lib.gpr
- ${REINPLACE_CMD} -e 's|gnaty.*|gnatyd",|' ${WRKSRC}/pcscada_common.gpr
- (cd ${WRKSRC} && ${REINPLACE_CMD} -e 's|"-lpcsclite");|"-L${LOCALBASE}/lib"); pragma Linker_Options ("-lpcsclite");|' \
- examples/cardd/cardd.adb \
- examples/sample/sample.adb \
- examples/pinverify/pinpad.adb \
- examples/thin/thin_example.adb \
- tests/runner.adb \
- tests/test_pcscada.adb)
do-build:
# We cannot use a redefined ALL_TARGET because MAKE_JOBS_SAFE is set