aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-03-15 20:00:15 +0800
committerijliao <ijliao@FreeBSD.org>2002-03-15 20:00:15 +0800
commit4295f316bbae2a5eaf0d7b076d0e8a1157194f8f (patch)
treec498d75a7fbb71a6ee0292755e246b8b81d55c4a /devel
parent9f2bfd5d4ef4625a7000075268ed3dc0ba3065b9 (diff)
downloadfreebsd-ports-gnome-4295f316bbae2a5eaf0d7b076d0e8a1157194f8f.tar.gz
freebsd-ports-gnome-4295f316bbae2a5eaf0d7b076d0e8a1157194f8f.tar.zst
freebsd-ports-gnome-4295f316bbae2a5eaf0d7b076d0e8a1157194f8f.zip
add py-spark 0.6.1
Scanning, Parsing, and Rewriting Kit
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-spark/Makefile29
-rw-r--r--devel/py-spark/distinfo1
-rw-r--r--devel/py-spark/pkg-comment1
-rw-r--r--devel/py-spark/pkg-descr6
-rw-r--r--devel/py-spark/pkg-plist5
6 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 8c192a151b95..3b462ec359b0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -550,6 +550,7 @@
SUBDIR += py-orbit
SUBDIR += py-period
SUBDIR += py-pqueue
+ SUBDIR += py-spark
SUBDIR += py-twisted
SUBDIR += py-unit
SUBDIR += py-xoltar-toolkit
diff --git a/devel/py-spark/Makefile b/devel/py-spark/Makefile
new file mode 100644
index 000000000000..e57ac3805922
--- /dev/null
+++ b/devel/py-spark/Makefile
@@ -0,0 +1,29 @@
+# ex:ts=8
+# Ports collection makefile for: spark
+# Date created: Mar 15, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= spark
+PORTVERSION= 0.6.1
+CATEGORIES= devel python
+MASTER_SITES= http://pages.cpsc.ucalgary.ca/~aycock/spark/
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+NO_BUILD= yes
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/spark.py ${PYTHON_SITELIBDIR}
+.if !defined(PORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in doc.html doc.tex paper.ps.gz
+ ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/py-spark/distinfo b/devel/py-spark/distinfo
new file mode 100644
index 000000000000..dac93841f54d
--- /dev/null
+++ b/devel/py-spark/distinfo
@@ -0,0 +1 @@
+MD5 (spark-0.6.1.tar.gz) = 28c4c3b1031a6a4e4c4bd42726d22b65
diff --git a/devel/py-spark/pkg-comment b/devel/py-spark/pkg-comment
new file mode 100644
index 000000000000..5e0304667063
--- /dev/null
+++ b/devel/py-spark/pkg-comment
@@ -0,0 +1 @@
+Scanning, Parsing, and Rewriting Kit
diff --git a/devel/py-spark/pkg-descr b/devel/py-spark/pkg-descr
new file mode 100644
index 000000000000..5f841e56458f
--- /dev/null
+++ b/devel/py-spark/pkg-descr
@@ -0,0 +1,6 @@
+SPARK stands for the Scanning, Parsing, and Rewriting Kit. It formerly had
+no name, and was referred to as the "little language framework." The first
+version (circa 1998) was described in the paper Compiling Little Languages
+in Python at the 7th International Python Conference.
+
+WWW: http://pages.cpsc.ucalgary.ca/~aycock/spark/
diff --git a/devel/py-spark/pkg-plist b/devel/py-spark/pkg-plist
new file mode 100644
index 000000000000..d9f5582f5718
--- /dev/null
+++ b/devel/py-spark/pkg-plist
@@ -0,0 +1,5 @@
+lib/%%PYTHON_VERSION%%/site-packages/spark.py
+%%PORTDOCS%%share/doc/spark/doc.html
+%%PORTDOCS%%share/doc/spark/doc.tex
+%%PORTDOCS%%share/doc/spark/paper.ps.gz
+%%PORTDOCS%%@dirrm share/doc/spark