aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-02-17 19:17:31 +0800
committermarino <marino@FreeBSD.org>2014-02-17 19:17:31 +0800
commit43f39e3f57c6babd95f9870400cf6ebb3458a20f (patch)
tree5c982587dda37d5f9c2cc01b2bdb3b4ed812f6cd /devel
parenta5b8c558a4d3178fddeddf4c7cbd858b5b9164f8 (diff)
downloadfreebsd-ports-gnome-43f39e3f57c6babd95f9870400cf6ebb3458a20f.tar.gz
freebsd-ports-gnome-43f39e3f57c6babd95f9870400cf6ebb3458a20f.tar.zst
freebsd-ports-gnome-43f39e3f57c6babd95f9870400cf6ebb3458a20f.zip
Add new port: devel/libspark2012
This is a source-files only Ada library required to build the upcoming port dns/ironsides.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libspark2012/Makefile19
-rw-r--r--devel/libspark2012/distinfo2
-rw-r--r--devel/libspark2012/pkg-descr6
-rw-r--r--devel/libspark2012/pkg-plist35
5 files changed, 63 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 55d1c7ea4573..a10fc313ba2e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1105,6 +1105,7 @@
SUBDIR += libsoup
SUBDIR += libsoup-gnome
SUBDIR += libsoup-reference
+ SUBDIR += libspark2012
SUBDIR += libstatgrab
SUBDIR += libstrfunc
SUBDIR += libstroke
diff --git a/devel/libspark2012/Makefile b/devel/libspark2012/Makefile
new file mode 100644
index 000000000000..0887e367f2bb
--- /dev/null
+++ b/devel/libspark2012/Makefile
@@ -0,0 +1,19 @@
+# Created by: John Marino <marino@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libspark2012
+PORTVERSION= 2012
+CATEGORIES= devel
+MASTER_SITES= http://downloads.dragonlace.net/src/
+
+MAINTAINER= marino@FreeBSD.org
+COMMENT= SPARK 2012 Spark.Ada library
+
+LICENSE= GPLv3
+
+USE_BZIP2= yes
+
+# No library is built; only the source files are installed
+# Therefore, USES=ada is not required
+
+.include <bsd.port.mk>
diff --git a/devel/libspark2012/distinfo b/devel/libspark2012/distinfo
new file mode 100644
index 000000000000..d7fa97ff55e9
--- /dev/null
+++ b/devel/libspark2012/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libspark2012-2012.tar.bz2) = 862e6b23ff44aea02ab10a4dcc2c00a9893231286d51a6bc587230366c936db2
+SIZE (libspark2012-2012.tar.bz2) = 23773
diff --git a/devel/libspark2012/pkg-descr b/devel/libspark2012/pkg-descr
new file mode 100644
index 000000000000..1c6d6a556356
--- /dev/null
+++ b/devel/libspark2012/pkg-descr
@@ -0,0 +1,6 @@
+At least one port requires exactly the Spark.Ada library that came
+with SPARK 2012. SPARK itself is not in ports -- SPARK 2014 is the
+first version planned to arrive -- so this is a separately packaged
+SPARK 2012 library to be compiled with the GNAT Ada compiler.
+
+WWW: http://www.spark-2014.org
diff --git a/devel/libspark2012/pkg-plist b/devel/libspark2012/pkg-plist
new file mode 100644
index 000000000000..01aad8ced41b
--- /dev/null
+++ b/devel/libspark2012/pkg-plist
@@ -0,0 +1,35 @@
+include/spark2012/spark-ada-command_line-unbounded_string.adb
+include/spark2012/spark-ada-command_line-unbounded_string.ads
+include/spark2012/spark-ada-command_line.adb
+include/spark2012/spark-ada-command_line.ads
+include/spark2012/spark-ada-containers.ads
+include/spark2012/spark-ada-strings-maps-not_spark.adb
+include/spark2012/spark-ada-strings-maps-not_spark.ads
+include/spark2012/spark-ada-strings-maps.adb
+include/spark2012/spark-ada-strings-maps.ads
+include/spark2012/spark-ada-strings-not_spark.adb
+include/spark2012/spark-ada-strings-not_spark.ads
+include/spark2012/spark-ada-strings-unbounded-not_spark.adb
+include/spark2012/spark-ada-strings-unbounded-not_spark.ads
+include/spark2012/spark-ada-strings-unbounded.adb
+include/spark2012/spark-ada-strings-unbounded.ads
+include/spark2012/spark-ada-strings.ads
+include/spark2012/spark-ada-text_io-not_spark.adb
+include/spark2012/spark-ada-text_io-not_spark.ads
+include/spark2012/spark-ada-text_io-unbounded_string.adb
+include/spark2012/spark-ada-text_io-unbounded_string.ads
+include/spark2012/spark-ada-text_io.adb
+include/spark2012/spark-ada-text_io.ads
+include/spark2012/spark-ada.ads
+include/spark2012/spark-crypto-debug.adb
+include/spark2012/spark-crypto-debug.ads
+include/spark2012/spark-crypto-hash-skein.adb
+include/spark2012/spark-crypto-hash-skein.ads
+include/spark2012/spark-crypto-hash.ads
+include/spark2012/spark-crypto.ads
+include/spark2012/spark-unsigned.adb
+include/spark2012/spark-unsigned.ads
+include/spark2012/spark.ads
+lib/gnat/spark2012.gpr
+@dirrmtry lib/gnat
+@dirrm include/spark2012