aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoroliver <oliver@FreeBSD.org>2004-08-13 03:14:08 +0800
committeroliver <oliver@FreeBSD.org>2004-08-13 03:14:08 +0800
commit48a53bf1839e6c48e659e5873f8fc346004ccddf (patch)
treef63e51b4f1dd6fc6d68b39c4dd91dbfd727feae0 /devel
parentffa3c38414f23f72dfd9185467f4fe57825c0b8d (diff)
downloadfreebsd-ports-gnome-48a53bf1839e6c48e659e5873f8fc346004ccddf.tar.gz
freebsd-ports-gnome-48a53bf1839e6c48e659e5873f8fc346004ccddf.tar.zst
freebsd-ports-gnome-48a53bf1839e6c48e659e5873f8fc346004ccddf.zip
fix build with gcc 3.4
Bump PORTREVISION
Diffstat (limited to 'devel')
-rw-r--r--devel/libuta/Makefile2
-rw-r--r--devel/libuta/files/patch-uta::blitters.cc39
-rw-r--r--devel/wftk/Makefile2
-rw-r--r--devel/wftk/files/patch-uta::blitters.cc39
4 files changed, 68 insertions, 14 deletions
diff --git a/devel/libuta/Makefile b/devel/libuta/Makefile
index 0ac32b61ab5a..e87b3d590e05 100644
--- a/devel/libuta/Makefile
+++ b/devel/libuta/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libuta
PORTVERSION= 0.4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/libuta/files/patch-uta::blitters.cc b/devel/libuta/files/patch-uta::blitters.cc
index d60c1d8cc82c..918a4ddd78a3 100644
--- a/devel/libuta/files/patch-uta::blitters.cc
+++ b/devel/libuta/files/patch-uta::blitters.cc
@@ -1,5 +1,5 @@
---- uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
-+++ uta/blitters.cc Sat Jul 26 01:16:18 2003
+--- /usr/obj/mnt/files/freebsd-cvs/ports/devel/libuta/work/libuta-0.4.4/uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
++++ /usr/obj/mnt/files/freebsd-cvs/ports/devel/libuta/work/libuta-0.4.4/uta/blitters.cc Thu Aug 12 20:58:40 2004
@@ -20,6 +20,7 @@
#include "blitters.h"
@@ -8,12 +8,39 @@
namespace uta {
-@@ -27,6 +28,8 @@
- #undef X86_ASSEMBLER
+@@ -28,6 +29,8 @@
#endif
#if !defined(X86_ASSEMBLER)
-+
-+using namespace std;
++using namespace std;
++
/** Apply const gamma value.
Blit just copies alpha value of the source to the destination surface.
+ */
+@@ -163,7 +166,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }
+@@ -211,7 +214,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }
+@@ -960,7 +963,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index 0ac32b61ab5a..e87b3d590e05 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libuta
PORTVERSION= 0.4.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/wftk/files/patch-uta::blitters.cc b/devel/wftk/files/patch-uta::blitters.cc
index d60c1d8cc82c..918a4ddd78a3 100644
--- a/devel/wftk/files/patch-uta::blitters.cc
+++ b/devel/wftk/files/patch-uta::blitters.cc
@@ -1,5 +1,5 @@
---- uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
-+++ uta/blitters.cc Sat Jul 26 01:16:18 2003
+--- /usr/obj/mnt/files/freebsd-cvs/ports/devel/libuta/work/libuta-0.4.4/uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
++++ /usr/obj/mnt/files/freebsd-cvs/ports/devel/libuta/work/libuta-0.4.4/uta/blitters.cc Thu Aug 12 20:58:40 2004
@@ -20,6 +20,7 @@
#include "blitters.h"
@@ -8,12 +8,39 @@
namespace uta {
-@@ -27,6 +28,8 @@
- #undef X86_ASSEMBLER
+@@ -28,6 +29,8 @@
#endif
#if !defined(X86_ASSEMBLER)
-+
-+using namespace std;
++using namespace std;
++
/** Apply const gamma value.
Blit just copies alpha value of the source to the destination surface.
+ */
+@@ -163,7 +166,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }
+@@ -211,7 +214,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }
+@@ -960,7 +963,7 @@
+ only using the lower 16bits of result
+ ... this is somehow dumb, but only executed once
+ per scanline, so I do not care */
+- movd_r2m(mm1,(unsigned int*)dPtr);
++ movd_r2m(mm1,*(mmx_t*)dPtr);
+ sPtr += 4;
+ dPtr += 4;
+ }