aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-01 21:29:03 +0800
committerclsung <clsung@FreeBSD.org>2006-08-01 21:29:03 +0800
commit4e1960c337c63eeda537c0bbba59a16469273ab3 (patch)
treed17f995a59ac6eb65e8a85445ad3844b7ecff0c0 /devel
parentce0c4fd1dbceda17499f3dc1f2ee0283ac3c224e (diff)
downloadfreebsd-ports-gnome-4e1960c337c63eeda537c0bbba59a16469273ab3.tar.gz
freebsd-ports-gnome-4e1960c337c63eeda537c0bbba59a16469273ab3.tar.zst
freebsd-ports-gnome-4e1960c337c63eeda537c0bbba59a16469273ab3.zip
Add p5-IPC-Mmap-Share 0.03, safely share structures among processes
using anonymous mmap. PR: ports/100417 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IPC-Mmap-Share/Makefile31
-rw-r--r--devel/p5-IPC-Mmap-Share/distinfo3
-rw-r--r--devel/p5-IPC-Mmap-Share/pkg-descr7
-rw-r--r--devel/p5-IPC-Mmap-Share/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f7f168104c7e..da121577a219 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1097,6 +1097,7 @@
SUBDIR += p5-IPC-Locker
SUBDIR += p5-IPC-MM
SUBDIR += p5-IPC-Mmap
+ SUBDIR += p5-IPC-Mmap-Share
SUBDIR += p5-IPC-Open3-Simple
SUBDIR += p5-IPC-Run
SUBDIR += p5-IPC-Run3
diff --git a/devel/p5-IPC-Mmap-Share/Makefile b/devel/p5-IPC-Mmap-Share/Makefile
new file mode 100644
index 000000000000..55754a039620
--- /dev/null
+++ b/devel/p5-IPC-Mmap-Share/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-IPC-Mmap-Share
+# Date created: 2006-07-17
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IPC-Mmap-Share
+PORTVERSION= 0.03
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IPC
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Safely share structures among processes using anonymous mmap
+
+RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/Mmap.pm:${PORTSDIR}/devel/p5-IPC-Mmap
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= IPC::Mmap::Share.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800 # Inherited from devel/p5-IPC-Mmap
+IGNORE= requires perl 5.8.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-IPC-Mmap-Share/distinfo b/devel/p5-IPC-Mmap-Share/distinfo
new file mode 100644
index 000000000000..804702ddac06
--- /dev/null
+++ b/devel/p5-IPC-Mmap-Share/distinfo
@@ -0,0 +1,3 @@
+MD5 (IPC-Mmap-Share-0.03.tar.gz) = 3da7999876994b764e6c68f7433351ad
+SHA256 (IPC-Mmap-Share-0.03.tar.gz) = 06fc0a22915da747dfc83bbbeb48916e49e4c94d09ee4174d08a95ef9fd34f41
+SIZE (IPC-Mmap-Share-0.03.tar.gz) = 12054
diff --git a/devel/p5-IPC-Mmap-Share/pkg-descr b/devel/p5-IPC-Mmap-Share/pkg-descr
new file mode 100644
index 000000000000..41bcaae3c62a
--- /dev/null
+++ b/devel/p5-IPC-Mmap-Share/pkg-descr
@@ -0,0 +1,7 @@
+The IPC::Mmap::Share was born out of the need to share structures
+among processes that come from the same ancestor. It tries to do so in
+a very simple and straightforward manner. Just create an
+IPC::Mmap::Share object, and use set to store your data and get to get
+it back.
+
+WWW: http://search.cpan.org/dist/IPC-Mmap-Share/
diff --git a/devel/p5-IPC-Mmap-Share/pkg-plist b/devel/p5-IPC-Mmap-Share/pkg-plist
new file mode 100644
index 000000000000..cf1cbe9f642f
--- /dev/null
+++ b/devel/p5-IPC-Mmap-Share/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap/Share/.packlist
+%%SITE_PERL%%/IPC/Mmap/Share.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap/Share
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/Mmap
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC
+@dirrmtry %%SITE_PERL%%/IPC/Mmap
+@dirrmtry %%SITE_PERL%%/IPC