aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordemon <demon@FreeBSD.org>2003-07-11 00:08:00 +0800
committerdemon <demon@FreeBSD.org>2003-07-11 00:08:00 +0800
commit4f2587ee8d65af5694abb3af5a48f6b31c8db399 (patch)
tree32ad82479aaf5369a34c154b70394e6f8585a7f3 /devel
parent4f7cce2ec0d33b10484b51972698b91559a3a6b5 (diff)
downloadfreebsd-ports-gnome-4f2587ee8d65af5694abb3af5a48f6b31c8db399.tar.gz
freebsd-ports-gnome-4f2587ee8d65af5694abb3af5a48f6b31c8db399.tar.zst
freebsd-ports-gnome-4f2587ee8d65af5694abb3af5a48f6b31c8db399.zip
Update to version 0.19.
PR: 54320 Submitted by: Mathieu Arnold <m@absolight.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Module-Build/Makefile8
-rw-r--r--devel/p5-Module-Build/distinfo2
-rw-r--r--devel/p5-Module-Build/pkg-descr10
-rw-r--r--devel/p5-Module-Build/pkg-plist16
4 files changed, 23 insertions, 13 deletions
diff --git a/devel/p5-Module-Build/Makefile b/devel/p5-Module-Build/Makefile
index 829deb9317de..9e5d32fa8d47 100644
--- a/devel/p5-Module-Build/Makefile
+++ b/devel/p5-Module-Build/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Module-Build
-PORTVERSION= 0.18
+PORTVERSION= 0.19
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Module
@@ -15,8 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= demon@FreeBSD.org
COMMENT= Build and install Perl modules
-BUILD_DEPENDS= ${SITE_PERL}/Module/Info.pm:${PORTSDIR}/devel/p5-Module-Info \
- ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
+BUILD_DEPENDS= ${SITE_PERL}/Archive/Tar.pm:${PORTSDIR}/archivers/p5-Archive-Tar \
${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -27,5 +26,8 @@ PERL_CONFIGURE= yes
.if ${PERL_LEVEL} > 500600
BUILD_DEPENDS+= ${SITE_PERL}/ExtUtils/ParseXS.pm:${PORTSDIR}/devel/p5-ExtUtils-ParseXS
.endif
+.if ${PERL_LEVEL} < 500600
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
.include <bsd.port.post.mk>
diff --git a/devel/p5-Module-Build/distinfo b/devel/p5-Module-Build/distinfo
index c5cc96c0dd53..dd33e98f8619 100644
--- a/devel/p5-Module-Build/distinfo
+++ b/devel/p5-Module-Build/distinfo
@@ -1 +1 @@
-MD5 (Module-Build-0.18.tar.gz) = 18f35dc7e5751f8e56554f564293d0bc
+MD5 (Module-Build-0.19.tar.gz) = c1647888d63033446583f9697fb7b426
diff --git a/devel/p5-Module-Build/pkg-descr b/devel/p5-Module-Build/pkg-descr
index 5b794a7836c7..6ed3436ac658 100644
--- a/devel/p5-Module-Build/pkg-descr
+++ b/devel/p5-Module-Build/pkg-descr
@@ -1,2 +1,8 @@
-Module::Build is a means for build and install Perl modules.
-It is meant to be a replacement for ExtUtils::MakeMaker.
+Module::Build is a system for building, testing, and installing Perl modules.
+It is meant to be a replacement for ExtUtils::MakeMaker. Developers may alter
+the behavior of the module through subclassing in a much more straightforward
+way than with MakeMaker. It also does not require a make on your system - most
+of the Module::Build code is pure-perl and written in a very cross-platform
+way.
+
+WWW: http://search.cpan.org/dist/Module-Build/
diff --git a/devel/p5-Module-Build/pkg-plist b/devel/p5-Module-Build/pkg-plist
index 13699e523951..53e278261f13 100644
--- a/devel/p5-Module-Build/pkg-plist
+++ b/devel/p5-Module-Build/pkg-plist
@@ -1,17 +1,19 @@
%%SITE_PERL%%/Module/Build.pm
-%%SITE_PERL%%/Module/Build/Base.pm
%%SITE_PERL%%/Module/Build/Compat.pm
-%%SITE_PERL%%/Module/Build/Platform/Amiga.pm
+%%SITE_PERL%%/Module/Build/Base.pm
+%%SITE_PERL%%/Module/Build/PPMMaker.pm
+%%SITE_PERL%%/Module/Build/Cookbook.pm
%%SITE_PERL%%/Module/Build/Platform/darwin.pm
-%%SITE_PERL%%/Module/Build/Platform/Default.pm
-%%SITE_PERL%%/Module/Build/Platform/EBCDIC.pm
%%SITE_PERL%%/Module/Build/Platform/MacOS.pm
-%%SITE_PERL%%/Module/Build/Platform/MPEiX.pm
%%SITE_PERL%%/Module/Build/Platform/RiscOS.pm
-%%SITE_PERL%%/Module/Build/Platform/Unix.pm
-%%SITE_PERL%%/Module/Build/Platform/VMS.pm
%%SITE_PERL%%/Module/Build/Platform/VOS.pm
%%SITE_PERL%%/Module/Build/Platform/Windows.pm
+%%SITE_PERL%%/Module/Build/Platform/Unix.pm
+%%SITE_PERL%%/Module/Build/Platform/Amiga.pm
+%%SITE_PERL%%/Module/Build/Platform/EBCDIC.pm
+%%SITE_PERL%%/Module/Build/Platform/MPEiX.pm
+%%SITE_PERL%%/Module/Build/Platform/VMS.pm
+%%SITE_PERL%%/Module/Build/Platform/Default.pm
@dirrm %%SITE_PERL%%/Module/Build/Platform
@dirrm %%SITE_PERL%%/Module/Build
@unexec rmdir %D/%%SITE_PERL%%/Module 2>/dev/null || true