aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-07-21 21:56:48 +0800
committerclsung <clsung@FreeBSD.org>2006-07-21 21:56:48 +0800
commit5116eb3add1f9514152af8ad0d77d7d62cbf30b2 (patch)
tree6aae88350864148ac5cf6c29df6c3a6f4f609685 /devel
parent8ec1a946f11140acce8a774c68c06dadf8f11527 (diff)
downloadfreebsd-ports-gnome-5116eb3add1f9514152af8ad0d77d7d62cbf30b2.tar.gz
freebsd-ports-gnome-5116eb3add1f9514152af8ad0d77d7d62cbf30b2.tar.zst
freebsd-ports-gnome-5116eb3add1f9514152af8ad0d77d7d62cbf30b2.zip
Add p5-SVN-Statistics 0.031, SVN::Statistics - perl module to create
subversion statistics. PR: ports/100134 Submitted by: Yuan-Chung Hsiao <ychsiao at ychsiao.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-SVN-Statistics/Makefile34
-rw-r--r--devel/p5-SVN-Statistics/distinfo3
-rw-r--r--devel/p5-SVN-Statistics/pkg-descr3
-rw-r--r--devel/p5-SVN-Statistics/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 79c8059da7d0..0969177076ae 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1259,6 +1259,7 @@
SUBDIR += p5-SVN-Mirror
SUBDIR += p5-SVN-Notify
SUBDIR += p5-SVN-Simple
+ SUBDIR += p5-SVN-Statistics
SUBDIR += p5-SVN-Web
SUBDIR += p5-Scalar-Util-Clone
SUBDIR += p5-Search-Binary
diff --git a/devel/p5-SVN-Statistics/Makefile b/devel/p5-SVN-Statistics/Makefile
new file mode 100644
index 000000000000..bb005c1c4a11
--- /dev/null
+++ b/devel/p5-SVN-Statistics/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-SVN-Statistics
+# Date created: 2006-07-12
+# Whom: Yuan-Chung Hsiao <ychsiao@ychsiao.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= SVN-Statistics
+PORTVERSION= 0.031
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= SVN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ychsiao@ychsiao.org
+COMMENT= SVN::Statistics - perl module to create subversion statistics
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/SVN/Core.pm:${PORTSDIR}/devel/subversion-perl \
+ p5-RRDTool-OO>=0:${PORTSDIR}/devel/p5-RRDTool-OO \
+ p5-Data-Dumper-Simple>=0:${PORTSDIR}/devel/p5-Data-Dumper-Simple \
+ p5-IO-Toolkit>=0:${PORTSDIR}/devel/p5-IO-Toolkit
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= SVN::Statistics.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= currently requires at least Perl 5.8. Please install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-SVN-Statistics/distinfo b/devel/p5-SVN-Statistics/distinfo
new file mode 100644
index 000000000000..5803805a513c
--- /dev/null
+++ b/devel/p5-SVN-Statistics/distinfo
@@ -0,0 +1,3 @@
+MD5 (SVN-Statistics-0.031.tar.gz) = ab6d0d4ec326785cde76cfc6dac00b55
+SHA256 (SVN-Statistics-0.031.tar.gz) = 32761b74c364f809b76ea80c03b4ff5b5c5e145671c2bf4fa7ccd17397a926ff
+SIZE (SVN-Statistics-0.031.tar.gz) = 4375
diff --git a/devel/p5-SVN-Statistics/pkg-descr b/devel/p5-SVN-Statistics/pkg-descr
new file mode 100644
index 000000000000..0fe47b2d1327
--- /dev/null
+++ b/devel/p5-SVN-Statistics/pkg-descr
@@ -0,0 +1,3 @@
+SVN::Statistics - perl module to create subversion statistics
+
+WWW: http://search.cpan.org/dist/SVN-Statistics
diff --git a/devel/p5-SVN-Statistics/pkg-plist b/devel/p5-SVN-Statistics/pkg-plist
new file mode 100644
index 000000000000..185062adfaf6
--- /dev/null
+++ b/devel/p5-SVN-Statistics/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/SVN/Statistics.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Statistics/.packlist
+@dirrmtry %%SITE_PERL%%/SVN
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN/Statistics
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/SVN