aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-04-01 18:52:15 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-04-01 18:52:15 +0800
commit5130b23050e5bbdfec0bb19f1f3de186d7c43102 (patch)
tree7b3b6d6b2a7a12a33014625e4be451c0fc0b9731 /devel
parent4545a080c4db822d2ebca385eca2b845d0d2f650 (diff)
downloadfreebsd-ports-gnome-5130b23050e5bbdfec0bb19f1f3de186d7c43102.tar.gz
freebsd-ports-gnome-5130b23050e5bbdfec0bb19f1f3de186d7c43102.tar.zst
freebsd-ports-gnome-5130b23050e5bbdfec0bb19f1f3de186d7c43102.zip
Add PHP 7.x support
- Use mysqli instead of mysqli - Update pecl-APCu dependency - Remove unnecessary PHP_EXT_DIR check - Sort USE_PHP - Bump PORTREVISION for dependency change Differential Revision: https://reviews.freebsd.org/D8647 Approved by: grembo (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/phabricator/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/devel/phabricator/Makefile b/devel/phabricator/Makefile
index afa48ee03011..5d1dca131705 100644
--- a/devel/phabricator/Makefile
+++ b/devel/phabricator/Makefile
@@ -2,6 +2,7 @@
PORTNAME= phabricator
PORTVERSION= 20161003
+PORTREVISION= 1
CATEGORIES= devel
PKGNAMEPREFIX= php5-
@@ -24,18 +25,19 @@ SHEBANG_FILES= externals/httpful/build \
externals/restful/build-phar \
scripts/install/install_rhel-derivs.sh \
scripts/install/install_ubuntu.sh
-USE_PHP= ctype curl fileinfo hash iconv filter mbstring mysql openssl \
+USE_PHP= ctype curl fileinfo filter hash iconv mbstring mysqli openssl \
pcntl posix
-IGNORE_WITH_PHP= 70
GD_USE= PHP=gd
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MOPCACHE}
-. if ${PHP_EXT_DIR:C|[^0-9]||g} >= 20121212
USE_PHP+= opcache
+. if ${PHP_VER} >= 70
RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu
+. else
+RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/apcu.so:devel/pecl-APCu4
. endif
.endif