aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-12 12:33:33 +0800
committerwill <will@FreeBSD.org>2003-06-12 12:33:33 +0800
commit51360e00a9fdcd4362d0256c73c294e475de98df (patch)
tree05805ebd70cca34372cbbda272130f899ac27a86 /devel
parent17a58fc4c39e5669674783f2de7d180cc6d617ea (diff)
downloadfreebsd-ports-gnome-51360e00a9fdcd4362d0256c73c294e475de98df.tar.gz
freebsd-ports-gnome-51360e00a9fdcd4362d0256c73c294e475de98df.tar.zst
freebsd-ports-gnome-51360e00a9fdcd4362d0256c73c294e475de98df.zip
Fix malloc problem.
PR: 47039 Submitted by: Chris Knight <chris@aims.com.au>, "Simon 'corecode' Schubert" <corecode@corecode.ath.cx>
Diffstat (limited to 'devel')
-rw-r--r--devel/cxref/Makefile1
-rw-r--r--devel/cxref/files/patch-af16
2 files changed, 17 insertions, 0 deletions
diff --git a/devel/cxref/Makefile b/devel/cxref/Makefile
index bce3dd563e91..c957a2322b2a 100644
--- a/devel/cxref/Makefile
+++ b/devel/cxref/Makefile
@@ -7,6 +7,7 @@
PORTNAME= cxref
PORTVERSION= 1.5d
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE} \
ftp://ftp.demon.co.uk/pub/unix/tools/
diff --git a/devel/cxref/files/patch-af b/devel/cxref/files/patch-af
new file mode 100644
index 000000000000..e01cfd9cfe09
--- /dev/null
+++ b/devel/cxref/files/patch-af
@@ -0,0 +1,16 @@
+--- comment.c.orig Tue Nov 16 20:11:38 1999
++++ comment.c Tue Jan 14 16:17:17 2003
+@@ -158,8 +158,11 @@
+
+ if(comment)
+ {
+- malloc_comment=Realloc(malloc_comment,strlen(comment)+1);
+- strcpy(malloc_comment,comment);
++ if(malloc_comment != comment)
++ {
++ malloc_comment=Realloc(malloc_comment,strlen(comment)+1);
++ strcpy(malloc_comment,comment);
++ }
+ current_comment=malloc_comment;
+ }
+ else