aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2011-11-23 12:32:53 +0800
committertota <tota@FreeBSD.org>2011-11-23 12:32:53 +0800
commit55011217da33464b74344d00a0072b5d9e2230fd (patch)
tree2155cdd33984ddacd27847e0d45872f765f93663 /devel
parent31c50decaadc0ebbdbe9ec78605406771c0b0a03 (diff)
downloadfreebsd-ports-gnome-55011217da33464b74344d00a0072b5d9e2230fd.tar.gz
freebsd-ports-gnome-55011217da33464b74344d00a0072b5d9e2230fd.tar.zst
freebsd-ports-gnome-55011217da33464b74344d00a0072b5d9e2230fd.zip
- Add a new port: devel/py-ordereddict
Drop-in substitute for Py2.7's new collections.OrderedDict. The recipe has big-oh performance that matches regular dictionaries (amortized O(1) insertion/deletion/lookup and O(n) iteration/repr/copy/equality_testing). WWW: http://pypi.python.org/pypi/ordereddict Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-ordereddict/Makefile27
-rw-r--r--devel/py-ordereddict/distinfo2
-rw-r--r--devel/py-ordereddict/pkg-descr6
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 19eca7240f05..3b658a5e9b22 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3105,6 +3105,7 @@
SUBDIR += py-omniorb
SUBDIR += py-optik
SUBDIR += py-orbit
+ SUBDIR += py-ordereddict
SUBDIR += py-parsedatetime
SUBDIR += py-parsing
SUBDIR += py-pefile
diff --git a/devel/py-ordereddict/Makefile b/devel/py-ordereddict/Makefile
new file mode 100644
index 000000000000..f98d8d378f99
--- /dev/null
+++ b/devel/py-ordereddict/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-ordereddict
+# Date created: 2011-11-20
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ordereddict
+PORTVERSION= 1.1
+CATEGORIES= devel
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A drop-in substitute for Py2.7's new collections
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_PYTHON= 2.4-2.7 # for graphics/py-blockdiag
+USE_PYDISTUTILS= yes
+
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/ordereddict.py \
+ %%PYTHON_SITELIBDIR%%/ordereddict.pyc \
+ %%PYTHON_SITELIBDIR%%/ordereddict.pyo
+
+.include <bsd.port.mk>
diff --git a/devel/py-ordereddict/distinfo b/devel/py-ordereddict/distinfo
new file mode 100644
index 000000000000..881b3a51f5d2
--- /dev/null
+++ b/devel/py-ordereddict/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ordereddict-1.1.tar.gz) = 1c35b4ac206cef2d24816c89f89cf289dd3d38cf7c449bb3fab7bf6d43f01b1f
+SIZE (ordereddict-1.1.tar.gz) = 2114
diff --git a/devel/py-ordereddict/pkg-descr b/devel/py-ordereddict/pkg-descr
new file mode 100644
index 000000000000..4f4f6f1e4133
--- /dev/null
+++ b/devel/py-ordereddict/pkg-descr
@@ -0,0 +1,6 @@
+Drop-in substitute for Py2.7's new collections.OrderedDict. The
+recipe has big-oh performance that matches regular dictionaries
+(amortized O(1) insertion/deletion/lookup and O(n)
+iteration/repr/copy/equality_testing).
+
+WWW: http://pypi.python.org/pypi/ordereddict