aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-03-16 01:14:59 +0800
committermiwi <miwi@FreeBSD.org>2009-03-16 01:14:59 +0800
commit55c31a85f8b3d2a8534dfcbcecc2e3b85de10a3c (patch)
tree3b99322e7025897f6a77dfd5d7d6ec7c3e2494b8 /devel
parent4f6fee6eb5dd6f7be9be0541f14fb559446e4200 (diff)
downloadfreebsd-ports-gnome-55c31a85f8b3d2a8534dfcbcecc2e3b85de10a3c.tar.gz
freebsd-ports-gnome-55c31a85f8b3d2a8534dfcbcecc2e3b85de10a3c.tar.zst
freebsd-ports-gnome-55c31a85f8b3d2a8534dfcbcecc2e3b85de10a3c.zip
File::ShareDir::PAR provides the same functionality as File::ShareDir but tries
hard to be compatible with PAR packaged applications. The problem is, that the concept of having a distribution or module specific share directory becomes a little hazy when you're loading everything from a single file. PAR uses an @INC hook to intercept any attempt to load a module. File::ShareDir uses the directory structure that is typically found in the directories that are listed in @INC for storing the shared data. In a PAR enviroment, this is not necessarily possible. WARNING: This module contains highly experimental code. If you want to load modules from .par files using PAR and then access their shared directory using File::ShareDir, you probably have no choice but to use it. WWW: http://search.cpan.org/dist/File-ShareDir-PAR/ PR: ports/132406 Submitted by: Cezary Morga <cm at therek.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-ShareDir-PAR/Makefile27
-rw-r--r--devel/p5-File-ShareDir-PAR/distinfo3
-rw-r--r--devel/p5-File-ShareDir-PAR/pkg-descr16
-rw-r--r--devel/p5-File-ShareDir-PAR/pkg-plist10
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f426b3420a05..c8e3593785bd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1374,6 +1374,7 @@
SUBDIR += p5-File-ReadBackwards
SUBDIR += p5-File-Remove
SUBDIR += p5-File-ShareDir
+ SUBDIR += p5-File-ShareDir-PAR
SUBDIR += p5-File-Slurp
SUBDIR += p5-File-Slurp-Tree
SUBDIR += p5-File-Stream
diff --git a/devel/p5-File-ShareDir-PAR/Makefile b/devel/p5-File-ShareDir-PAR/Makefile
new file mode 100644
index 000000000000..8398365b680f
--- /dev/null
+++ b/devel/p5-File-ShareDir-PAR/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-File-ShareDir-PAR
+# Date created: March 8th 2009
+# Whom: Cezary Morga <cm@therek.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-ShareDir-PAR
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= cm@therek.net
+COMMENT= Perl5 File::ShareDir module with PAR support
+
+BUILD_DEPENDS= ${SITE_PERL}/Class/Inspector.pm:${PORTSDIR}/devel/p5-Class-Inspector \
+ ${SITE_PERL}/File/ShareDir.pm:${PORTSDIR}/devel/p5-File-ShareDir \
+ ${SITE_PERL}/PAR.pm:${PORTSDIR}/devel/p5-PAR \
+ ${SITE_PERL}/${PERL_ARCH}/Params/Util.pm:${PORTSDIR}/devel/p5-Params-Util
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= File::ShareDir::PAR.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-ShareDir-PAR/distinfo b/devel/p5-File-ShareDir-PAR/distinfo
new file mode 100644
index 000000000000..620799186964
--- /dev/null
+++ b/devel/p5-File-ShareDir-PAR/distinfo
@@ -0,0 +1,3 @@
+MD5 (File-ShareDir-PAR-0.04.tar.gz) = 12de4325a2111afa743b66effac90be7
+SHA256 (File-ShareDir-PAR-0.04.tar.gz) = db2abc38012ccd2e7ca8fff3708a90858db9a250bf6fc9b0c91f2a2590dc9d98
+SIZE (File-ShareDir-PAR-0.04.tar.gz) = 27174
diff --git a/devel/p5-File-ShareDir-PAR/pkg-descr b/devel/p5-File-ShareDir-PAR/pkg-descr
new file mode 100644
index 000000000000..ec2b257a4baa
--- /dev/null
+++ b/devel/p5-File-ShareDir-PAR/pkg-descr
@@ -0,0 +1,16 @@
+File::ShareDir::PAR provides the same functionality as File::ShareDir but tries
+hard to be compatible with PAR packaged applications.
+
+The problem is, that the concept of having a distribution or module specific
+share directory becomes a little hazy when you're loading everything from
+a single file. PAR uses an @INC hook to intercept any attempt to load a module.
+File::ShareDir uses the directory structure that is typically found in the
+directories that are listed in @INC for storing the shared data. In a PAR
+enviroment, this is not necessarily possible.
+
+WARNING:
+This module contains highly experimental code. If you want to load
+modules from .par files using PAR and then access their shared directory
+using File::ShareDir, you probably have no choice but to use it.
+
+WWW: http://search.cpan.org/dist/File-ShareDir-PAR/
diff --git a/devel/p5-File-ShareDir-PAR/pkg-plist b/devel/p5-File-ShareDir-PAR/pkg-plist
new file mode 100644
index 000000000000..a25bf9f87b09
--- /dev/null
+++ b/devel/p5-File-ShareDir-PAR/pkg-plist
@@ -0,0 +1,10 @@
+%%SITE_PERL%%/auto/share/dist/File-ShareDir-PAR/sample.txt
+%%SITE_PERL%%/auto/share/dist/File-ShareDir-PAR/subdir/sample.txt
+%%SITE_PERL%%/auto/share/module/File-ShareDir-PAR/test_file.txt
+%%SITE_PERL%%/File/ShareDir/PAR.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ShareDir/PAR/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/ShareDir/PAR
+@dirrmtry %%SITE_PERL%%/auto/share/module/File-ShareDir-PAR
+@dirrmtry %%SITE_PERL%%/auto/share/dist/File-ShareDir-PAR/subdir
+@dirrmtry %%SITE_PERL%%/auto/share/dist/File-ShareDir-PAR
+@dirrmtry %%SITE_PERL%%/File/ShareDir