aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2003-04-13 14:58:39 +0800
committerdinoex <dinoex@FreeBSD.org>2003-04-13 14:58:39 +0800
commit5a86ad125208eaab45d6437ea0bab8b8187b0f5e (patch)
tree546ffd302cfe5b1feea0b952f4aa4c9d284125f8 /devel
parent4effb674a3ca2866d43c62740014811bce605e2a (diff)
downloadfreebsd-ports-gnome-5a86ad125208eaab45d6437ea0bab8b8187b0f5e.tar.gz
freebsd-ports-gnome-5a86ad125208eaab45d6437ea0bab8b8187b0f5e.tar.zst
freebsd-ports-gnome-5a86ad125208eaab45d6437ea0bab8b8187b0f5e.zip
- Use libobjc.so
- Cleanup - Use bsd.gnustep.mk PR: 50479
Diffstat (limited to 'devel')
-rw-r--r--devel/gnustep-make/Makefile19
-rw-r--r--devel/projectcenter.app/Makefile32
2 files changed, 11 insertions, 40 deletions
diff --git a/devel/gnustep-make/Makefile b/devel/gnustep-make/Makefile
index 195f8e6e8d67..1e6e30849f00 100644
--- a/devel/gnustep-make/Makefile
+++ b/devel/gnustep-make/Makefile
@@ -17,15 +17,8 @@ MASTER_SITE_SUBDIR= core
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep makefile package
-USE_GCC= 3.2
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 300000
-BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
-.endif
-
PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c" \
CFLAGS="${CFLAGS} -D_THREAD_SAFE"
@@ -33,14 +26,10 @@ CONFIGURE_TARGET=
USE_GMAKE= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
-NO_MTREE= yes
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
-.endif
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
post-configure:
${MV} ${WRKSRC}/config.make ${WRKSRC}/config.make.sed
diff --git a/devel/projectcenter.app/Makefile b/devel/projectcenter.app/Makefile
index fc94e482a362..edd7f11fa0ba 100644
--- a/devel/projectcenter.app/Makefile
+++ b/devel/projectcenter.app/Makefile
@@ -16,31 +16,21 @@ MASTER_SITE_SUBDIR= dev-apps
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A development environment for GNUstep
-BUILD_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-BUILD_DEPENDS+= ${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
-RUN_DEPENDS= ${BACKBUNDLEDIR}/libgnustep-back:${PORTSDIR}/x11-toolkits/gnustep-back
-
PREFIX= ${LOCALBASE}/GNUstep
+NO_MTREE= yes
WRKSRC= ${WRKDIR}/ProjectCenter
USE_GMAKE= yes
MAKEFILE= GNUmakefile
-MAKE_ENV= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}" \
- ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu"
+MAKE_ENV+= ADDITIONAL_INCLUDE_DIRS="-I${WRKSRC}"
+MAKE_ENV+= ADDITIONAL_LIB_DIRS="-L${WRKSRC}/PCLib/shared_obj/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu"
ALL_TARGET=
-NO_MTREE= yes
-USE_GCC= 3.2
-
-BACKBUNDLEDIR= ${PREFIX}/System/Library/Bundles/libgnustep-back.bundle/${GNU_ARCH}/${OPSYS:L}/gnu-gnu-gnu
.include <bsd.port.pre.mk>
-.if ${MACHINE_ARCH} == "i386"
-GNU_ARCH= ix86
-.else
-GNU_ARCH= ${MACHINE_ARCH}
-.endif
-
-PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
+USE_GNUSTEP_BACK= yes
+USE_GNUSTEP_BUILD= yes
+USE_GNUSTEP_INSTALL= yes
+.include "${PORTSDIR}/devel/gnustep/bsd.gnustep.mk"
# XXX This is ugly beyond measure. Don't tell anyone I did this.
post-extract:
@@ -54,12 +44,4 @@ post-patch:
${WRKSRC}/${file}.sed > ${WRKSRC}/${file}
.endfor
-do-build:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
-
-do-install:
- @(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
- ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
-
.include <bsd.port.post.mk>