aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2010-04-24 19:52:07 +0800
committermiwi <miwi@FreeBSD.org>2010-04-24 19:52:07 +0800
commit5e45b3bcb6d054058fe276d039b72a3096b8a2c1 (patch)
tree4f27adb564ac4f1a0a1bbc01e51516176f2b2a14 /devel
parent1a4ade8df688f0da85ea0a1cfb2c075538c02ca2 (diff)
downloadfreebsd-ports-gnome-5e45b3bcb6d054058fe276d039b72a3096b8a2c1.tar.gz
freebsd-ports-gnome-5e45b3bcb6d054058fe276d039b72a3096b8a2c1.tar.zst
freebsd-ports-gnome-5e45b3bcb6d054058fe276d039b72a3096b8a2c1.zip
systemu is a portable replacement for popen4 in ruby.
systemu can be used on any platform to return status, stdout, and stderr of any command. unlike other methods like open3/popen4 there is zero danger of full pipes or threading issues hanging your process or subprocess. WWW: http://codeforpeople.com/lib/ruby/systemu/ PR: ports/145845 Submitted by: renchap at cocoa-x.com
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-systemu/Makefile23
-rw-r--r--devel/rubygem-systemu/distinfo3
-rw-r--r--devel/rubygem-systemu/pkg-descr7
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index cfcfd6a5f57d..58744959adcb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2996,6 +2996,7 @@
SUBDIR += rubygem-stomp
SUBDIR += rubygem-stream
SUBDIR += rubygem-streetaddress
+ SUBDIR += rubygem-systemu
SUBDIR += rubygem-templater
SUBDIR += rubygem-transactionsimple
SUBDIR += rubygem-treetop
diff --git a/devel/rubygem-systemu/Makefile b/devel/rubygem-systemu/Makefile
new file mode 100644
index 000000000000..fbc074fada31
--- /dev/null
+++ b/devel/rubygem-systemu/Makefile
@@ -0,0 +1,23 @@
+# Ports collection makefile for: rubygem-systemu
+# Date created: 18 Mar 2010
+# Whom: renchap@cocoa-x.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= systemu
+PORTVERSION= 1.2.0
+CATEGORIES= devel
+MASTER_SITES= http://gemcutter.org/gems/
+
+MAINTAINER= renchap@cocoa-x.com
+COMMENT= A portable replacement for popen4
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+# we care about not passing -A to allow HTTP redirects
+FETCH_ARGS= -pRr
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-systemu/distinfo b/devel/rubygem-systemu/distinfo
new file mode 100644
index 000000000000..5aa95a10e6f9
--- /dev/null
+++ b/devel/rubygem-systemu/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/systemu-1.2.0.gem) = 5d7eeb75395e74683c16542c0adbb984
+SHA256 (rubygem/systemu-1.2.0.gem) = 49fcf0393ab111ab454bd2caa3e230179fc4cb1ac6a47dc8083cb9ae43cde3f0
+SIZE (rubygem/systemu-1.2.0.gem) = 8704
diff --git a/devel/rubygem-systemu/pkg-descr b/devel/rubygem-systemu/pkg-descr
new file mode 100644
index 000000000000..6d584b236892
--- /dev/null
+++ b/devel/rubygem-systemu/pkg-descr
@@ -0,0 +1,7 @@
+systemu is a portable replacement for popen4 in ruby.
+
+systemu can be used on any platform to return status, stdout, and stderr of
+any command. unlike other methods like open3/popen4 there is zero danger of
+full pipes or threading issues hanging your process or subprocess.
+
+WWW: http://codeforpeople.com/lib/ruby/systemu/