aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorak <ak@FreeBSD.org>2012-06-25 12:15:50 +0800
committerak <ak@FreeBSD.org>2012-06-25 12:15:50 +0800
commit60979559fcb0d746133013f327e5d5e06658a074 (patch)
tree405353c9080123863f2fedaa42e8801637968ae4 /devel
parent77abb0bc8cfedd52e471c22b28566de4364f658c (diff)
downloadfreebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.tar.gz
freebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.tar.zst
freebsd-ports-gnome-60979559fcb0d746133013f327e5d5e06658a074.zip
- Convert to optionsNG
- Pet portlint - Remove pkg-plist from security/dropbear Approved by: eadler (mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-SDL/Makefile36
1 files changed, 20 insertions, 16 deletions
diff --git a/devel/p5-SDL/Makefile b/devel/p5-SDL/Makefile
index 9d69989ecc89..97fc3deaf99c 100644
--- a/devel/p5-SDL/Makefile
+++ b/devel/p5-SDL/Makefile
@@ -17,39 +17,43 @@ COMMENT= Perl Bindings for SDL
BUILD_DEPENDS= p5-YAML>=0.62:${PORTSDIR}/textproc/p5-YAML
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+ jpeg:${PORTSDIR}/graphics/jpeg
USE_SDL= sdl
PERL_MODBUILD= yes
-OPTIONS= SDL_TTF "Enable TTF support" on \
- SDL_NET "Enable NET support" on \
- SDL_GFX "Enable GFX support" on \
- SDL_IMAGE "Enable IMAGE support" on \
- SDL_MIXER "Enable MIXER support" on
+OPTIONS_DEFINE= GFX IMAGE MIXER NET TTF
-.include <bsd.port.pre.mk>
+GFX_DESC= Enable GFX support
+IMAGE_DESC= Enable IMAGE support
+MIXER_DESC= Enable MIXER support
+NET_DESC= Enable NET support
+TTF_DESC= Enable TTF support
-.if !defined(WITHOUT_SDL_TTF)
-USE_SDL+= ttf
-.endif
+OPTIONS_DEFAULT= GFX IMAGE MIXER NET TTF
-.if !defined(WITHOUT_SDL_NET)
-USE_SDL+= net
-.endif
+.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_SDL_GFX)
+.if ${PORT_OPTIONS:MGFX}
USE_SDL+= gfx
.endif
-.if !defined(WITHOUT_SDL_IMAGE)
+.if ${PORT_OPTIONS:MIMAGE}
USE_SDL+= image
.endif
-.if !defined(WITHOUT_SDL_MIXER)
+.if ${PORT_OPTIONS:MMIXER}
USE_SDL+= mixer
.endif
+.if ${PORT_OPTIONS:MNET}
+USE_SDL+= net
+.endif
+
+.if ${PORT_OPTIONS:MTTF}
+USE_SDL+= ttf
+.endif
+
USE_LDCONFIG= yes
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}