aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2013-01-15 20:16:13 +0800
committertobez <tobez@FreeBSD.org>2013-01-15 20:16:13 +0800
commit61cbddc4cf98d17c197a95f25d9c45f00ca8c157 (patch)
tree7b159c970af03452c42fad780071672a93e2a513 /devel
parent1d92bf96144ac160eba36fd498ca8c52ff27baf7 (diff)
downloadfreebsd-ports-gnome-61cbddc4cf98d17c197a95f25d9c45f00ca8c157.tar.gz
freebsd-ports-gnome-61cbddc4cf98d17c197a95f25d9c45f00ca8c157.tar.zst
freebsd-ports-gnome-61cbddc4cf98d17c197a95f25d9c45f00ca8c157.zip
- Update to 0.42
- Remove unnecessary BUILD_DEPENDS and TEST_DEPENDS - Set IS_INTERACTIVE, and add patch file to support BATCH mode Changes: http://search.cpan.org/dist/Inline-CPP/Changes PR: 174874 Submitted by: Po-Chien Lin
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Inline-CPP/Makefile28
-rw-r--r--devel/p5-Inline-CPP/distinfo4
-rw-r--r--devel/p5-Inline-CPP/files/opt-patch-Makefile.PL15
3 files changed, 29 insertions, 18 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
index ea11fc84f920..23648a6f6326 100644
--- a/devel/p5-Inline-CPP/Makefile
+++ b/devel/p5-Inline-CPP/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: Inline::CPP
-# Date created: 14 Dec 2001
-# Whom: Sergey Skvortsov <skv@protey.ru>
-#
+# Created by: Sergey Skvortsov <skv@protey.ru>
# $FreeBSD$
-#
PORTNAME= Inline-CPP
-PORTVERSION= 0.39
+PORTVERSION= 0.42
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -16,22 +12,22 @@ COMMENT= Write Perl subroutines and classes in C++
LICENSE= ART10
-BUILD_DEPENDS= p5-Inline>=0.50:${PORTSDIR}/devel/p5-Inline \
+RUN_DEPENDS= p5-Inline>=0.51:${PORTSDIR}/devel/p5-Inline \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
-RUN_DEPENDS:= ${BUILD_DEPENDS}
-TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
- p5-Test-Kwalitee>=0:${PORTSDIR}/devel/p5-Test-Kwalitee
PERL_CONFIGURE= yes
+.if defined(BATCH) || defined(PACKAGE_BUILDING)
+EXTRA_PATCHES+= ${FILESDIR}/opt-patch-Makefile.PL
+.else
+IS_INTERACTIVE= yes
+.endif
+
MAN3= Inline::CPP.3 \
Inline::CPP::Config.3 \
Inline::CPP::grammar.3
-.include <bsd.port.pre.mk>
-
-.if ${PERL_LEVEL} < 501400
-TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
-.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's/g++/${CXX}/' ${WRKSRC}/Makefile.PL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/p5-Inline-CPP/distinfo b/devel/p5-Inline-CPP/distinfo
index 63a403bb41ea..da575555cb93 100644
--- a/devel/p5-Inline-CPP/distinfo
+++ b/devel/p5-Inline-CPP/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Inline-CPP-0.39.tar.gz) = 601c765aac9a0e33e478dec7da983949187c9f570598297f535c67aff4d64a69
-SIZE (Inline-CPP-0.39.tar.gz) = 44089
+SHA256 (Inline-CPP-0.42.tar.gz) = 824dd95e92dcb4bc719f5859245f35ef2626ff9b0a7a28b46eef36ddfb341890
+SIZE (Inline-CPP-0.42.tar.gz) = 50592
diff --git a/devel/p5-Inline-CPP/files/opt-patch-Makefile.PL b/devel/p5-Inline-CPP/files/opt-patch-Makefile.PL
new file mode 100644
index 000000000000..377fc652d0f2
--- /dev/null
+++ b/devel/p5-Inline-CPP/files/opt-patch-Makefile.PL
@@ -0,0 +1,15 @@
+--- ./Makefile.PL.orig 2013-01-01 03:27:22.000000000 +0800
++++ ./Makefile.PL 2013-01-01 03:30:52.000000000 +0800
+@@ -121,10 +121,9 @@
+ print "This will configure and build Inline::C++.\n";
+
+ my $cpp_compiler
+- = prompt( "What default C++ compiler would you like to use?", $cc_guess );
++ = $cc_guess;
+
+-my $libs = prompt( "What default libraries would you like to include?",
+- $libs_guess );
++my $libs = $libs_guess;
+
+ #============================================================================
+ # Test whether the compiler prefers <iostream> or <iostream.h>.