aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2011-12-25 10:41:07 +0800
committerwxs <wxs@FreeBSD.org>2011-12-25 10:41:07 +0800
commit62bb748aaa7f01276d04b6603ed7396f6f717d3e (patch)
tree40b543c1b577d2cb80d78a624204cf9d988d9a95 /devel
parent66e7917d17817c5e5e30fd956d68b26072aaaa88 (diff)
downloadfreebsd-ports-gnome-62bb748aaa7f01276d04b6603ed7396f6f717d3e.tar.gz
freebsd-ports-gnome-62bb748aaa7f01276d04b6603ed7396f6f717d3e.tar.zst
freebsd-ports-gnome-62bb748aaa7f01276d04b6603ed7396f6f717d3e.zip
LibHTP is a security-aware parser for the HTTP protocol and the related bits
and pieces. The goals of the project, in the order of importance, are as follows: 1. Completeness of coverage; LibHTP must be able to parse virtually all traffic that is found in practice. 2. Permissive parsing; LibHTP must never fail to parse a stream that would be parsed by some other web server. 3. Awareness of evasion techniques; LibHTP must be able to detect and effectively deal with various evasion techniques, producing, where practical, identical or practically identical results as the web server processing the same traffic stream. 4. Performance; The performance must be adequate for the desired tasks. Completeness and security are often detremental to performance. Our idea of handling the conflicting requirements is to put the library user in control, allowing him to choose the most desired library characteristic. Author: Ivan Ristic <ivanr@webkreator.com> WWW: http://www.libhtp.org
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libhtp/Makefile22
-rw-r--r--devel/libhtp/distinfo2
-rw-r--r--devel/libhtp/pkg-descr23
-rw-r--r--devel/libhtp/pkg-plist13
5 files changed, 61 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2b6439b1554f..7a0009bd8df4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -849,6 +849,7 @@
SUBDIR += libhash
SUBDIR += libhid
SUBDIR += libhoard
+ SUBDIR += libhtp
SUBDIR += libical
SUBDIR += libinotify
SUBDIR += libiqxmlrpc
diff --git a/devel/libhtp/Makefile b/devel/libhtp/Makefile
new file mode 100644
index 000000000000..e3f8b5a574cc
--- /dev/null
+++ b/devel/libhtp/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: libhtp
+# Date created: 19 December 2011
+# Whom: wxs@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= libhtp
+PORTVERSION= 0.2.6
+CATEGORIES= devel
+MASTER_SITES= http://www.openinfosecfoundation.org/download/
+
+MAINTAINER= wxs@FreeBSD.org
+COMMENT= Security-aware parser for the HTTP protocol
+
+WRKSRC= ${WRKDIR}/htp-${PORTVERSION}
+
+USE_LDCONFIG= yes
+USE_GNOME= pkgconfig gnomehack
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libhtp/distinfo b/devel/libhtp/distinfo
new file mode 100644
index 000000000000..9bff2332d2a3
--- /dev/null
+++ b/devel/libhtp/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libhtp-0.2.6.tar.gz) = 59c4f46ccd88430f6d392cdc43bb926a84336d07595657510435a6c112eede87
+SIZE (libhtp-0.2.6.tar.gz) = 354351
diff --git a/devel/libhtp/pkg-descr b/devel/libhtp/pkg-descr
new file mode 100644
index 000000000000..cc0c95982829
--- /dev/null
+++ b/devel/libhtp/pkg-descr
@@ -0,0 +1,23 @@
+LibHTP is a security-aware parser for the HTTP protocol and the related bits
+and pieces. The goals of the project, in the order of importance, are as
+follows:
+
+ 1. Completeness of coverage; LibHTP must be able to parse virtually all
+ traffic that is found in practice.
+
+ 2. Permissive parsing; LibHTP must never fail to parse a stream that would
+ be parsed by some other web server.
+
+ 3. Awareness of evasion techniques; LibHTP must be able to detect and
+ effectively deal with various evasion techniques, producing, where
+ practical, identical or practically identical results as the web
+ server processing the same traffic stream.
+
+ 4. Performance; The performance must be adequate for the desired tasks.
+ Completeness and security are often detremental to performance. Our
+ idea of handling the conflicting requirements is to put the library
+ user in control, allowing him to choose the most desired library
+ characteristic.
+
+Author: Ivan Ristic <ivanr@webkreator.com>
+WWW: http://www.libhtp.org
diff --git a/devel/libhtp/pkg-plist b/devel/libhtp/pkg-plist
new file mode 100644
index 000000000000..21794183cdf0
--- /dev/null
+++ b/devel/libhtp/pkg-plist
@@ -0,0 +1,13 @@
+include/htp/hooks.h
+include/htp/htp_decompressors.h
+include/htp/bstr.h
+include/htp/utf8_decoder.h
+include/htp/dslib.h
+include/htp/htp.h
+lib/libhtp-0.2.so
+lib/libhtp-0.2.so.1
+lib/libhtp.a
+lib/libhtp.la
+lib/libhtp.so
+libdata/pkgconfig/htp.pc
+@dirrm include/htp