aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:49:29 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:49:29 +0800
commit633a911dd69a29bb8cee55abdd321f8bd0d07ffa (patch)
treeec126d19ea10a4974110139f6941a7a765949029 /devel
parent5659112bee4d5fbcb476c8f16f95be2294b526fa (diff)
downloadfreebsd-ports-gnome-633a911dd69a29bb8cee55abdd321f8bd0d07ffa.tar.gz
freebsd-ports-gnome-633a911dd69a29bb8cee55abdd321f8bd0d07ffa.tar.zst
freebsd-ports-gnome-633a911dd69a29bb8cee55abdd321f8bd0d07ffa.zip
Add p5-File-Binary 0.3, a perl interface to modify and read binary files.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-File-Binary/Makefile23
-rw-r--r--devel/p5-File-Binary/distinfo1
-rw-r--r--devel/p5-File-Binary/pkg-comment1
-rw-r--r--devel/p5-File-Binary/pkg-descr6
-rw-r--r--devel/p5-File-Binary/pkg-plist3
6 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d9598b25faac..ed489f79f19d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -234,6 +234,7 @@
SUBDIR += p5-Devel-Symdump
SUBDIR += p5-Errno
SUBDIR += p5-File-BasicFlock
+ SUBDIR += p5-File-Binary
SUBDIR += p5-File-Lock
SUBDIR += p5-File-MMagic
SUBDIR += p5-File-Slurp
diff --git a/devel/p5-File-Binary/Makefile b/devel/p5-File-Binary/Makefile
new file mode 100644
index 000000000000..f98d36fe950c
--- /dev/null
+++ b/devel/p5-File-Binary/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: File-Binary
+# Date created: Mon Jan 1 11:48:35 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Binary
+PORTVERSION= 0.3
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= File
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= File::Binary.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-File-Binary/distinfo b/devel/p5-File-Binary/distinfo
new file mode 100644
index 000000000000..8f0231365f6e
--- /dev/null
+++ b/devel/p5-File-Binary/distinfo
@@ -0,0 +1 @@
+MD5 (File-Binary-0.3.tar.gz) = d15f164258ddd1af6905825de9068229
diff --git a/devel/p5-File-Binary/pkg-comment b/devel/p5-File-Binary/pkg-comment
new file mode 100644
index 000000000000..62d7330ac4c1
--- /dev/null
+++ b/devel/p5-File-Binary/pkg-comment
@@ -0,0 +1 @@
+Perl interface to modify and read binary files
diff --git a/devel/p5-File-Binary/pkg-descr b/devel/p5-File-Binary/pkg-descr
new file mode 100644
index 000000000000..40032158f6b8
--- /dev/null
+++ b/devel/p5-File-Binary/pkg-descr
@@ -0,0 +1,6 @@
+File::Binary is a perl module that provides an interface to modify
+and read binary files.
+
+Author: Simon Wistow <simon@twoshortplanks.com>
+
+--will
diff --git a/devel/p5-File-Binary/pkg-plist b/devel/p5-File-Binary/pkg-plist
new file mode 100644
index 000000000000..404a7d60aa06
--- /dev/null
+++ b/devel/p5-File-Binary/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/File/Binary.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Binary/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/File/Binary