aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsperber <sperber@FreeBSD.org>2012-12-01 07:52:43 +0800
committersperber <sperber@FreeBSD.org>2012-12-01 07:52:43 +0800
commit6417c901f2ce5967e14e2c2181c98694ec43f2ee (patch)
tree74bc07a9cdfba0ce9c13b8703fd18fbf0e9927fb /devel
parent8f29a67cb345ef2dec548bc6d01b6263d6c4434d (diff)
downloadfreebsd-ports-gnome-6417c901f2ce5967e14e2c2181c98694ec43f2ee.tar.gz
freebsd-ports-gnome-6417c901f2ce5967e14e2c2181c98694ec43f2ee.tar.zst
freebsd-ports-gnome-6417c901f2ce5967e14e2c2181c98694ec43f2ee.zip
- Update to version 3.9.1
- Add LICENSE - Add MAKE_JOBS_SAFE PR: ports/171984 Submitted by: KATO Tsuguru <tkato432 _at_ yahoo.com> Approved by: beat (mentor) Feature safe: yes
Diffstat (limited to 'devel')
-rw-r--r--devel/jrtplib/Makefile18
-rw-r--r--devel/jrtplib/distinfo4
-rw-r--r--devel/jrtplib/files/patch-src-rtperrors.cpp11
-rw-r--r--devel/jrtplib/files/patch-src-rtperrors.h10
-rw-r--r--devel/jrtplib/pkg-plist14
5 files changed, 26 insertions, 31 deletions
diff --git a/devel/jrtplib/Makefile b/devel/jrtplib/Makefile
index 660b1bd3d021..88bdc96c8367 100644
--- a/devel/jrtplib/Makefile
+++ b/devel/jrtplib/Makefile
@@ -2,23 +2,25 @@
# $FreeBSD$
PORTNAME= jrtplib
-PORTVERSION= 3.7.1
+PORTVERSION= 3.9.1
CATEGORIES= devel
MASTER_SITES= http://research.edm.uhasselt.be/jori/jrtplib/
MAINTAINER= ports@FreeBSD.org
COMMENT= Object-oriented RTP library written in C++
-USE_AUTOTOOLS= libtool
-GNU_CONFIGURE= yes
-USE_GMAKE= yes
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.MIT
+
+USE_BZIP2= yes
+USE_CMAKE= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --disable-jthread
+MAKE_JOBS_SAFE= yes
-PLIST_SUB+= JRTPLIB_VER=${PORTVERSION}
+PLIST_SUB= JRTPLIB_VER="${PORTVERSION}"
post-patch:
- @${REINPLACE_CMD} -e 's|\$$(libdir)/pkgconfig|\$$(prefix)/libdata/pkgconfig|' \
- ${WRKSRC}/pkgconfig/Makefile.in
+ @${REINPLACE_CMD} -e \
+ '/pkgconfig/s|$${LIBRARY_INSTALL_DIR}|$${CMAKE_INSTALL_PREFIX}/libdata|' ${WRKSRC}/CMakeLists.txt
.include <bsd.port.mk>
diff --git a/devel/jrtplib/distinfo b/devel/jrtplib/distinfo
index 9341c683c93e..8f52a844337c 100644
--- a/devel/jrtplib/distinfo
+++ b/devel/jrtplib/distinfo
@@ -1,2 +1,2 @@
-SHA256 (jrtplib-3.7.1.tar.gz) = 9c098c4778aee40df55fd00831a29d247336c2a7a3ac0692e79e5693b6d87cd6
-SIZE (jrtplib-3.7.1.tar.gz) = 474916
+SHA256 (jrtplib-3.9.1.tar.bz2) = a99a0d5764e8ca9f84bf167e6de91c3092ce3633497bacc3e2d13b69aa4403df
+SIZE (jrtplib-3.9.1.tar.bz2) = 117735
diff --git a/devel/jrtplib/files/patch-src-rtperrors.cpp b/devel/jrtplib/files/patch-src-rtperrors.cpp
deleted file mode 100644
index 7abf4425b426..000000000000
--- a/devel/jrtplib/files/patch-src-rtperrors.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/rtperrors.cpp.orig 2008-11-17 14:35:19.000000000 +0800
-+++ src/rtperrors.cpp 2008-11-17 14:35:50.000000000 +0800
-@@ -38,7 +38,7 @@
- struct RTPErrorInfo
- {
- int code;
-- char *description;
-+ std::string description;
- };
-
- static RTPErrorInfo ErrorDescriptions[]=
diff --git a/devel/jrtplib/files/patch-src-rtperrors.h b/devel/jrtplib/files/patch-src-rtperrors.h
index 06b0405e6b77..b280abe449d4 100644
--- a/devel/jrtplib/files/patch-src-rtperrors.h
+++ b/devel/jrtplib/files/patch-src-rtperrors.h
@@ -1,10 +1,10 @@
---- src/rtperrors.h Tue Feb 21 17:31:13 2006
-+++ src/rtperrors.h Sun Apr 16 20:46:09 2006
-@@ -34,6 +34,7 @@
-
+--- src/rtperrors.h.orig 2011-08-29 22:43:27.000000000 +0900
++++ src/rtperrors.h 2012-09-24 22:25:22.000000000 +0900
+@@ -39,6 +39,7 @@
#define RTPERRORS_H
+ #include "rtpconfig.h"
+#include <cstdio>
#include <string>
- std::string RTPGetErrorString(int errcode);
+ namespace jrtplib
diff --git a/devel/jrtplib/pkg-plist b/devel/jrtplib/pkg-plist
index 67ea0f17ddfa..ba6915b2f140 100644
--- a/devel/jrtplib/pkg-plist
+++ b/devel/jrtplib/pkg-plist
@@ -11,13 +11,13 @@ include/jrtplib3/rtcpsdespacket.h
include/jrtplib3/rtcpsrpacket.h
include/jrtplib3/rtcpunknownpacket.h
include/jrtplib3/rtpaddress.h
+include/jrtplib3/rtpbyteaddress.h
include/jrtplib3/rtpcollisionlist.h
include/jrtplib3/rtpconfig.h
-include/jrtplib3/rtpconfig_unix.h
-include/jrtplib3/rtpconfig_win.h
include/jrtplib3/rtpdebug.h
include/jrtplib3/rtpdefines.h
include/jrtplib3/rtperrors.h
+include/jrtplib3/rtpexternaltransmitter.h
include/jrtplib3/rtpfaketransmitter.h
include/jrtplib3/rtphashtable.h
include/jrtplib3/rtpinternalsourcedata.h
@@ -33,6 +33,9 @@ include/jrtplib3/rtppacket.h
include/jrtplib3/rtppacketbuilder.h
include/jrtplib3/rtppollthread.h
include/jrtplib3/rtprandom.h
+include/jrtplib3/rtprandomrand48.h
+include/jrtplib3/rtprandomrands.h
+include/jrtplib3/rtprandomurandom.h
include/jrtplib3/rtprawpacket.h
include/jrtplib3/rtpsession.h
include/jrtplib3/rtpsessionparams.h
@@ -43,13 +46,14 @@ include/jrtplib3/rtpstructs.h
include/jrtplib3/rtptimeutilities.h
include/jrtplib3/rtptransmitter.h
include/jrtplib3/rtptypes.h
-include/jrtplib3/rtptypes_unix.h
include/jrtplib3/rtptypes_win.h
include/jrtplib3/rtpudpv4transmitter.h
include/jrtplib3/rtpudpv6transmitter.h
-lib/libjrtp-%%JRTPLIB_VER%%.so
+lib/cmake/JRTPLIB/JRTPLIBConfig.cmake
lib/libjrtp.a
-lib/libjrtp.la
lib/libjrtp.so
+lib/libjrtp.so.%%JRTPLIB_VER%%
libdata/pkgconfig/jrtplib.pc
+@dirrm lib/cmake/JRTPLIB
+@dirrmtry lib/cmake
@dirrm include/jrtplib3