aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2005-12-28 21:58:46 +0800
committertobez <tobez@FreeBSD.org>2005-12-28 21:58:46 +0800
commit6cd1e78533ce5fe3bf3bbad397a8a2b1b59b5447 (patch)
tree787a19d6327dec9a60f6d41bd76e7b5615605550 /devel
parent28f14b4838a2f55a9357373837b6c449aa31592e (diff)
downloadfreebsd-ports-gnome-6cd1e78533ce5fe3bf3bbad397a8a2b1b59b5447.tar.gz
freebsd-ports-gnome-6cd1e78533ce5fe3bf3bbad397a8a2b1b59b5447.tar.zst
freebsd-ports-gnome-6cd1e78533ce5fe3bf3bbad397a8a2b1b59b5447.zip
Add devel/p5-Proc-Queue 1.16, a Perl module that overrides fork and
related syscalls to limit the number of spawned children transparently.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Proc-Queue/Makefile28
-rw-r--r--devel/p5-Proc-Queue/distinfo3
-rw-r--r--devel/p5-Proc-Queue/pkg-descr5
-rw-r--r--devel/p5-Proc-Queue/pkg-plist6
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 870c71cf36ce..52774273c761 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1097,6 +1097,7 @@
SUBDIR += p5-Proc-PID-File
SUBDIR += p5-Proc-PIDFile
SUBDIR += p5-Proc-ProcessTable
+ SUBDIR += p5-Proc-Queue
SUBDIR += p5-Proc-Reliable
SUBDIR += p5-Proc-Simple
SUBDIR += p5-Project-Gantt
diff --git a/devel/p5-Proc-Queue/Makefile b/devel/p5-Proc-Queue/Makefile
new file mode 100644
index 000000000000..99bdcafae19d
--- /dev/null
+++ b/devel/p5-Proc-Queue/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: devel/p5-Proc-Queue
+# Date created: 28 December 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Proc-Queue
+PORTVERSION= 1.16
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Proc
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Proc::Queue - limit the number of child processes running
+
+PERL_CONFIGURE= yes
+
+MAN3= Proc::Queue.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-Proc-Queue/distinfo b/devel/p5-Proc-Queue/distinfo
new file mode 100644
index 000000000000..8ebfbf09aa0b
--- /dev/null
+++ b/devel/p5-Proc-Queue/distinfo
@@ -0,0 +1,3 @@
+MD5 (Proc-Queue-1.16.tar.gz) = 154b98dba798de3aa9dc3d3b87ab583e
+SHA256 (Proc-Queue-1.16.tar.gz) = 1e9b95851fad236856d4c11ea84a6a4e02257b87dc7814f7eb36cf56ceb08fb2
+SIZE (Proc-Queue-1.16.tar.gz) = 7890
diff --git a/devel/p5-Proc-Queue/pkg-descr b/devel/p5-Proc-Queue/pkg-descr
new file mode 100644
index 000000000000..fe219c89eca7
--- /dev/null
+++ b/devel/p5-Proc-Queue/pkg-descr
@@ -0,0 +1,5 @@
+This module lets you parallelise a perl program using the fork, exit,
+wait and waitpid calls as usual but without taking care of creating too
+many processes and overloading the machine.
+
+WWW: http://search.cpan.org/dist/Proc-Queue/
diff --git a/devel/p5-Proc-Queue/pkg-plist b/devel/p5-Proc-Queue/pkg-plist
new file mode 100644
index 000000000000..b666a4292b8f
--- /dev/null
+++ b/devel/p5-Proc-Queue/pkg-plist
@@ -0,0 +1,6 @@
+%%SITE_PERL%%/Proc/Queue.pm
+%%SITE_PERL%%/Proc/example.pl
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Queue/.packlist
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc/Queue 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Proc 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Proc 2>/dev/null || true