aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2011-08-14 04:36:01 +0800
committerpgj <pgj@FreeBSD.org>2011-08-14 04:36:01 +0800
commit6e135b6c706842f8e6c69f6b9f4d3b60fd851fd9 (patch)
tree81501f9b749cfe1a8b4e262da6bfaca4f999ac38 /devel
parent940434bd226f00a49ffd163033f8b616f0ad438a (diff)
downloadfreebsd-ports-gnome-6e135b6c706842f8e6c69f6b9f4d3b60fd851fd9.tar.gz
freebsd-ports-gnome-6e135b6c706842f8e6c69f6b9f4d3b60fd851fd9.tar.zst
freebsd-ports-gnome-6e135b6c706842f8e6c69f6b9f4d3b60fd851fd9.zip
This package defines a class, Hashable, for types that can be converted
to a hash value. This class exists for the benefit of hashing-based data structures. The package provides instances for basic types and a way to combine hash values. WWW: http://github.com/tibbe/hashable Obtained from: FreeBSD Haskell
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/hs-hashable/Makefile21
-rw-r--r--devel/hs-hashable/distinfo2
-rw-r--r--devel/hs-hashable/pkg-descr6
4 files changed, 30 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4e569d7bf889..5c484b65319d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -606,6 +606,7 @@
SUBDIR += hs-haddock
SUBDIR += hs-haddock-docs
SUBDIR += hs-happy
+ SUBDIR += hs-hashable
SUBDIR += hs-hashed-storage
SUBDIR += hs-haskeline
SUBDIR += hs-haskell-platform
diff --git a/devel/hs-hashable/Makefile b/devel/hs-hashable/Makefile
new file mode 100644
index 000000000000..efa640baf0d7
--- /dev/null
+++ b/devel/hs-hashable/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: hs-hashable
+# Date created: July 17, 2011
+# Whom: haskell@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashable
+PORTVERSION= 1.1.2.1
+CATEGORIES= devel haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= A class for types that can be converted to a hash value
+
+LICENSE= BSD
+
+CABAL_SETUP= Setup.hs
+USE_CABAL= text>=0.11.0.5
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/devel/hs-hashable/distinfo b/devel/hs-hashable/distinfo
new file mode 100644
index 000000000000..05e9c80f9447
--- /dev/null
+++ b/devel/hs-hashable/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/hashable-1.1.2.1.tar.gz) = 9df1d1333b11967bf5b714e957c5f75688e6f73f9dfb77da556b5696b21cbdce
+SIZE (cabal/hashable-1.1.2.1.tar.gz) = 8406
diff --git a/devel/hs-hashable/pkg-descr b/devel/hs-hashable/pkg-descr
new file mode 100644
index 000000000000..7626cba88a8f
--- /dev/null
+++ b/devel/hs-hashable/pkg-descr
@@ -0,0 +1,6 @@
+This package defines a class, Hashable, for types that can be converted
+to a hash value. This class exists for the benefit of hashing-based data
+structures. The package provides instances for basic types and a way to
+combine hash values.
+
+WWW: http://github.com/tibbe/hashable