aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjgh <jgh@FreeBSD.org>2012-12-15 16:11:02 +0800
committerjgh <jgh@FreeBSD.org>2012-12-15 16:11:02 +0800
commit70a22535ca2de5e4f33684c1bf9cd6935c22c0c0 (patch)
treea82b4a654391f723c6295c86d2f5b0913dbb9891 /devel
parent0e7cd6894171862822bab243a4dc607c6d49de14 (diff)
downloadfreebsd-ports-gnome-70a22535ca2de5e4f33684c1bf9cd6935c22c0c0.tar.gz
freebsd-ports-gnome-70a22535ca2de5e4f33684c1bf9cd6935c22c0c0.tar.zst
freebsd-ports-gnome-70a22535ca2de5e4f33684c1bf9cd6935c22c0c0.zip
- add new port: devel/libslave
This is a library that allows any arbitrary C++ application to connect to a Mysql replication master and read/parse the replication binary logs. In effect, any application can now act like a Mysql replication slave, without having to compile or link with any Mysql server code. One important use-case for this library is for receiving changes in the master database in real-time, without having the store the master's data on the client server. WWW: https://github.com/Begun/libslave PR: 174335 Submitted by: g.veniamin@googlemail.com
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libslave/Makefile56
-rw-r--r--devel/libslave/distinfo2
-rw-r--r--devel/libslave/pkg-descr12
-rw-r--r--devel/libslave/pkg-plist15
5 files changed, 86 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9925aaca7540..c3d1f9202fe5 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1030,6 +1030,7 @@
SUBDIR += libsigcx
SUBDIR += libsigsegv
SUBDIR += libslang2
+ SUBDIR += libslave
SUBDIR += libsoup
SUBDIR += libsoup-gnome
SUBDIR += libsoup-reference
diff --git a/devel/libslave/Makefile b/devel/libslave/Makefile
new file mode 100644
index 000000000000..6355ed3a6995
--- /dev/null
+++ b/devel/libslave/Makefile
@@ -0,0 +1,56 @@
+# Created by: Gvozdikov Veniamin <g.veniamin@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= libslave
+PORTVERSION= 0.0.${DATE}
+CATEGORIES= devel databases
+MASTER_SITES= GH GHC
+
+MAINTAINER= g.veniamin@googlemail.com
+COMMENT= Mysql replication client library, embeddable into your C++ application
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
+
+DATE= 20121210
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_MYSQL= client
+USE_GITHUB= yes
+GH_ACCOUNT= Begun
+GH_COMMIT= 64d548b
+GH_TAGNAME= master
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= STATIC TEST EXAMPLES
+STATIC_DESC= Build static lib
+TEST_DESC= Build test binary
+
+OPTIONS_DEFAULT=STATIC
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MSTATIC}
+PLIST_SUB+= STATIC=""
+CMAKE_ARGS+= -DENABLE_STATIC=ON
+.else
+CMAKE_ARGS+= -DENABLE_STATIC=OFF
+PLIST_SUB+= STATIC="@comment "
+.endif
+
+.if ${PORT_OPTIONS:MTEST}
+PLIST_SUB+= TEST=""
+CMAKE_ARGS+= -DENABLE_TEST=ON
+.else
+CMAKE_ARGS+= -DENABLE_TEST=OFF
+PLIST_SUB+= TEST="@comment "
+.endif
+
+post-install:
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC} && ${COPYTREE_SHARE} test ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/libslave/distinfo b/devel/libslave/distinfo
new file mode 100644
index 000000000000..d5d2cab57db9
--- /dev/null
+++ b/devel/libslave/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libslave-0.0.20121210.tar.gz) = 5062e6c3757af510e7f82eeaa463f13628d5a7a24b77b268fbc10e0fe1929d25
+SIZE (libslave-0.0.20121210.tar.gz) = 30057
diff --git a/devel/libslave/pkg-descr b/devel/libslave/pkg-descr
new file mode 100644
index 000000000000..c3f75b0cd7c9
--- /dev/null
+++ b/devel/libslave/pkg-descr
@@ -0,0 +1,12 @@
+This is a library that allows any arbitrary C++ application to connect
+to a Mysql replication master and read/parse the replication binary
+logs.
+
+In effect, any application can now act like a Mysql replication slave,
+without having to compile or link with any Mysql server code.
+
+One important use-case for this library is for receiving changes in
+the master database in real-time, without having the store the
+master's data on the client server.
+
+WWW: https://github.com/Begun/libslave
diff --git a/devel/libslave/pkg-plist b/devel/libslave/pkg-plist
new file mode 100644
index 000000000000..fd0ca7511dae
--- /dev/null
+++ b/devel/libslave/pkg-plist
@@ -0,0 +1,15 @@
+%%TEST%%bin/slave_test
+include/libslave/Logging.h
+include/libslave/Slave.h
+include/libslave/SlaveStats.h
+include/libslave/collate.h
+include/libslave/field.h
+include/libslave/nanomysql.h
+include/libslave/recordset.h
+include/libslave/relayloginfo.h
+include/libslave/slave_log_event.h
+include/libslave/table.h
+%%STATIC%%lib/libslave.a
+lib/libslave.so
+lib/libslave.so.0
+@dirrm include/libslave