aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordanilo <danilo@FreeBSD.org>2013-10-05 11:26:09 +0800
committerdanilo <danilo@FreeBSD.org>2013-10-05 11:26:09 +0800
commit71551902a690a1f486c620c4ed45e804e3e770b6 (patch)
tree8462dfd210c0e48c10f8723d6c5ae4b3f5a7ec6c /devel
parentbc8caf6af6b907e7bb7d1a10378effbcd1e6bd04 (diff)
downloadfreebsd-ports-gnome-71551902a690a1f486c620c4ed45e804e3e770b6.tar.gz
freebsd-ports-gnome-71551902a690a1f486c620c4ed45e804e3e770b6.tar.zst
freebsd-ports-gnome-71551902a690a1f486c620c4ed45e804e3e770b6.zip
- Update from r243 to r251
- Change clang dependence to clang33 - Change maintainer email to @FreeBSD.org - Add "Created by" line to header - Simplify BUILD_DEPENDS - Convert LIB_DEPENDS to new syntax - Simplify LDFLAGS - Use libc++ on CURRENT - Add a patch to insert an necessary header - Add stage support Approved by: wg / culot (mentors, implicit)
Diffstat (limited to 'devel')
-rw-r--r--devel/ccons/Makefile37
-rw-r--r--devel/ccons/distinfo4
-rw-r--r--devel/ccons/files/patch-Console.cpp10
3 files changed, 29 insertions, 22 deletions
diff --git a/devel/ccons/Makefile b/devel/ccons/Makefile
index 22ed943e9a6c..c94f4240a12f 100644
--- a/devel/ccons/Makefile
+++ b/devel/ccons/Makefile
@@ -1,48 +1,45 @@
+# Created by: Danilo Egea Gondolfo <danilo@FreeBSD.org>
# $FreeBSD$
PORTNAME= ccons
-PORTVERSION= r243
+PORTVERSION= r251
CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= danilogondolfo@gmail.com
+MAINTAINER= danilo@FreeBSD.org
COMMENT= Interactive Console for the C Programming Language
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${LOCALBASE}/bin/llvm-config:${PORTSDIR}/devel/llvm \
- ${LOCALBASE}/bin/clang:${PORTSDIR}/lang/clang \
- ${LOCALBASE}/bin/ld:${PORTSDIR}/devel/binutils
-LIB_DEPENDS= ncurses:${PORTSDIR}/devel/ncurses
+BUILD_DEPENDS= llvm-config33:${PORTSDIR}/devel/llvm33 \
+ clang++33:${PORTSDIR}/lang/clang33
+LIB_DEPENDS= libncurses.so:${PORTSDIR}/devel/ncurses
ONLY_FOR_ARCHS= i386 amd64
USES= cmake
-CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE:FILEPATH=${LOCALBASE}/bin/llvm-config
-
-CXX= ${LOCALBASE}/bin/clang++
+CMAKE_ARGS+= -DLLVM_CONFIG_EXECUTABLE=${LOCALBASE}/bin/llvm-config33
CXXFLAGS+= -fno-rtti
-LDFLAGS+= -lclangFrontendTool -lclangFrontend -lclangDriver -lclangSerialization \
- -lclangCodeGen -lclangParse -lclangSema -lclangStaticAnalyzerCheckers \
- -lclangStaticAnalyzerCore -lclangAnalysis -lclang -lclangAST -lclangLex \
- -lclangBasic -ledit -lm
+LDFLAGS+= -lclang
+CXX= clang++33
+CC= clang33
-PLIST_FILES= bin/ccons
+PLIST_FILES= bin/ccons man/man1/ccons.1.gz
WRKSRC= ${WRKDIR}/ccons
-
-MAN1= ccons.1
-
-NO_STAGE= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 1000054
+CXXFLAGS+= -stdlib=libc++
+.endif
+
.if ${OSVERSION} < 900044
BROKEN= ccons does not work on FreeBSD < 9.0-RELEASE
.endif
do-install:
- @${INSTALL_PROGRAM} ${WRKSRC}/ccons ${PREFIX}/bin/ccons
- @${INSTALL_MAN} ${WRKSRC}/man/ccons.1 ${MAN1PREFIX}/man/man1/ccons.1
+ @${INSTALL_PROGRAM} ${WRKSRC}/ccons ${STAGEDIR}${PREFIX}/bin/ccons
+ @${INSTALL_MAN} ${WRKSRC}/man/ccons.1 ${STAGEDIR}${MAN1PREFIX}/man/man1/ccons.1
.include <bsd.port.post.mk>
diff --git a/devel/ccons/distinfo b/devel/ccons/distinfo
index 552b7e6ca2a3..606247c1bd5d 100644
--- a/devel/ccons/distinfo
+++ b/devel/ccons/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ccons-r243.tar.gz) = 22edb1420578f0aba6adc5edb5d2add523b7b0fdb83c9ef10f1bb3d43b66aad8
-SIZE (ccons-r243.tar.gz) = 26270
+SHA256 (ccons-r251.tar.gz) = 766619e217d795276d36c0fe324ce3fdf03ed67929bd8b452b5adcb20fba5812
+SIZE (ccons-r251.tar.gz) = 26469
diff --git a/devel/ccons/files/patch-Console.cpp b/devel/ccons/files/patch-Console.cpp
new file mode 100644
index 000000000000..b89e36a7c35e
--- /dev/null
+++ b/devel/ccons/files/patch-Console.cpp
@@ -0,0 +1,10 @@
+--- ./Console.cpp.orig 2013-09-18 15:56:23.000000000 -0300
++++ ./Console.cpp 2013-09-18 15:56:32.000000000 -0300
+@@ -12,6 +12,7 @@
+
+ #include <errno.h>
+ #include <ctype.h>
++#include <unistd.h>
+
+ #include <iostream>
+ #include <map>