aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-03-03 00:45:58 +0800
committermiwi <miwi@FreeBSD.org>2013-03-03 00:45:58 +0800
commit7282bdeb83962ddf462afcca19904528224e03c8 (patch)
tree15d6861328ce6ac9ea18e018efb03bc2bbf9e294 /devel
parent5e6ec65957f6d4c408da1a88a973cc1f287f879c (diff)
downloadfreebsd-ports-gnome-7282bdeb83962ddf462afcca19904528224e03c8.tar.gz
freebsd-ports-gnome-7282bdeb83962ddf462afcca19904528224e03c8.tar.zst
freebsd-ports-gnome-7282bdeb83962ddf462afcca19904528224e03c8.zip
This extension provides interface to the libeio library.
Libeio is a an asynchronous I/O library. Features basically include asynchronous versions of POSIX API(read, write, open, close, stat, unlink, fdatasync, mknod, readdir etc.); sendfile (native on Solaris, Linux, HP-UX, FreeBSD); readahead. libeio itself emulates the system calls, if they are not available on specific(UNIX-like) platform. WWW: http://pecl.php.net/package/eio/ PR: ports/176323 Submitted by: Gasol Wu <gasol.wu@gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-eio/Makefile22
-rw-r--r--devel/pecl-eio/distinfo2
-rw-r--r--devel/pecl-eio/pkg-descr9
4 files changed, 34 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3858fa3de757..ab17582bfc9c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3167,6 +3167,7 @@
SUBDIR += pecl-bbcode
SUBDIR += pecl-bcompiler
SUBDIR += pecl-dio
+ SUBDIR += pecl-eio
SUBDIR += pecl-ev
SUBDIR += pecl-expect
SUBDIR += pecl-gearman
diff --git a/devel/pecl-eio/Makefile b/devel/pecl-eio/Makefile
new file mode 100644
index 000000000000..5c83d5d89bf1
--- /dev/null
+++ b/devel/pecl-eio/Makefile
@@ -0,0 +1,22 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= eio
+PORTVERSION= 1.2.1
+CATEGORIES= devel
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= Provides interface to the libeio library
+
+LICENSE= PHP301
+
+CONFIGURE_ARGS= --enable-eio
+USE_PHP= yes
+USE_PHPEXT= yes
+IGNORE_WITH_PHP= 52
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-eio/distinfo b/devel/pecl-eio/distinfo
new file mode 100644
index 000000000000..a5dd7b5ca61b
--- /dev/null
+++ b/devel/pecl-eio/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PECL/eio-1.2.1.tgz) = 6682e360728a327764813a4211fe80b29c2fb241b14cb051bd8f763b405146c5
+SIZE (PECL/eio-1.2.1.tgz) = 57296
diff --git a/devel/pecl-eio/pkg-descr b/devel/pecl-eio/pkg-descr
new file mode 100644
index 000000000000..55ebb4993354
--- /dev/null
+++ b/devel/pecl-eio/pkg-descr
@@ -0,0 +1,9 @@
+This extension provides interface to the libeio library.
+
+Libeio is a an asynchronous I/O library. Features basically include
+asynchronous versions of POSIX API(read, write, open, close, stat, unlink,
+fdatasync, mknod, readdir etc.); sendfile (native on Solaris, Linux, HP-UX,
+FreeBSD); readahead. libeio itself emulates the system calls, if they are not
+available on specific(UNIX-like) platform.
+
+WWW: http://pecl.php.net/package/eio/