aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2012-06-30 13:52:54 +0800
committeraz <az@FreeBSD.org>2012-06-30 13:52:54 +0800
commit7334f9e3595adca6e3037545ff416a5565658030 (patch)
tree043befe8e5815425dd16f87ee2ff808986cb7b24 /devel
parentaa44daa1a2357db2175dd99b45bc46bbdfc3e66b (diff)
downloadfreebsd-ports-gnome-7334f9e3595adca6e3037545ff416a5565658030.tar.gz
freebsd-ports-gnome-7334f9e3595adca6e3037545ff416a5565658030.tar.zst
freebsd-ports-gnome-7334f9e3595adca6e3037545ff416a5565658030.zip
- Remove SITE_PERL from *_DEPENDS
Approved by: portmgr@ (bapt@)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-App-Trace/Makefile2
-rw-r--r--devel/p5-Class-Std-Fast/Makefile2
-rw-r--r--devel/p5-DateTime-Format-DateParse/Makefile4
-rw-r--r--devel/p5-Event-RPC/Makefile8
-rw-r--r--devel/p5-File-Find-Rule-Filesys-Virtual/Makefile6
-rw-r--r--devel/p5-File-Pid/Makefile2
-rw-r--r--devel/p5-File-Slurp-Tree/Makefile4
-rw-r--r--devel/p5-Getargs-Long/Makefile2
-rw-r--r--devel/p5-IPC-Mmap-Share/Makefile2
-rw-r--r--devel/p5-JQuery/Makefile10
-rw-r--r--devel/p5-Luka/Makefile18
-rw-r--r--devel/p5-Parse-Pidl/Makefile2
-rw-r--r--devel/p5-SOAP-WSDL/Makefile8
-rw-r--r--devel/p5-Test-Benchmark/Makefile4
-rw-r--r--devel/p5-Test-Singleton/Makefile4
-rw-r--r--devel/p5-Workflow/Makefile56
-rw-r--r--devel/p5-subatom/Makefile2
17 files changed, 68 insertions, 68 deletions
diff --git a/devel/p5-App-Trace/Makefile b/devel/p5-App-Trace/Makefile
index 06ab37c3db27..b15a45e8a937 100644
--- a/devel/p5-App-Trace/Makefile
+++ b/devel/p5-App-Trace/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Embedded debug statements, including call/return tracing
-RUN_DEPENDS= ${SITE_PERL}/App/Options.pm:${PORTSDIR}/devel/p5-App-Options
+RUN_DEPENDS= p5-App-Options>=0:${PORTSDIR}/devel/p5-App-Options
PERL_CONFIGURE= yes
diff --git a/devel/p5-Class-Std-Fast/Makefile b/devel/p5-Class-Std-Fast/Makefile
index c0185a6df976..7624579c9fe8 100644
--- a/devel/p5-Class-Std-Fast/Makefile
+++ b/devel/p5-Class-Std-Fast/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Faster but less secure than Class::Std
BUILD_DEPENDS= p5-Test-Simple>=0.86:${PORTSDIR}/devel/p5-Test-Simple
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/version.pm:${PORTSDIR}/devel/p5-version \
+RUN_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version \
p5-Class-Std>=0.0.9:${PORTSDIR}/devel/p5-Class-Std
PERL_CONFIGURE= YES
diff --git a/devel/p5-DateTime-Format-DateParse/Makefile b/devel/p5-DateTime-Format-DateParse/Makefile
index 008506fb495b..fbdc41618817 100644
--- a/devel/p5-DateTime-Format-DateParse/Makefile
+++ b/devel/p5-DateTime-Format-DateParse/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= svysh@pn.sinp.msu.ru
COMMENT= This module is a compatibility wrapper around Date::Parse
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/Date/Parse.pm:${PORTSDIR}/devel/p5-TimeDate
+BUILD_DEPENDS= p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
PERL_MODBUILD= yes
diff --git a/devel/p5-Event-RPC/Makefile b/devel/p5-Event-RPC/Makefile
index 3bdb5c0e52e2..0df1c63fb7e2 100644
--- a/devel/p5-Event-RPC/Makefile
+++ b/devel/p5-Event-RPC/Makefile
@@ -33,20 +33,20 @@ OPTIONS= GLIB "Use Glib event handler" off \
.include <bsd.port.pre.mk>
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Storable.pm:${PORTSDIR}/devel/p5-Storable
+BUILD_DEPENDS= p5-Storable>=0:${PORTSDIR}/devel/p5-Storable
.if !defined(WITHOUT_EVENT)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Event.pm:${PORTSDIR}/devel/p5-Event
+BUILD_DEPENDS+= p5-Event>=0:${PORTSDIR}/devel/p5-Event
.endif
.if defined(WITH_GLIB)
-BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/Glib.pm:${PORTSDIR}/devel/p5-Glib2
+BUILD_DEPENDS+= p5-Glib2>=0:${PORTSDIR}/devel/p5-Glib2
.endif
.if !defined(WITHOUT_SSL)
# we can't use USE_OPENSSL=yes after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.openssl.mk"
-BUILD_DEPENDS+= ${SITE_PERL}/IO/Socket/SSL.pm:${PORTSDIR}/security/p5-IO-Socket-SSL
+BUILD_DEPENDS+= p5-IO-Socket-SSL>=0:${PORTSDIR}/security/p5-IO-Socket-SSL
.endif
RUN_DEPENDS:= ${BUILD_DEPENDS}
diff --git a/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile b/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
index 32b62e5f7ed0..5e840755fce1 100644
--- a/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
+++ b/devel/p5-File-Find-Rule-Filesys-Virtual/Makefile
@@ -14,9 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= File::Find::Rule adapted to Filesys::Virtual
-RUN_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
- ${SITE_PERL}/Filesys/Virtual.pm:${PORTSDIR}/devel/p5-Filesys-Virtual \
- ${SITE_PERL}/Filesys/Virtual/Plain.pm:${PORTSDIR}/devel/p5-Filesys-Virtual-Plain
+RUN_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-Filesys-Virtual>=0:${PORTSDIR}/devel/p5-Filesys-Virtual \
+ p5-Filesys-Virtual-Plain>=0:${PORTSDIR}/devel/p5-Filesys-Virtual-Plain
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-Pid/Makefile b/devel/p5-File-Pid/Makefile
index ebcb97e80c69..5a4835058606 100644
--- a/devel/p5-File-Pid/Makefile
+++ b/devel/p5-File-Pid/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Pid File Manipulation
-RUN_DEPENDS= ${SITE_PERL}/Class/Accessor/Fast.pm:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-File-Slurp-Tree/Makefile b/devel/p5-File-Slurp-Tree/Makefile
index 889819dc93ff..968b65ac314f 100644
--- a/devel/p5-File-Slurp-Tree/Makefile
+++ b/devel/p5-File-Slurp-Tree/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Slurp and emit file trees as nested hashes
-BUILD_DEPENDS= ${SITE_PERL}/File/Find/Rule.pm:${PORTSDIR}/devel/p5-File-Find-Rule \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
+BUILD_DEPENDS= p5-File-Find-Rule>=0:${PORTSDIR}/devel/p5-File-Find-Rule \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Getargs-Long/Makefile b/devel/p5-Getargs-Long/Makefile
index 30815a130fef..4a194239e132 100644
--- a/devel/p5-Getargs-Long/Makefile
+++ b/devel/p5-Getargs-Long/Makefile
@@ -15,7 +15,7 @@ MAINTAINER= wenheping@gmail.com
COMMENT= Parse routine arguments
BUILD_DEPENDS= p5-Log-Agent>=0.105:${PORTSDIR}/devel/p5-Log-Agent \
- ${SITE_PERL}/Module/Install.pm:${PORTSDIR}/devel/p5-Module-Install
+ p5-Module-Install>=0:${PORTSDIR}/devel/p5-Module-Install
RUN_DEPENDS= p5-Log-Agent>=0.105:${PORTSDIR}/devel/p5-Log-Agent
PERL_CONFIGURE= yes
diff --git a/devel/p5-IPC-Mmap-Share/Makefile b/devel/p5-IPC-Mmap-Share/Makefile
index 62c67bc3f140..9d3f153a122e 100644
--- a/devel/p5-IPC-Mmap-Share/Makefile
+++ b/devel/p5-IPC-Mmap-Share/Makefile
@@ -14,7 +14,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Safely share structures among processes using anonymous mmap
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/IPC/Mmap.pm:${PORTSDIR}/devel/p5-IPC-Mmap
+RUN_DEPENDS= p5-IPC-Mmap>=0:${PORTSDIR}/devel/p5-IPC-Mmap
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-JQuery/Makefile b/devel/p5-JQuery/Makefile
index 6f7b9c6981df..a747071e9e62 100644
--- a/devel/p5-JQuery/Makefile
+++ b/devel/p5-JQuery/Makefile
@@ -16,11 +16,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Interface to Jquery, a language based on Javascript
-RUN_DEPENDS= ${SITE_PERL}/CGI/Application.pm:${PORTSDIR}/www/p5-CGI-Application \
- ${SITE_PERL}/CSS.pm:${PORTSDIR}/textproc/p5-CSS \
- ${SITE_PERL}/HTML/Table.pm:${PORTSDIR}/www/p5-HTML-Table \
- ${SITE_PERL}/IO/String.pm:${PORTSDIR}/devel/p5-IO-String \
- ${SITE_PERL}/XML/Writer.pm:${PORTSDIR}/textproc/p5-XML-Writer
+RUN_DEPENDS= p5-CGI-Application>=0:${PORTSDIR}/www/p5-CGI-Application \
+ p5-CSS>=0:${PORTSDIR}/textproc/p5-CSS \
+ p5-HTML-Table>=0:${PORTSDIR}/www/p5-HTML-Table \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-XML-Writer>=0:${PORTSDIR}/textproc/p5-XML-Writer
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_MODBUILD= yes
diff --git a/devel/p5-Luka/Makefile b/devel/p5-Luka/Makefile
index c34832cbaa52..fc6ac4ab732a 100644
--- a/devel/p5-Luka/Makefile
+++ b/devel/p5-Luka/Makefile
@@ -15,15 +15,15 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Exception handling and reporting framework
-RUN_DEPENDS= ${SITE_PERL}/Class/Std.pm:${PORTSDIR}/devel/p5-Class-Std \
- ${SITE_PERL}/Config/IniFiles.pm:${PORTSDIR}/devel/p5-Config-IniFiles \
- ${SITE_PERL}/Error.pm:${PORTSDIR}/lang/p5-Error \
- ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/Mail/SendEasy.pm:${PORTSDIR}/mail/p5-Mail-SendEasy \
- ${SITE_PERL}/Sub/Uplevel.pm:${PORTSDIR}/devel/p5-Sub-Uplevel \
- ${SITE_PERL}/Sys/Hostname/Long.pm:${PORTSDIR}/sysutils/p5-Sys-Hostname-Long \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/What/MTA.pm:${PORTSDIR}/net/p5-What
+RUN_DEPENDS= p5-Class-Std>=0:${PORTSDIR}/devel/p5-Class-Std \
+ p5-Config-IniFiles>=0:${PORTSDIR}/devel/p5-Config-IniFiles \
+ p5-Error>=0:${PORTSDIR}/lang/p5-Error \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-Mail-SendEasy>=0:${PORTSDIR}/mail/p5-Mail-SendEasy \
+ p5-Sub-Uplevel>=0:${PORTSDIR}/devel/p5-Sub-Uplevel \
+ p5-Sys-Hostname-Long>=0:${PORTSDIR}/sysutils/p5-Sys-Hostname-Long \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-What>=0:${PORTSDIR}/net/p5-What
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Parse-Pidl/Makefile b/devel/p5-Parse-Pidl/Makefile
index 22a5641284d3..b11914f042a1 100644
--- a/devel/p5-Parse-Pidl/Makefile
+++ b/devel/p5-Parse-Pidl/Makefile
@@ -15,7 +15,7 @@ PKGNAMESUFFIX=
COMMENT= IDL compiler written in Perl
-RUN_DEPENDS= ${SITE_PERL}/Parse/Yapp.pm:${PORTSDIR}/devel/p5-Parse-Yapp
+RUN_DEPENDS= p5-Parse-Yapp>=0:${PORTSDIR}/devel/p5-Parse-Yapp
CONFLICTS=
diff --git a/devel/p5-SOAP-WSDL/Makefile b/devel/p5-SOAP-WSDL/Makefile
index f29052e98adc..108c75b19641 100644
--- a/devel/p5-SOAP-WSDL/Makefile
+++ b/devel/p5-SOAP-WSDL/Makefile
@@ -15,18 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wenheping@gmail.com
COMMENT= Perl module for SOAP with WSDL support
-RUN_DEPENDS= ${SITE_PERL}/Class/Std/Fast.pm:${PORTSDIR}/devel/p5-Class-Std-Fast \
+RUN_DEPENDS= p5-Class-Std-Fast>=0:${PORTSDIR}/devel/p5-Class-Std-Fast \
p5-Template-Toolkit>=2.20:${PORTSDIR}/www/p5-Template-Toolkit \
p5-TimeDate>=1.16:${PORTSDIR}/devel/p5-TimeDate \
p5-XML-Parser>=2.36:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww\
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww\
p5-URI>=1.37:${PORTSDIR}/net/p5-URI \
p5-Term-ReadKey>=2.30:${PORTSDIR}/devel/p5-Term-ReadKey
-BUILD_DEPENDS= ${SITE_PERL}/Class/Std/Fast.pm:${PORTSDIR}/devel/p5-Class-Std-Fast \
+BUILD_DEPENDS= p5-Class-Std-Fast>=0:${PORTSDIR}/devel/p5-Class-Std-Fast \
p5-Template-Toolkit>=2.20:${PORTSDIR}/www/p5-Template-Toolkit \
p5-TimeDate>=1.16:${PORTSDIR}/devel/p5-TimeDate \
p5-XML-Parser>=2.36:${PORTSDIR}/textproc/p5-XML-Parser \
- ${SITE_PERL}/HTTP/Request/Common.pm:${PORTSDIR}/www/p5-libwww
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_MODBUILD= YES
diff --git a/devel/p5-Test-Benchmark/Makefile b/devel/p5-Test-Benchmark/Makefile
index faa574e18ef5..63d823245df8 100644
--- a/devel/p5-Test-Benchmark/Makefile
+++ b/devel/p5-Test-Benchmark/Makefile
@@ -14,8 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Make sure something really is faster
-BUILD_DEPENDS= ${SITE_PERL}/Test/Tester.pm:${PORTSDIR}/devel/p5-Test-Tester \
- ${SITE_PERL}/Test/NoWarnings.pm:${PORTSDIR}/devel/p5-Test-NoWarnings
+BUILD_DEPENDS= p5-Test-Tester>=0:${PORTSDIR}/devel/p5-Test-Tester \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Test-Singleton/Makefile b/devel/p5-Test-Singleton/Makefile
index 2b6f6c05f6d6..63fd484a7a0b 100644
--- a/devel/p5-Test-Singleton/Makefile
+++ b/devel/p5-Test-Singleton/Makefile
@@ -15,8 +15,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Test for Singleton classes
-RUN_DEPENDS= ${SITE_PERL}/Class/Singleton.pm:${PORTSDIR}/devel/p5-Class-Singleton \
- ${SITE_PERL}/Test/Builder/Tester.pm:${PORTSDIR}/devel/p5-Test-Simple
+RUN_DEPENDS= p5-Class-Singleton>=0:${PORTSDIR}/devel/p5-Class-Singleton \
+ p5-Test-Simple>=0:${PORTSDIR}/devel/p5-Test-Simple
BUILD_DEPENDS:= ${RUN_DEPENDS}
PERL_CONFIGURE= yes
diff --git a/devel/p5-Workflow/Makefile b/devel/p5-Workflow/Makefile
index 199c951b2c6c..c4cbd7d2cec7 100644
--- a/devel/p5-Workflow/Makefile
+++ b/devel/p5-Workflow/Makefile
@@ -14,34 +14,34 @@ PKGNAMEPREFIX= p5-
MAINTAINER= svysh@pn.sinp.msu.ru
COMMENT= Simple, flexible system to implement workflows
-RUN_DEPENDS= ${SITE_PERL}/Class/Observable.pm:${PORTSDIR}/devel/p5-Class-Observable \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/DBD/Mock.pm:${PORTSDIR}/databases/p5-DBD-Mock \
- ${SITE_PERL}/Class/Factory.pm:${PORTSDIR}/devel/p5-Class-Factory \
- ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
- ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
-BUILD_DEPENDS= ${SITE_PERL}/Class/Observable.pm:${PORTSDIR}/devel/p5-Class-Observable \
- ${SITE_PERL}/Class/Accessor.pm:${PORTSDIR}/devel/p5-Class-Accessor \
- ${SITE_PERL}/DBD/Mock.pm:${PORTSDIR}/databases/p5-DBD-Mock \
- ${SITE_PERL}/Class/Factory.pm:${PORTSDIR}/devel/p5-Class-Factory \
- ${SITE_PERL}/${PERL_ARCH}/DateTime.pm:${PORTSDIR}/devel/p5-DateTime \
- ${SITE_PERL}/Exception/Class.pm:${PORTSDIR}/devel/p5-Exception-Class \
- ${SITE_PERL}/DateTime/Format/Strptime.pm:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
- ${SITE_PERL}/XML/Simple.pm:${PORTSDIR}/textproc/p5-XML-Simple \
- ${SITE_PERL}/Log/Dispatch.pm:${PORTSDIR}/devel/p5-Log-Dispatch \
- ${SITE_PERL}/Log/Log4perl.pm:${PORTSDIR}/devel/p5-Log-Log4perl \
- ${SITE_PERL}/${PERL_ARCH}/Data/UUID.pm:${PORTSDIR}/devel/p5-Data-UUID \
- ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI \
- ${SITE_PERL}/Test/Exception.pm:${PORTSDIR}/devel/p5-Test-Exception \
- ${SITE_PERL}/File/Slurp.pm:${PORTSDIR}/devel/p5-File-Slurp
+RUN_DEPENDS= p5-Class-Observable>=0:${PORTSDIR}/devel/p5-Class-Observable \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-DBD-Mock>=0:${PORTSDIR}/databases/p5-DBD-Mock \
+ p5-Class-Factory>=0:${PORTSDIR}/devel/p5-Class-Factory \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
+BUILD_DEPENDS= p5-Class-Observable>=0:${PORTSDIR}/devel/p5-Class-Observable \
+ p5-Class-Accessor>=0:${PORTSDIR}/devel/p5-Class-Accessor \
+ p5-DBD-Mock>=0:${PORTSDIR}/databases/p5-DBD-Mock \
+ p5-Class-Factory>=0:${PORTSDIR}/devel/p5-Class-Factory \
+ p5-DateTime>=0:${PORTSDIR}/devel/p5-DateTime \
+ p5-Exception-Class>=0:${PORTSDIR}/devel/p5-Exception-Class \
+ p5-DateTime-Format-Strptime>=0:${PORTSDIR}/devel/p5-DateTime-Format-Strptime \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-Log-Dispatch>=0:${PORTSDIR}/devel/p5-Log-Dispatch \
+ p5-Log-Log4perl>=0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-Data-UUID>=0:${PORTSDIR}/devel/p5-Data-UUID \
+ p5-DBI>=0:${PORTSDIR}/databases/p5-DBI \
+ p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp
PERL_CONFIGURE= yes
diff --git a/devel/p5-subatom/Makefile b/devel/p5-subatom/Makefile
index 524971d3d671..e35545260d0a 100644
--- a/devel/p5-subatom/Makefile
+++ b/devel/p5-subatom/Makefile
@@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= gslin@gslin.org
COMMENT= Produce an atom feed from subversion commits
-BUILD_DEPENDS= ${SITE_PERL}/XML/Atom/SimpleFeed.pm:${PORTSDIR}/textproc/p5-XML-Atom-SimpleFeed
+BUILD_DEPENDS= p5-XML-Atom-SimpleFeed>=0:${PORTSDIR}/textproc/p5-XML-Atom-SimpleFeed
RUN_DEPENDS:= ${BUILD_DEPENDS}
PERL_MODBUILD= yes