aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-11-03 13:00:53 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-11-03 13:00:53 +0800
commit74fbe40a84d49e412fcdfe524065eea3303a49a0 (patch)
treed77809ff025fd263696ce1db31f0043aa0ce77d4 /devel
parent2a9d415ca044a1214f0b04fcfac59478d508a2b9 (diff)
downloadfreebsd-ports-gnome-74fbe40a84d49e412fcdfe524065eea3303a49a0.tar.gz
freebsd-ports-gnome-74fbe40a84d49e412fcdfe524065eea3303a49a0.tar.zst
freebsd-ports-gnome-74fbe40a84d49e412fcdfe524065eea3303a49a0.zip
- Add p5-IPC-ShellCmd 0.005
IPC::ShellCmd comes from the nth time I've had to implement a select loop and wanted appropriate sudo/su privilege magic, environment variables that are set in the child, working directories set etc. It aims to provide a reasonable interface for setting up command execution environment (working directory, environment variables, stdin, stdout and stderr redirection if necessary), but allowing for ssh and sudo and magicking in the appropriate shell quoting. It tries to be flexible about how you might want to capture output, exit status and other such, but in such a way as it's hopefully easy to understand and make it work. Setup method calls are chain-able in a File::Find::Rule kind of a way. WWW: http://search.cpan.org/dist/IPC-ShellCmd/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IPC-ShellCmd/Makefile24
-rw-r--r--devel/p5-IPC-ShellCmd/distinfo2
-rw-r--r--devel/p5-IPC-ShellCmd/pkg-descr16
-rw-r--r--devel/p5-IPC-ShellCmd/pkg-plist15
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b27264a29ef3..cbff97d9397b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2150,6 +2150,7 @@
SUBDIR += p5-IPC-ShareLite
SUBDIR += p5-IPC-Shareable
SUBDIR += p5-IPC-SharedCache
+ SUBDIR += p5-IPC-ShellCmd
SUBDIR += p5-IPC-Signal
SUBDIR += p5-IPC-System-Simple
SUBDIR += p5-Import-Into
diff --git a/devel/p5-IPC-ShellCmd/Makefile b/devel/p5-IPC-ShellCmd/Makefile
new file mode 100644
index 000000000000..023e0d91a374
--- /dev/null
+++ b/devel/p5-IPC-ShellCmd/Makefile
@@ -0,0 +1,24 @@
+# Created by: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= IPC-ShellCmd
+PORTVERSION= 0.005
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:ANDREWF
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Run a command with a given environment and capture output
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/sudo:${PORTSDIR}/security/sudo \
+ p5-String-ShellQuote>=0:${PORTSDIR}/textproc/p5-String-ShellQuote
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+USE_PERL5= configure
+USES= perl5
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IPC-ShellCmd/distinfo b/devel/p5-IPC-ShellCmd/distinfo
new file mode 100644
index 000000000000..680edc9a0ba7
--- /dev/null
+++ b/devel/p5-IPC-ShellCmd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (IPC-ShellCmd-0.005.tar.gz) = 78f78d0b6c37038a2584db9daa07b19686a2f70d1cbf9363ef9c606e49c2f552
+SIZE (IPC-ShellCmd-0.005.tar.gz) = 40152
diff --git a/devel/p5-IPC-ShellCmd/pkg-descr b/devel/p5-IPC-ShellCmd/pkg-descr
new file mode 100644
index 000000000000..7459d95cee11
--- /dev/null
+++ b/devel/p5-IPC-ShellCmd/pkg-descr
@@ -0,0 +1,16 @@
+IPC::ShellCmd comes from the nth time I've had to implement a select loop and
+wanted appropriate sudo/su privilege magic, environment variables that are set
+in the child, working directories set etc.
+
+It aims to provide a reasonable interface for setting up command execution
+environment (working directory, environment variables, stdin, stdout and stderr
+redirection if necessary), but allowing for ssh and sudo and magicking in the
+appropriate shell quoting.
+
+It tries to be flexible about how you might want to capture output, exit status
+and other such, but in such a way as it's hopefully easy to understand and make
+it work.
+
+Setup method calls are chain-able in a File::Find::Rule kind of a way.
+
+WWW: http://search.cpan.org/dist/IPC-ShellCmd/
diff --git a/devel/p5-IPC-ShellCmd/pkg-plist b/devel/p5-IPC-ShellCmd/pkg-plist
new file mode 100644
index 000000000000..df2e55b1128b
--- /dev/null
+++ b/devel/p5-IPC-ShellCmd/pkg-plist
@@ -0,0 +1,15 @@
+%%SITE_PERL%%/IPC/ShellCmd.pm
+%%SITE_PERL%%/IPC/ShellCmd/Generic.pm
+%%SITE_PERL%%/IPC/ShellCmd/SSH.pm
+%%SITE_PERL%%/IPC/ShellCmd/ShBase.pm
+%%SITE_PERL%%/IPC/ShellCmd/Sudo.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/ShellCmd/.packlist
+%%PERL5_MAN3%%/IPC::ShellCmd.3.gz
+%%PERL5_MAN3%%/IPC::ShellCmd::Generic.3.gz
+%%PERL5_MAN3%%/IPC::ShellCmd::SSH.3.gz
+%%PERL5_MAN3%%/IPC::ShellCmd::ShBase.3.gz
+%%PERL5_MAN3%%/IPC::ShellCmd::Sudo.3.gz
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC/ShellCmd
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/IPC
+@dirrm %%SITE_PERL%%/IPC/ShellCmd
+@dirrmtry %%SITE_PERL%%/IPC