aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2014-05-31 02:43:48 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2014-05-31 02:43:48 +0800
commit754ed9164a250d2f217e879081ad3f440aed8227 (patch)
tree406c99419b936a23894ecc0203a749241e499321 /devel
parentbafc449147e4f2ce44d078260a536f2171f045c8 (diff)
downloadfreebsd-ports-gnome-754ed9164a250d2f217e879081ad3f440aed8227.tar.gz
freebsd-ports-gnome-754ed9164a250d2f217e879081ad3f440aed8227.tar.zst
freebsd-ports-gnome-754ed9164a250d2f217e879081ad3f440aed8227.zip
- Switch to USES=libtool, drop .la files
- Strip libraries
Diffstat (limited to 'devel')
-rw-r--r--devel/alf/Makefile5
-rw-r--r--devel/alf/files/patch-python__Makefile.in11
-rw-r--r--devel/alf/pkg-plist3
3 files changed, 15 insertions, 4 deletions
diff --git a/devel/alf/Makefile b/devel/alf/Makefile
index 03b04d896dd3..242f8685b3f4 100644
--- a/devel/alf/Makefile
+++ b/devel/alf/Makefile
@@ -3,16 +3,17 @@
PORTNAME= alf
PORTVERSION= 0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel python
MASTER_SITES= SF/largefiles/largefiles/${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Abstract Large File
-USE_AUTOTOOLS= libtool
+USES= libtool
USE_PYTHON= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
.include <bsd.port.mk>
diff --git a/devel/alf/files/patch-python__Makefile.in b/devel/alf/files/patch-python__Makefile.in
new file mode 100644
index 000000000000..2d62479bf04e
--- /dev/null
+++ b/devel/alf/files/patch-python__Makefile.in
@@ -0,0 +1,11 @@
+--- python/Makefile.in.orig 2002-05-22 17:05:02.000000000 +0400
++++ python/Makefile.in 2014-05-30 21:46:22.000000000 +0400
+@@ -104,7 +104,7 @@
+
+ pyexec_LTLIBRARIES = alfmodule.la
+ alfmodule_la_LDFLAGS = -module -avoid-version -export-symbols-regex initalf
+-alfmodule_la_LIBADD = -L../src -lalf
++alfmodule_la_LIBADD = -L../src -L../src/.libs -lalf
+ alfmodule_la_SOURCES = alfmodule.c
+ subdir = python
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/devel/alf/pkg-plist b/devel/alf/pkg-plist
index 4c8daeda87ac..9ae71d4e8760 100644
--- a/devel/alf/pkg-plist
+++ b/devel/alf/pkg-plist
@@ -1,10 +1,9 @@
include/alf/alf.h
include/alf/common.h
lib/libalf.a
-lib/libalf.la
lib/libalf.so
lib/libalf.so.0
+lib/libalf.so.0.0.0
%%PYTHON_SITELIBDIR%%/alfmodule.a
-%%PYTHON_SITELIBDIR%%/alfmodule.la
%%PYTHON_SITELIBDIR%%/alfmodule.so
@dirrm include/alf