aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorglarkin <glarkin@FreeBSD.org>2009-08-28 01:05:17 +0800
committerglarkin <glarkin@FreeBSD.org>2009-08-28 01:05:17 +0800
commit7c2a5e1d788f71628c1f6e68eb3d3fec177e9278 (patch)
tree61bcf2ccb98e8592e8c08ccf284a36403811b84b /devel
parentf832116aa18627412f63646a69a0d07d73f7e0eb (diff)
downloadfreebsd-ports-gnome-7c2a5e1d788f71628c1f6e68eb3d3fec177e9278.tar.gz
freebsd-ports-gnome-7c2a5e1d788f71628c1f6e68eb3d3fec177e9278.tar.zst
freebsd-ports-gnome-7c2a5e1d788f71628c1f6e68eb3d3fec177e9278.zip
Data::HashArray is an array of hashes or hash-based objects. This
class has some magical properties that make it easier to deal with multiplicity. WWW: http://search.cpan.org/dist/Data-HashArray/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Data-HashArray/Makefile24
-rw-r--r--devel/p5-Data-HashArray/distinfo3
-rw-r--r--devel/p5-Data-HashArray/pkg-descr5
-rw-r--r--devel/p5-Data-HashArray/pkg-plist5
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a1d95f9e5643..2c6ced937eac 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1187,6 +1187,7 @@
SUBDIR += p5-Data-Dumper-Simple
SUBDIR += p5-Data-Flow
SUBDIR += p5-Data-GUID
+ SUBDIR += p5-Data-HashArray
SUBDIR += p5-Data-HexDump
SUBDIR += p5-Data-Hexdumper
SUBDIR += p5-Data-Hierarchy
diff --git a/devel/p5-Data-HashArray/Makefile b/devel/p5-Data-HashArray/Makefile
new file mode 100644
index 000000000000..31bba7fb1717
--- /dev/null
+++ b/devel/p5-Data-HashArray/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Data::HashArray
+# Date created: 2009-08-27
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-HashArray
+PORTVERSION= 1.0
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Array class of hashes with properties via overloading and AUTOLOAD
+
+BUILD_DEPENDS= p5-Data-Dumper>=0:${PORTSDIR}/devel/p5-Data-Dumper \
+ p5-Scalar-List-Utils>=0:${PORTSDIR}/lang/p5-Scalar-List-Utils
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::HashArray.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Data-HashArray/distinfo b/devel/p5-Data-HashArray/distinfo
new file mode 100644
index 000000000000..e25522952013
--- /dev/null
+++ b/devel/p5-Data-HashArray/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-HashArray-1.0.tar.gz) = 56b29c7834e68cec48c0c0bb7e101bd5
+SHA256 (Data-HashArray-1.0.tar.gz) = 51855bae8cc0c423216524e27e85a82afe8c983db90cbf7da1edf22f0a1ff8fe
+SIZE (Data-HashArray-1.0.tar.gz) = 6977
diff --git a/devel/p5-Data-HashArray/pkg-descr b/devel/p5-Data-HashArray/pkg-descr
new file mode 100644
index 000000000000..b5604733470a
--- /dev/null
+++ b/devel/p5-Data-HashArray/pkg-descr
@@ -0,0 +1,5 @@
+Data::HashArray is an array of hashes or hash-based objects. This
+class has some magical properties that make it easier to deal with
+multiplicity.
+
+WWW: http://search.cpan.org/dist/Data-HashArray/
diff --git a/devel/p5-Data-HashArray/pkg-plist b/devel/p5-Data-HashArray/pkg-plist
new file mode 100644
index 000000000000..6bacfe740206
--- /dev/null
+++ b/devel/p5-Data-HashArray/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Data/HashArray.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/HashArray/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/HashArray
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data