aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-02 03:24:21 +0800
committerbapt <bapt@FreeBSD.org>2017-04-02 03:24:21 +0800
commit82a92f6b7af00f7a6264536c3de5b8b2790655a3 (patch)
tree086fd3e5df73d7a90d07d493bb4698f153e58744 /devel
parent02d5910edabf829c65228732267026313e757e22 (diff)
downloadfreebsd-ports-gnome-82a92f6b7af00f7a6264536c3de5b8b2790655a3.tar.gz
freebsd-ports-gnome-82a92f6b7af00f7a6264536c3de5b8b2790655a3.tar.zst
freebsd-ports-gnome-82a92f6b7af00f7a6264536c3de5b8b2790655a3.zip
update to 2.52.0
- remove the GDB option and always install the py script, it does not hurt - remove pathfix as pkgconf now accept the lib/pkgconfig path - switch to option framework where possible Obtained from: kwm (older version)
Diffstat (limited to 'devel')
-rw-r--r--devel/glib20/Makefile46
-rw-r--r--devel/glib20/distinfo5
-rw-r--r--devel/glib20/files/extra-glib_gdbscripts20
-rw-r--r--devel/glib20/files/patch-gio_gunionvolumemonitor.c16
-rw-r--r--devel/glib20/files/patch-glib_gthread-posix.c20
-rw-r--r--devel/glib20/pkg-plist39
6 files changed, 65 insertions, 81 deletions
diff --git a/devel/glib20/Makefile b/devel/glib20/Makefile
index efd8e95e0d1e..40f98f496841 100644
--- a/devel/glib20/Makefile
+++ b/devel/glib20/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= glib
-PORTVERSION= 2.46.2
-PORTREVISION= 5
+PORTVERSION= 2.52.0
CATEGORIES= devel
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -25,7 +24,7 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
# iconv:wchar_t - our iconv in base doesn't support utf-8 -> wchar_t (boooo)
# (wchar_t is used by glibmm, rawtherapee triggered this)
-USES+= gettext gmake gnome iconv:wchar_t libtool pathfix perl5 \
+USES+= gettext gmake gnome iconv:wchar_t libtool localbase perl5 \
pkgconfig python shebangfix
USE_PYTHON= py3kplist
CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
@@ -34,13 +33,11 @@ CONFIGURE_ARGS= --disable-gtk-doc --with-html-dir=${PREFIX}/share/doc \
--with-pcre=system \
--disable-fam
CONFIGURE_ENV= ac_cv_header_sys_inotify_h=
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
SHEBANG_FILES= */*.pl
-LIBVERSION= 0.4600.2
+LIBVERSION= 0.5200.0
PLIST_SUB+= LIBVERSION=${LIBVERSION}
glib_MAN= gtester.1 gtester-report.1 glib-gettextize.1
@@ -49,10 +46,22 @@ gio_MAN= gdbus.1 gsettings.1 gio-querymodules.1 \
glib-compile-resources.1 gresource.1 gdbus-codegen.1
gobject_MAN= glib-genmarshal.1 glib-mkenums.1 gobject-query.1
-OPTIONS_DEFINE= COLLATION_FIX DEBUG GDB
+OPTIONS_DEFINE= COLLATION_FIX DEBUG
# libc collation was fixed by https://svnweb.freebsd.org/changeset/base/290494
COLLATION_FIX_DESC= Use ICU for UTF-8 string collation (if libc is broken)
-GDB_DESC= Install python gdb scripts
+
+OPTIONS_EXCLUDE_FreeBSD_11= COLLATION_FIX
+OPTIONS_EXCLUDE_FreeBSD_12= COLLATION_FIX
+
+DEBUG_CONFIGURE_ARGS+= --enable-debug=yes \
+ --disable-silent-rules
+
+COLLATION_FIX_LIB_DEPENDS+= libicui18n.so:devel/icu
+COLLATION_FIX_EXTRA_PATCHES+= ${FILESDIR}/extra-patch-glib_Makefile.in \
+ ${FILESDIR}/extra-patch-glib_gunicollate.c
+# Disable it until someone can figure why it causes net-im/pidgin crashed.
+# http://www.freebsd.org/cgi/query-pr.cgi?pr=175930 see comment by ed@
+#COLLATION_FIX_CONFIGURE_ENV+= CFLAGS="-D__STDC_ISO_10646__"
.include <bsd.port.pre.mk>
@@ -79,27 +88,6 @@ GLIB_ARCH= ${ARCH}
.endif
CONFIGURE_TARGET=${GLIB_ARCH}-portbld-freebsd${OSREL}
-.if ${PORT_OPTIONS:MCOLLATION_FIX}
-LIB_DEPENDS+= libicui18n.so:devel/icu
-EXTRA_PATCHES+= ${FILESDIR}/extra-patch-glib_Makefile.in \
- ${FILESDIR}/extra-patch-glib_gunicollate.c
-# Disable it until someone can figure why it causes net-im/pidgin crashed.
-# http://www.freebsd.org/cgi/query-pr.cgi?pr=175930 see comment by ed@
-#CONFIGURE_ENV+= CFLAGS="-D__STDC_ISO_10646__"
-.endif
-
-.if ${PORT_OPTIONS:MGDB}
-PLIST_SUB+= GDB=""
-.else
-EXTRA_PATCHES+= ${FILESDIR}/extra-glib_gdbscripts \
- ${FILESDIR}/extra-gobject_gdbscripts
-PLIST_SUB+= GDB="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDEBUG}
-CONFIGURE_ARGS+= --enable-debug=yes
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g ; \
s|/usr/share/locale/locale|${LOCALBASE}/share/locale/locale|g' \
diff --git a/devel/glib20/distinfo b/devel/glib20/distinfo
index d8ef11ab0b03..b0f537c7dc9b 100644
--- a/devel/glib20/distinfo
+++ b/devel/glib20/distinfo
@@ -1,2 +1,3 @@
-SHA256 (gnome2/glib-2.46.2.tar.xz) = 5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db
-SIZE (gnome2/glib-2.46.2.tar.xz) = 7344636
+TIMESTAMP = 1491072363
+SHA256 (gnome2/glib-2.52.0.tar.xz) = 4578e3e077b1b978cafeec8d28b676c680aba0c0475923874c4c993403df311a
+SIZE (gnome2/glib-2.52.0.tar.xz) = 7655820
diff --git a/devel/glib20/files/extra-glib_gdbscripts b/devel/glib20/files/extra-glib_gdbscripts
deleted file mode 100644
index bdde1c66ce04..000000000000
--- a/devel/glib20/files/extra-glib_gdbscripts
+++ /dev/null
@@ -1,20 +0,0 @@
---- glib/Makefile.in.orig 2014-03-09 10:06:29.765325337 +0000
-+++ glib/Makefile.in 2014-03-09 10:06:46.935323979 +0000
-@@ -2834,7 +2834,7 @@
- info-am:
-
- install-data-am: install-data-local install-deprecatedincludeHEADERS \
-- install-dist_gdbSCRIPTS install-glibincludeHEADERS \
-+ install-glibincludeHEADERS \
- install-glibsubincludeHEADERS \
- install-installed_testLTLIBRARIES \
- install-installed_testPROGRAMS install-installed_testSCRIPTS \
-@@ -3084,8 +3084,6 @@
- $(AM_V_GEN) $(SED) -e "s|\@datadir\@|$(datadir)|" $(srcdir)/libglib-gdb.py.in > $(builddir)/libglib-gdb.py
-
- install-data-hook: libglib-gdb.py
-- mkdir -p $(DESTDIR)$(datadir)/gdb/auto-load$(ABS_GLIB_RUNTIME_LIBDIR)
-- $(INSTALL) $(builddir)/libglib-gdb.py $(DESTDIR)$(datadir)/gdb/auto-load$(ABS_GLIB_RUNTIME_LIBDIR)/libglib-2.0.so.0.$(LT_CURRENT).$(LT_REVISION)-gdb.py
- @HAVE_GLIB_RUNTIME_LIBDIR_TRUE@ mkdir -p $(DESTDIR)$(libdir)/$(GLIB_RUNTIME_LIBDIR)
- @HAVE_GLIB_RUNTIME_LIBDIR_TRUE@ mv $(DESTDIR)$(libdir)/libglib-2.0.so.0 $(DESTDIR)$(libdir)/$(GLIB_RUNTIME_LIBDIR)
- @HAVE_GLIB_RUNTIME_LIBDIR_TRUE@ mv $(DESTDIR)$(libdir)/libglib-2.0.so.0.$(LT_CURRENT).$(LT_REVISION) $(DESTDIR)$(libdir)/$(GLIB_RUNTIME_LIBDIR)
diff --git a/devel/glib20/files/patch-gio_gunionvolumemonitor.c b/devel/glib20/files/patch-gio_gunionvolumemonitor.c
deleted file mode 100644
index 2749dca027cb..000000000000
--- a/devel/glib20/files/patch-gio_gunionvolumemonitor.c
+++ /dev/null
@@ -1,16 +0,0 @@
-https://bugzilla.gnome.org/show_bug.cgi?id=753378
-
---- gio/gunionvolumemonitor.c.orig 2015-09-25 11:23:00.429587000 +0200
-+++ gio/gunionvolumemonitor.c 2015-09-25 11:23:12.787618000 +0200
-@@ -592,9 +592,9 @@ _g_mount_get_for_mount_path (const gchar
-
- if (klass->get_mount_for_mount_path)
- {
-- g_rec_mutex_lock (&the_volume_monitor_mutex);
-+// g_rec_mutex_lock (&the_volume_monitor_mutex);
- mount = klass->get_mount_for_mount_path (mount_path, cancellable);
-- g_rec_mutex_unlock (&the_volume_monitor_mutex);
-+// g_rec_mutex_unlock (&the_volume_monitor_mutex);
- }
-
- /* TODO: How do we know this succeeded? Keep in mind that the native
diff --git a/devel/glib20/files/patch-glib_gthread-posix.c b/devel/glib20/files/patch-glib_gthread-posix.c
new file mode 100644
index 000000000000..3334a19ba25a
--- /dev/null
+++ b/devel/glib20/files/patch-glib_gthread-posix.c
@@ -0,0 +1,20 @@
+--- glib/gthread-posix.c.orig 2014-09-22 15:42:12.000000000 +0200
++++ glib/gthread-posix.c 2014-09-28 09:46:56.659280343 +0200
+@@ -98,7 +98,7 @@
+ if G_UNLIKELY (mutex == NULL)
+ g_thread_abort (errno, "malloc");
+
+-#ifdef PTHREAD_ADAPTIVE_MUTEX_INITIALIZER_NP
++#if defined(PTHREAD_ADAPTIVE_MUTEX_INITIALIZER_NP) && !defined(__FreeBSD__)
+ pthread_mutexattr_init (&attr);
+ pthread_mutexattr_settype (&attr, PTHREAD_MUTEX_ADAPTIVE_NP);
+ pattr = &attr;
+@@ -107,7 +107,7 @@
+ if G_UNLIKELY ((status = pthread_mutex_init (mutex, pattr)) != 0)
+ g_thread_abort (status, "pthread_mutex_init");
+
+-#ifdef PTHREAD_ADAPTIVE_MUTEX_NP
++#if defined(PTHREAD_ADAPTIVE_MUTEX_NP) && !defined(__FreeBSD__)
+ pthread_mutexattr_destroy (&attr);
+ #endif
+
diff --git a/devel/glib20/pkg-plist b/devel/glib20/pkg-plist
index afce3c3c61ac..75e403260288 100644
--- a/devel/glib20/pkg-plist
+++ b/devel/glib20/pkg-plist
@@ -1,6 +1,7 @@
bin/gapplication
bin/gdbus
bin/gdbus-codegen
+bin/gio
bin/gio-querymodules
bin/glib-compile-resources
bin/glib-compile-schemas
@@ -44,6 +45,7 @@ include/glib-2.0/gio/gconverter.h
include/glib-2.0/gio/gconverterinputstream.h
include/glib-2.0/gio/gconverteroutputstream.h
include/glib-2.0/gio/gcredentials.h
+include/glib-2.0/gio/gdatagrambased.h
include/glib-2.0/gio/gdatainputstream.h
include/glib-2.0/gio/gdataoutputstream.h
include/glib-2.0/gio/gdbusactiongroup.h
@@ -69,6 +71,9 @@ include/glib-2.0/gio/gdbusproxy.h
include/glib-2.0/gio/gdbusserver.h
include/glib-2.0/gio/gdbusutils.h
include/glib-2.0/gio/gdrive.h
+include/glib-2.0/gio/gdtlsclientconnection.h
+include/glib-2.0/gio/gdtlsconnection.h
+include/glib-2.0/gio/gdtlsserverconnection.h
include/glib-2.0/gio/gemblem.h
include/glib-2.0/gio/gemblemedicon.h
include/glib-2.0/gio/gfile.h
@@ -133,10 +138,10 @@ include/glib-2.0/gio/gsettingsbackend.h
include/glib-2.0/gio/gsettingsschema.h
include/glib-2.0/gio/gsimpleaction.h
include/glib-2.0/gio/gsimpleactiongroup.h
-include/glib-2.0/gio/gsimpleiostream.h
-include/glib-2.0/gio/gsimpleproxyresolver.h
include/glib-2.0/gio/gsimpleasyncresult.h
+include/glib-2.0/gio/gsimpleiostream.h
include/glib-2.0/gio/gsimplepermission.h
+include/glib-2.0/gio/gsimpleproxyresolver.h
include/glib-2.0/gio/gsocket.h
include/glib-2.0/gio/gsocketaddress.h
include/glib-2.0/gio/gsocketaddressenumerator.h
@@ -169,6 +174,7 @@ include/glib-2.0/gio/gvolume.h
include/glib-2.0/gio/gvolumemonitor.h
include/glib-2.0/gio/gzlibcompressor.h
include/glib-2.0/gio/gzlibdecompressor.h
+include/glib-2.0/glib/guuid.h
include/glib-2.0/glib-object.h
include/glib-2.0/glib-unix.h
include/glib-2.0/glib.h
@@ -293,14 +299,14 @@ lib/libgthread-2.0.a
lib/libgthread-2.0.so
lib/libgthread-2.0.so.0
lib/libgthread-2.0.so.%%LIBVERSION%%
-libdata/pkgconfig/gio-2.0.pc
-libdata/pkgconfig/gio-unix-2.0.pc
-libdata/pkgconfig/glib-2.0.pc
-libdata/pkgconfig/gmodule-2.0.pc
-libdata/pkgconfig/gmodule-export-2.0.pc
-libdata/pkgconfig/gmodule-no-export-2.0.pc
-libdata/pkgconfig/gobject-2.0.pc
-libdata/pkgconfig/gthread-2.0.pc
+lib/pkgconfig/gio-2.0.pc
+lib/pkgconfig/gio-unix-2.0.pc
+lib/pkgconfig/glib-2.0.pc
+lib/pkgconfig/gmodule-2.0.pc
+lib/pkgconfig/gmodule-export-2.0.pc
+lib/pkgconfig/gmodule-no-export-2.0.pc
+lib/pkgconfig/gobject-2.0.pc
+lib/pkgconfig/gthread-2.0.pc
man/man1/gapplication.1.gz
man/man1/gdbus-codegen.1.gz
man/man1/gdbus.1.gz
@@ -319,8 +325,10 @@ share/aclocal/glib-2.0.m4
share/aclocal/glib-gettext.m4
share/aclocal/gsettings.m4
share/bash-completion/completions/gapplication
-%%GDB%%share/gdb/auto-load/libglib-2.0.so.%%LIBVERSION%%-gdb.py
-%%GDB%%share/gdb/auto-load/libgobject-2.0.so.%%LIBVERSION%%-gdb.py
+share/gdb/auto-load/usr/local/lib/libglib-2.0.so.0.5200.0-gdb.py
+share/gdb/auto-load/usr/local/lib/libgobject-2.0.so.0.5200.0-gdb.py
+share/gettext/its/gschema.its
+share/gettext/its/gschema.loc
share/glib-2.0/codegen/__init__.py
share/glib-2.0/codegen/__init__.pyc
share/glib-2.0/codegen/__init__.pyo
@@ -345,10 +353,11 @@ share/glib-2.0/codegen/parser.pyo
share/glib-2.0/codegen/utils.py
share/glib-2.0/codegen/utils.pyc
share/glib-2.0/codegen/utils.pyo
-%%GDB%%share/glib-2.0/gdb/glib.py
-%%GDB%%share/glib-2.0/gdb/gobject.py
+share/glib-2.0/gdb/glib_gdb.py
+share/glib-2.0/gdb/gobject_gdb.py
share/glib-2.0/gettext/po/Makefile.in.in
share/glib-2.0/schemas/gschema.dtd
+share/glib-2.0/valgrind/glib.supp
share/locale/af/LC_MESSAGES/glib20.mo
share/locale/am/LC_MESSAGES/glib20.mo
share/locale/an/LC_MESSAGES/glib20.mo
@@ -380,7 +389,9 @@ share/locale/eu/LC_MESSAGES/glib20.mo
share/locale/fa/LC_MESSAGES/glib20.mo
share/locale/fi/LC_MESSAGES/glib20.mo
share/locale/fr/LC_MESSAGES/glib20.mo
+share/locale/fur/LC_MESSAGES/glib20.mo
share/locale/ga/LC_MESSAGES/glib20.mo
+share/locale/gd/LC_MESSAGES/glib20.mo
share/locale/gl/LC_MESSAGES/glib20.mo
share/locale/gu/LC_MESSAGES/glib20.mo
share/locale/he/LC_MESSAGES/glib20.mo