aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2013-10-03 02:25:44 +0800
committerantoine <antoine@FreeBSD.org>2013-10-03 02:25:44 +0800
commit868b667f05205683f62d6aea623c546ca931ca9f (patch)
treecc910a51d33756aee4175b114075bc6fb5cf733d /devel
parent35b79d1fd3990e2d2fd2b098fd1d12164425d706 (diff)
downloadfreebsd-ports-gnome-868b667f05205683f62d6aea623c546ca931ca9f.tar.gz
freebsd-ports-gnome-868b667f05205683f62d6aea623c546ca931ca9f.tar.zst
freebsd-ports-gnome-868b667f05205683f62d6aea623c546ca931ca9f.zip
Convert to STAGEDIR
Diffstat (limited to 'devel')
-rw-r--r--devel/libpff/Makefile20
-rw-r--r--devel/libpff/pkg-plist3
2 files changed, 11 insertions, 12 deletions
diff --git a/devel/libpff/Makefile b/devel/libpff/Makefile
index 177e9017ac29..e5ecd6700677 100644
--- a/devel/libpff/Makefile
+++ b/devel/libpff/Makefile
@@ -13,34 +13,30 @@ COMMENT= Library and tools to access the PFF and the OFF formats
LICENSE= LGPL3
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-python
+CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE} ${ICONV_CONFIGURE_ARG}
USES= gettext iconv pathfix
USE_PYTHON= -2.7
USE_LDCONFIG= yes
-
+# Remove when configure gets LDFLAGS for python correctly
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
-MAN1= pffexport.1 pffinfo.1
-MAN3= libpff.3
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
PORTDOCS= AUTHORS ChangeLog
PORTEXAMPLES= *
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS EXAMPLES
+
.include <bsd.port.options.mk>
post-install:
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.endif
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/${PORTNAME}/* \
- ${WRKSRC}/examples/${PORTNAME:S,lib,py,}/* ${EXAMPLESDIR}
+ ${WRKSRC}/examples/${PORTNAME:S,lib,py,}/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/libpff/pkg-plist b/devel/libpff/pkg-plist
index a87dc593f194..818ba11c7943 100644
--- a/devel/libpff/pkg-plist
+++ b/devel/libpff/pkg-plist
@@ -16,4 +16,7 @@ lib/libpff.so.1
%%PYTHON_SITELIBDIR%%/pypff.la
%%PYTHON_SITELIBDIR%%/pypff.so
libdata/pkgconfig/libpff.pc
+man/man1/pffexport.1.gz
+man/man1/pffinfo.1.gz
+man/man3/libpff.3.gz
@dirrm include/libpff